当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装wine1.1.26出错
帖子发表于 : 2009-08-06 10:44 

注册: 2009-08-06 10:42
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
代码:
[os@QiPengos wine-1.1.26]$ sudo ./configure
[sudo] password for os:
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for cpp... cpp
checking whether gcc -m32 works... no
configure: error: Cannot build a 32-bit program, you need to install 32-bit development libraries.

最后一行说要我安装32位库是什么意思,难道64位系统需要不同的源安装包吗?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装wine1.1.26出错
帖子发表于 : 2009-08-06 10:49 

注册: 2009-08-06 10:42
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
http://wiki.winehq.org/WineOn64bit有这么一段话:

代码:
Installing 32-bit Wine on a 64-bit system

If you just want to use Wine, there is no need to compile it using the instructions here. Just go to the downloads page and click the link for your distribution:

http://www.winehq.org/site/download

Building Wine on a 32-bit system

Has its own page Recommended Packages.

Building 64-bit Wine on a 64-bit system

Has its own page Wine64.

Building 32-bit Wine on a 64-bit (x86-64) system

To successfully build 32-bit Wine on 64-bit system your system needs 32-bit compatibility packages. These include: a compiler that can create 32-bit binaries, 32-bit development and runtime libraries, and development headers. To install them all, you can do it the easy way or the hard way:

(Note: Since the Linux world as well as Wine change daily, what works today might not work tomorrow. "Easy scripts" might not install everything that the latest Wine requires.)


快晕了,在64位机子上安装32位的wine还是64位的wine 更好?


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 安装wine1.1.26出错
帖子发表于 : 2009-08-06 12:02 
头像

注册: 2006-12-15 9:32
帖子: 1247
系统: linux
送出感谢: 2
接收感谢: 13
64位的系统运行32位的软件需要32位软件的相关支持,wine貌似并非真正的64位原生程序,只是兼容64位,因此需要在64位系统下安装32位的相应支持程序。
而且64位的系统没法安32位的wine


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 安装wine1.1.26出错
帖子发表于 : 2009-08-06 12:04 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
wine 只有 32 位的, 参考官网上的 build 指南


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 安装wine1.1.26出错
帖子发表于 : 2009-11-01 13:02 

注册: 2009-08-01 13:19
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
that means you have to install the need libraries for a ia32 development.


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 安装wine1.1.26出错
帖子发表于 : 2009-11-01 13:10 

注册: 2009-08-01 13:19
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
I happened to meet the same problem with you, and the url below would certainly be helpful

http://wiki.ubuntu.org.cn/UbuntuWiki:In ... gCompilers

Whats more the ibus input utiliy is out of work in my kubuntu 9.10 and that's why I could only use english. :em06


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 安装wine1.1.26出错
帖子发表于 : 2009-11-01 13:11 

注册: 2009-08-01 13:19
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
http://wiki.ubuntu.org.cn/UbuntuWiki:In ... gCompilers


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译