当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 关于更新、公钥的问题
帖子发表于 : 2009-08-09 17:49 

注册: 2009-03-30 13:06
帖子: 65
送出感谢: 0 次
接收感谢: 0 次
每次更新都会提示这些信息,昨天想升级firefox的,打算先卸载再装的,结果卸载后就装不了了,新立得也下载不了
提示的都是下面这些信息,谁来救救我?
我知道大概是什么密码之类的问题,不过不知道怎么弄了



W: GPG签名验证错误: http://ubuntu.cn99.com jaunty Release: 由于没有公钥,下列签名无法进行验证: NO_PUBKEY 40976EAF437D05B5
W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://ubuntu.cn99.com jaunty-updates Release: 由于没有公钥,下列签名无法进行验证: NO_PUBKEY 40976EAF437D05B5

W: GPG签名验证错误: http://archive.canonical.com jaunty Release: 由于没有公钥,下列签名无法进行验证: NO_PUBKEY 40976EAF437D05B5
W: GPG签名验证错误: http://mirror.noreply.org etch Release: 由于没有公钥,下列签名无法进行验证: NO_PUBKEY CFF71CB3AFA44BDD
W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://ubuntu.cn99.com jaunty-security Release: 由于没有公钥,下列签名无法进行验证: NO_PUBKEY 40976EAF437D05B5

W: 无法下载 cdrom://Ubuntu 9.04 _Jaunty Jackalope_ - Release i386 (20090420.1)/dists/jaunty/main/binary-i386/Packages 请使用 apt-cdrom,通过它就可以让 APT 能识别该光盘。apt-get upgdate 不能被用来加入新的光盘。

W: 无法下载 cdrom://Ubuntu 9.04 _Jaunty Jackalope_ - Release i386 (20090420.1)/dists/jaunty/restricted/binary-i386/Packages 请使用 apt-cdrom,通过它就可以让 APT 能识别该光盘。apt-get upgdate 不能被用来加入新的光盘。

W: 无法下载 http://ubuntu.cn99.com/ubuntu/dists/jau ... es/Release

W: 无法下载 http://ubuntu.cn99.com/ubuntu/dists/jau ... ty/Release

W: 无法下载 http://ppa.launchpad.net/kUbuntu-experi ... 6/Packages 404 Not Found

W: 有一些索引文件不能下载,它们可能被忽略了,也可能转而使用了旧的索引文件。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 关于更新、公钥的问题
帖子发表于 : 2009-08-09 18:17 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
换一个源试试, 之前做过什么了?

官方的公钥应该默认有添加的


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 关于更新、公钥的问题
帖子发表于 : 2009-08-09 18:27 

注册: 2009-03-30 13:06
帖子: 65
送出感谢: 0 次
接收感谢: 0 次
先前装了些软件,都是网上找的教程所的,都只是添加源,没有动过系统里面默认的源

不知道怎么回事,现在连firefox都装不了了,

有没有方法恢复到默认的源的状态?

我没有备份的


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 关于更新、公钥的问题
帖子发表于 : 2009-10-16 14:19 
头像

注册: 2009-03-19 9:19
帖子: 1423
地址: 江苏
送出感谢: 0 次
接收感谢: 2
os: ubuntu 9.04

sudo apt-get update
W: GPG 签名验证错误: http://mirror.noreply.org/ jaunty Release: 由于没有公钥,下列签名无法进行验证: NO_PUBKEY CFF71CB3AFA44BDD

$ gpg --keyserver keys.gnupg.net --recv AFA44BDD
gpg: 下载密钥‘AFA44BDD’,从 hkp 服务器 keys.gnupg.net
gpg: 密钥 94C09C7F:公钥“Peter Palfrader”已导入
gpg: 没有找到任何绝对信任的密钥
gpg: 合计被处理的数量:1
gpg: 已导入:1


$ gpg --export --armor AFA44BDD | sudo apt-key add -

如果是缺少其他公钥,只要修改公钥最后8位就可以了。


_________________


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 关于更新、公钥的问题
帖子发表于 : 2009-10-25 1:17 
头像

注册: 2008-05-10 14:12
帖子: 43
地址: 广工__龙洞
送出感谢: 0 次
接收感谢: 0 次
mark,成功


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译