当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : kqemu安装失败
帖子发表于 : 2009-08-16 18:47 
头像

注册: 2009-04-18 18:30
帖子: 119
送出感谢: 1
接收感谢: 0 次
kqemu安装失败
按照http://forum.ubuntu.org.cn/viewtopic.php?f=65&t=46999的方法安装,第一步就失败
代码:
$ sudo apt-get install qemu kernel-package linux-source kqemu-source build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
build-essential 已经是最新的版本了。
build-essential 被设置为手动安装。
将会安装下列额外的软件包:
  bochsbios debootstrap dkms fakeroot libvdemgmt0 libvdeplug2
  linux-source-2.6.28 sharutils vde2 vgabios
建议安装的软件包:
  libdb3-dev libncurses-dev docbook-utils xmlto libqt3-dev samba mailx
  vde2-cryptcab kvm
推荐安装的软件包:
  proll openhackware openbios-sparc
下列【新】软件包将被安装:
  bochsbios debootstrap dkms fakeroot kernel-package kqemu-source libvdemgmt0
  libvdeplug2 linux-source linux-source-2.6.28 qemu sharutils vde2 vgabios
共升级了 0 个软件包,新安装了 14 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 72.9MB/73.1MB 的软件包。
解压缩后会消耗掉 108MB 的额外空间。
您希望继续执行吗?[Y/n]y
获取:1 http://ftp.sjtu.edu.cn jaunty/main kernel-package 11.015 [537kB]
获取:2 http://ftp.sjtu.edu.cn jaunty/universe kqemu-source 1.4.0~pre1-1ubuntu3 [91.3kB]
获取:3 http://ftp.sjtu.edu.cn jaunty/universe libvdemgmt0 2.2.2-3ubuntu1 [12.7kB]
获取:4 http://ftp.sjtu.edu.cn jaunty/universe libvdeplug2 2.2.2-3ubuntu1 [11.9kB]
获取:5 http://ftp.sjtu.edu.cn jaunty-proposed/main linux-source-2.6.28 2.6.28-15.48 [56.9MB]
获取:6 http://ftp.sjtu.edu.cn jaunty-proposed/main linux-source 2.6.28.15.20 [3520B]                                                         
获取:7 http://ftp.sjtu.edu.cn jaunty/universe vgabios 0.6b-1 [79.0kB]                                                                       
获取:8 http://ftp.sjtu.edu.cn jaunty/universe bochsbios 2.3.7-1ubuntu1 [155kB]                                                               
获取:9 http://ftp.sjtu.edu.cn jaunty/universe qemu 0.10.0-1ubuntu1 [14.8MB]                                                                 
获取:10 http://ftp.sjtu.edu.cn jaunty/main sharutils 1:4.6.3-1build1 [108kB]                                                                 
获取:11 http://ftp.sjtu.edu.cn jaunty/universe vde2 2.2.2-3ubuntu1 [183kB]                                                                   
获取:12 http://ftp.sjtu.edu.cn jaunty-backports/main debootstrap 1.0.13~jaunty1 [52.3kB]                                                     
下载 72.9MB,耗时 57s (1276kB/s)                                                                                                             
选中了曾被取消选择的软件包 dkms。
(正在读取数据库 ... 系统当前总共安装有 178150 个文件和目录。)
正在解压缩 dkms (从 .../dkms_2.0.21.1-0ubuntu3_all.deb) ...
选中了曾被取消选择的软件包 fakeroot。
正在解压缩 fakeroot (从 .../fakeroot_1.12.1ubuntu1_i386.deb) ...
选中了曾被取消选择的软件包 kernel-package。
正在解压缩 kernel-package (从 .../kernel-package_11.015_all.deb) ...
选中了曾被取消选择的软件包 kqemu-source。
正在解压缩 kqemu-source (从 .../kqemu-source_1.4.0~pre1-1ubuntu3_all.deb) ...
选中了曾被取消选择的软件包 libvdemgmt0。
正在解压缩 libvdemgmt0 (从 .../libvdemgmt0_2.2.2-3ubuntu1_i386.deb) ...
选中了曾被取消选择的软件包 libvdeplug2。
正在解压缩 libvdeplug2 (从 .../libvdeplug2_2.2.2-3ubuntu1_i386.deb) ...
选中了曾被取消选择的软件包 linux-source-2.6.28。
正在解压缩 linux-source-2.6.28 (从 .../linux-source-2.6.28_2.6.28-15.48_all.deb) ...
选中了曾被取消选择的软件包 linux-source。
正在解压缩 linux-source (从 .../linux-source_2.6.28.15.20_all.deb) ...
选中了曾被取消选择的软件包 vgabios。
正在解压缩 vgabios (从 .../vgabios_0.6b-1_all.deb) ...
选中了曾被取消选择的软件包 bochsbios。
正在解压缩 bochsbios (从 .../bochsbios_2.3.7-1ubuntu1_all.deb) ...
选中了曾被取消选择的软件包 qemu。
正在解压缩 qemu (从 .../qemu_0.10.0-1ubuntu1_i386.deb) ...
选中了曾被取消选择的软件包 sharutils。
正在解压缩 sharutils (从 .../sharutils_1%3a4.6.3-1build1_i386.deb) ...
选中了曾被取消选择的软件包 vde2。
正在解压缩 vde2 (从 .../vde2_2.2.2-3ubuntu1_i386.deb) ...
选中了曾被取消选择的软件包 debootstrap。
正在解压缩 debootstrap (从 .../debootstrap_1.0.13~jaunty1_all.deb) ...
正在处理用于 man-db 的触发器...
正在处理用于 doc-base 的触发器...
Processing 1 added doc-base file(s)...
Registering documents with scrollkeeper...
正在设置 dkms (2.0.21.1-0ubuntu3) ...
 * Running DKMS auto installation service for kernel 2.6.28-12-generic                                                                  [ OK ]

正在设置 fakeroot (1.12.1ubuntu1) ...

正在设置 kernel-package (11.015) ...
正在设置 kqemu-source (1.4.0~pre1-1ubuntu3) ...
正在添加组 'kqemu' (GID 125)...
完成。
 * Reloading kernel event manager...                                                                                                    [ OK ]
Adding Module to DKMS build system
Doing initial module build

Error! Your kernel source for kernel 2.6.28-12-generic cannot be found at
/lib/modules/2.6.28-12-generic/build or /lib/modules/2.6.28-12-generic/source.
Installing initial module

Error! Could not locate kqemu.ko for module kqemu in the DKMS tree.
You must run a dkms build for kernel 2.6.28-12-generic (i686) first.
Done.
FATAL: Module kqemu not found.
 * Module kqemu failed to load
invoke-rc.d: initscript kqemu-source, action "start" failed.
dpkg:处理 kqemu-source (--configure)时出错:
 子进程 post-installation script 返回了错误号 1
正在设置 libvdemgmt0 (2.2.2-3ubuntu1) ...

正在设置 libvdeplug2 (2.2.2-3ubuntu1) ...

正在设置 linux-source-2.6.28 (2.6.28-15.48) ...
正在设置 linux-source (2.6.28.15.20) ...
正在设置 vgabios (0.6b-1) ...
正在设置 bochsbios (2.3.7-1ubuntu1) ...
正在设置 qemu (0.10.0-1ubuntu1) ...

正在设置 sharutils (1:4.6.3-1build1) ...

正在设置 vde2 (2.2.2-3ubuntu1) ...

正在设置 debootstrap (1.0.13~jaunty1) ...
正在处理用于 libc6 的触发器...
ldconfig deferred processing now taking place
在处理时有错误发生:
 kqemu-source
E: Sub-process /usr/bin/dpkg returned an error code (1)

现在不管安装什么软件包都会出现:
代码:
正在设置 kqemu-source (1.4.0~pre1-1ubuntu3) ...
 * Reloading kernel event manager...                                     [ OK ]
Adding Module to DKMS build system

Error! DKMS tree already contains: kqemu-1.4.0~pre1
You cannot add the same module/version combo more than once.
Doing initial module build

Error! Your kernel source for kernel 2.6.28-12-generic cannot be found at
/lib/modules/2.6.28-12-generic/build or /lib/modules/2.6.28-12-generic/source.
Installing initial module

Error! Could not locate kqemu.ko for module kqemu in the DKMS tree.
You must run a dkms build for kernel 2.6.28-12-generic (i686) first.
Done.
FATAL: Module kqemu not found.
 * Module kqemu failed to load
invoke-rc.d: initscript kqemu-source, action "start" failed.
dpkg:处理 kqemu-source (--configure)时出错:
 子进程 post-installation script 返回了错误号 1
正在设置 2vcard (0.5-3) ...
在处理时有错误发生:
 kqemu-source
E: Sub-process /usr/bin/dpkg returned an error code (1)


页首
 用户资料  
 
2 楼 
 文章标题 : Re: kqemu安装失败
帖子发表于 : 2009-08-16 18:49 
头像

注册: 2009-04-18 18:30
帖子: 119
送出感谢: 1
接收感谢: 0 次
各位高手帮帮我,就算不能安装也要把总是出现“正在设置 kqemu-source (1.4.0~pre1-1ubuntu3) ...“的问题修复啊


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译