当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 于是想装一个.tar.gz软件包但是不会装- -各位能否告下怎么安装
帖子发表于 : 2009-08-20 11:35 
头像

注册: 2008-07-02 9:03
帖子: 37
地址: Dark temple
送出感谢: 0 次
接收感谢: 0 次
RT
下载了一个dssi-vst软件包准备安装(见附件),但是现在只会安装.deb格式的,于是就这样N个.tar.gz软件包从偶身旁擦肩而过 :em49 - -

于是各位高手请告下怎么安装.tar.gz的软件包- -在此严重感谢了 :em09


附件:
dssi-1.0.0.tar.gz [397.41 KiB]
被下载 17 次
页首
 用户资料  
 
2 楼 
 文章标题 : Re: 于是想装一个.tar.gz软件包但是不会装- -各位能否告下怎么安装
帖子发表于 : 2009-08-20 11:36 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
看解压出来的readme or install文件


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 于是想装一个.tar.gz软件包但是不会装- -各位能否告下怎么安装
帖子发表于 : 2009-08-20 11:37 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
没法说,上百上千种。


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 于是想装一个.tar.gz软件包但是不会装- -各位能否告下怎么安装
帖子发表于 : 2009-08-20 11:41 
头像

注册: 2008-02-12 19:47
帖子: 262
送出感谢: 0 次
接收感谢: 0 次
在编译环境(apt-get install build-essential)安好的情况下,一般步骤都是解包后./configure(如果存在configure文件),然后make,再make install。当然具体的要看readme文件。
看了下INSTALL文件,照上面的步骤来就行的样子


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 于是想装一个.tar.gz软件包但是不会装- -各位能否告下怎么安装
帖子发表于 : 2009-08-22 17:41 
头像

注册: 2008-07-02 9:03
帖子: 37
地址: Dark temple
送出感谢: 0 次
接收感谢: 0 次
LS :em01 LSS :em01 LSSS :em01 各位高人的帮助收到- -已经照你们的说解开.tar.gz文件了但是cd解压缩的文件之后然后看readme文件先/configure之后make不能- -如下- -

zhou2629@zhou2629-dell:~$ cd /home/zhou2629/桌面/dssi-1.0.0
zhou2629@zhou2629-dell:~/桌面/dssi-1.0.0$ /configure
bash: /configure: 没有该文件或目录
zhou2629@zhou2629-dell:~/桌面/dssi-1.0.0$ /home/zhou2629/桌面/dssi-1.0.0/configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for ar... ar
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking whether we are using the GNU C++ compiler... (cached) yes
checking whether g++ accepts -g... (cached) yes
checking dependency style of g++... (cached) gcc3
checking how to run the C++ preprocessor... g++ -E
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking for ld used by g++... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking whether the g++ linker (/usr/bin/ld) supports shared libraries... yes
checking for g++ option to produce PIC... -fPIC -DPIC
checking if g++ PIC flag -fPIC -DPIC works... yes
checking if g++ static flag -static works... yes
checking if g++ supports -c -o file.o... yes
checking if g++ supports -c -o file.o... (cached) yes
checking whether the g++ linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether ln -s works... yes
checking whether byte ordering is bigendian... no
checking ladspa.h usability... yes
checking ladspa.h presence... yes
checking for ladspa.h... yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for ALSA... no
checking for ALSA... no
configure: error: neither ALSA nor libdssialsacompat found
zhou2629@zhou2629-dell:~/桌面/dssi-1.0.0$

- -在此之后就不会make了- -貌似是ALSA的问题- -装的ubunut studio的所有软件貌似但是很能听到音乐不是驱动和声卡的问题(偶用的DELL的笔记本) :em06 求接下来该咋办- -

- -README内容参上:
DSSI
----

This is the DSSI Soft Synth Interface specification & example
code repository.

You'll find here:

doc/RFC.txt -- proposed DSSI specification -- read this first

dssi/dssi.h -- DSSI header file -- the comments define those parts
of the spec dealing with host/plugin interaction (not covered in RFC)

jack-dssi-host/jack-dssi-host.c -- a simple JACK/ALSA-sequencer plugin host

examples/dssi_osc_send.c
examples/dssi_osc_update.c -- simple DSSI OSC test programs

examples/trivial_synth.c -- a quite useless but fairly clear
illustrative synth plugin

examples/less_trivial_synth.c -- a synth that actually does some
basic synthesis

examples/less_trivial_synth_qt_gui.cpp -- a very simple Qt GUI
for the above

examples/karplong.cpp -- a simple Karplus+Strong plucked string synth

examples/trivial_sampler.c -- a simple one-sample polyphonic
mono sampler (that doesn't do proper pitch scaling)

examples/trivial_sampler_qt_gui.cpp -- a very simple Qt GUI for
the above


Requirements
------------

In order to install the development files (dssi.h and dssi.pc)
needed to compile DSSI applications, you only need the following:

pkgconfig with PKG_CONFIG_PATH set appropriately
ALSA 0.9/1.0.x (or libdssialsacompat: see
http://smbolton.com/linux.html)
LADSPA SDK 1.x

To build the included host and plugins, you will also need:

JACK
liblo-0.12 or above: http://liblo.sourceforge.net/
libsndfile: http://www.mega-nerd.com/libsndfile/
libsamplerate: http://www.mega-nerd.com/SRC/

To build the less_trivial_synth and trivial_sampler Qt GUIs, you
will need:

Qt 3

Note that because DSSI itself is just an API, it is possible to use
DSSI applications (say, Rosegarden with Xsynth-DSSI) without any of
the hosts or plugins contained in this DSSI distribution.
Furthermore, to compile DSSI applications, only the DSSI development
files (dssi.h and dssi.pc) are needed. OS distribution maintainers
are urged to keep these dependencies in mind when packaging DSSI,
and not make their `dssi-devel' package dependent on JACK or Qt, for
example.

Build
-----

DSSI can be installed using the usual autoconf/automake `./configure
&& make && make install' procedure. See the included file INSTALL
for generic installation instructions.

You will need to ensure PKG_CONFIG_PATH is set correctly to locate
the pkgconfig files for ALSA or libdssialsacompat, liblo, JACK,
sndfile, and samplerate. You may also need to set the QTDIR and/or
QTINCDIR variables to point to your Qt installation. If you do not
have any of these, any DSSI programs or plugins dependent on them
will not be built.

For example, to build on Debian I use:

$ QTDIR=/usr
$ QTINCDIR=/usr/include/qt3
$ PKG_CONFIG_PATH=/usr/lib/pkgconfig
$ export QTDIR QTINCDIR PKG_CONFIG_PATH
$ ./configure
$ make && make check

After compiling, optionally test the host and example plugins (see
below) and then run `make install' from the top-level directory to
install the dssi header, dssi.pc pkgconfig file, and the host and
examples. The default install prefix is /usr/local.

Test
----

The quickest test (provided your system has all the required
software, you've done `make install', and JACK is running) is just
to run `less_trivial_synth' or `trivial_sampler', which should have
been installed in your $PREFIX/bin. These should simply start up a
standalone sampler/synth with a GUI window. If these both work,
pretty much everything else should.

Here's a more descriptive test:

Assuming you've built the host and plugins, installed them to
/usr/local, and JACK is running, you may run:

$ export DSSI_PATH=/usr/local/lib/dssi
$ /usr/local/bin/jack-dssi-host less_trivial_synth.so

A synth GUI should pop up, with an ALSA sequencer input and JACK
output (connected by default to the first alsa_pcm out). If you
connect a MIDI keyboard (or vkeybd) to its ALSA MIDI input, you should
be able to play it and use MIDI controllers to adjust its parameters:
MIDI CC1 (the modulation wheel) controls timbre, and controllers 72,
73, 75 and 79 control release, attack, decay and sustain respectively
(some keyboards already have controls set up for these values).

What has actually happened (if it worked) is that the host has
been started, has loaded the first synth plugin (labelled LTS) found
in the given .so file, has located the GUI executable that the make
procedure installed into examples/less_trivial_synth/LTS_qt,
instantiated the plugin, started the GUI and is now managing the MIDI
input from ALSA, control changes from the GUI and audio out to JACK.

You may also run multiple synth instances simultaneously with this
host:

$ export DSSI_PATH=/usr/local/lib/dssi
$ export PATH=$PATH:/usr/local/bin # if it's not there already
$ jack-dssi-host -2 less_trivial_synth.so -3 trivial_sampler.so

This will create two less_trivial_synth instances and three
trivial_sampler instances. Note that the instances are assigned
consecutive MIDI channels, and their outputs are spread across all
of the available JACK physical outputs.


Licensing
---------

The DSSI API itself (dssi.h) is licensed under the GNU Lesser General
Public License. See COPYING for details.

The jack-dssi-host is provided under a BSD-style license. This means
you can do anything you want with it so long as you retain the
copyright attribution and license information. See the source files
for details.

Licensing for the files in the examples directory may vary: please
check the individual files for details. Most of them are in the
public domain, which means you can use them for anything you want.


_________________
ubuntu studio 9.04 use——Welcome baidu ubuntu studio club.

关于艺术(Artist),无论使用ubuntu studio还是那个囧雷的windows vista,只要linuxer的信条融入到灵魂即可


最后由 zhou2629 编辑于 2009-08-22 17:45,总共编辑了 1 次

页首
 用户资料  
 
6 楼 
 文章标题 : Re: 于是想装一个.tar.gz软件包但是不会装- -各位能否告下怎么安装
帖子发表于 : 2009-08-22 17:45 
头像

注册: 2009-06-05 18:13
帖子: 694
送出感谢: 0 次
接收感谢: 0 次
你需要如下软件包:
Requirements
------------

In order to install the development files (dssi.h and dssi.pc)
needed to compile DSSI applications, you only need the following:

pkgconfig with PKG_CONFIG_PATH set appropriately
ALSA 0.9/1.0.x (or libdssialsacompat: see
http://smbolton.com/linux.html)
LADSPA SDK 1.x

To build the included host and plugins, you will also need:

JACK
liblo-0.12 or above: http://liblo.sourceforge.net/
libsndfile: http://www.mega-nerd.com/libsndfile/
libsamplerate: http://www.mega-nerd.com/SRC/

=================
只有上述的依赖包全部安装后,才能安装成功!!相应的网址也已经告诉你了!!
good luck!


_________________
==========================
我的博客地址:http://blog.163.com/fanglinyong_81
这里记录了我学习使用ubuntu中遇到的诸多问题,希望整理出来,供网友参考,也希望各位能提出不同的解决方法!

==========================
system:ubuntu9.04
firefox3.5.2
CPU:AMD Sempron(tm) 2500+
DDR:1G

==========================


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 于是想装一个.tar.gz软件包但是不会装- -各位能否告下怎么安装
帖子发表于 : 2009-08-22 17:49 
头像

注册: 2008-07-02 9:03
帖子: 37
地址: Dark temple
送出感谢: 0 次
接收感谢: 0 次
ubuntu_fang 写道:
你需要如下软件包:
Requirements
------------

In order to install the development files (dssi.h and dssi.pc)
needed to compile DSSI applications, you only need the following:

pkgconfig with PKG_CONFIG_PATH set appropriately
ALSA 0.9/1.0.x (or libdssialsacompat: see
http://smbolton.com/linux.html)
LADSPA SDK 1.x

To build the included host and plugins, you will also need:

JACK
liblo-0.12 or above: http://liblo.sourceforge.net/
libsndfile: http://www.mega-nerd.com/libsndfile/
libsamplerate: http://www.mega-nerd.com/SRC/

=================
只有上述的依赖包全部安装后,才能安装成功!!相应的网址也已经告诉你了!!
good luck!


于是先行感谢 :em09


_________________
ubuntu studio 9.04 use——Welcome baidu ubuntu studio club.

关于艺术(Artist),无论使用ubuntu studio还是那个囧雷的windows vista,只要linuxer的信条融入到灵魂即可


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 于是想装一个.tar.gz软件包但是不会装- -各位能否告下怎么安装
帖子发表于 : 2009-08-22 17:54 
头像

注册: 2009-06-05 18:13
帖子: 694
送出感谢: 0 次
接收感谢: 0 次
zhou2629 写道:
ubuntu_fang 写道:
你需要如下软件包:
Requirements
------------

In order to install the development files (dssi.h and dssi.pc)
needed to compile DSSI applications, you only need the following:

pkgconfig with PKG_CONFIG_PATH set appropriately
ALSA 0.9/1.0.x (or libdssialsacompat: see
http://smbolton.com/linux.html)
LADSPA SDK 1.x

To build the included host and plugins, you will also need:

JACK
liblo-0.12 or above: http://liblo.sourceforge.net/
libsndfile: http://www.mega-nerd.com/libsndfile/
libsamplerate: http://www.mega-nerd.com/SRC/

=================
只有上述的依赖包全部安装后,才能安装成功!!相应的网址也已经告诉你了!!
good luck!


于是先行感谢 :em09

以后建议楼主解压缩tar包后,多多看看里面的安装说明文件,一般都是readme或者install之类的文本文件!!
先安装依赖的软件包,才能保证一次安装成功,要不得走弯路!


_________________
==========================
我的博客地址:http://blog.163.com/fanglinyong_81
这里记录了我学习使用ubuntu中遇到的诸多问题,希望整理出来,供网友参考,也希望各位能提出不同的解决方法!

==========================
system:ubuntu9.04
firefox3.5.2
CPU:AMD Sempron(tm) 2500+
DDR:1G

==========================


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译