当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : “su - 用户名a “提示找不到命令
帖子发表于 : 2009-08-26 10:42 

注册: 2008-09-05 21:36
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
su - 用户名a 提示找不到命令,但仍切换到了用户名a下,去掉“-”就不提示
root@gw:~# su - informix
:找不到命令
informix@gw:~$

informix@gw:~$ su -
口令:
:找不到命令
root@gw:~#

root@gw:~# su informix
informix@gw:/root$

informix@gw:/root$ su
口令:
root@gw:~#

使用source命令时,也提示找不到命令
root@gw:~# source /etc/profile
:找不到命令

我以前装的8.04,这些都是正确的,换到9.04就出现上述问题


页首
 用户资料  
 
2 楼 
 文章标题 : Re: “su - 用户名a “提示找不到命令
帖子发表于 : 2009-08-26 10:51 
头像

注册: 2008-02-17 23:47
帖子: 22109
地址: 美丽富饶的那啥星球
送出感谢: 11
接收感谢: 82
代码:
su <用户名>


_________________
明天就换大三八!
——8核CPU、8G内存、8T硬盘……
8卡交火,80寸大屏放8个……
IPv8的光纤要8条……

---------------------------------------------------------------------------------
[图片版]新手当自强(续)FAQ
[新手进阶]挂载、fstab、调整linux分区
[图片版]E17桌面环境配置手把手


页首
 用户资料  
 
3 楼 
 文章标题 : Re: “su - 用户名a “提示找不到命令
帖子发表于 : 2009-08-26 10:53 

注册: 2009-07-05 19:36
帖子: 848
送出感谢: 0 次
接收感谢: 0 次
:em04 “-” 是个符号。。。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: “su - 用户名a “提示找不到命令
帖子发表于 : 2009-08-26 10:54 

注册: 2009-07-05 19:36
帖子: 848
送出感谢: 0 次
接收感谢: 0 次
xxx@xxx-desktop:~$ su - xxx
口令:
xxx@xxx-desktop:~$

可以啊。。。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: “su - 用户名a “提示找不到命令
帖子发表于 : 2009-08-26 11:11 

注册: 2009-08-26 11:09
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
我试的没问题啊


页首
 用户资料  
 
6 楼 
 文章标题 : Re: “su - 用户名a “提示找不到命令
帖子发表于 : 2009-08-26 12:14 

注册: 2008-09-05 21:36
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
原来是我的/etc/profile里的一句有问题,真奇怪,我把他删除后重新写了一遍就好了,莫名其妙的,一个字都没改


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译