当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu9。04无声
帖子发表于 : 2009-09-01 22:52 

注册: 2009-08-16 16:47
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
ubuntu9.04 惠普康柏笔记本
笔记本的音响没声音,开机时只有耳机有声音。
已经找了很久试了很多方法还是不行。
知道如何解决的请指教


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu9。04无声
帖子发表于 : 2009-09-01 22:56 
头像

注册: 2008-04-14 23:29
帖子: 2114
地址: 曾也在NB大学呆过
送出感谢: 3
接收感谢: 10
把耳机拔了。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu9。04无声
帖子发表于 : 2009-09-01 23:01 

注册: 2009-08-16 16:47
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
。。。。。
自然是已经试过把耳机拔了,但也没声音


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu9。04无声
帖子发表于 : 2009-09-01 23:08 
头像

注册: 2009-08-11 14:16
帖子: 84
地址: http://www.ihacklog.com
送出感谢: 0 次
接收感谢: 1
zpw_0130 写道:
ubuntu9.04 惠普康柏笔记本
笔记本的音响没声音,开机时只有耳机有声音。
已经找了很久试了很多方法还是不行。
知道如何解决的请指教

终端下命令: sudo gedit /etc/modprobe.d/alsa-base.conf

找到文档底部很多options的地方,填入以下内容:

代码:
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=laptop
options snd-hda-intel enable_msi=1

保存后退出,重启Ubuntu应该就能听到声音了。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ubuntu9。04无声
帖子发表于 : 2009-09-01 23:18 

注册: 2009-08-16 16:47
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
补充下,执行aplay -l后显示



**** PLAYBACK硬件设备列表 ****
卡 0: SB [HDA ATI SB], 设备 0: STAC92xx Analog [STAC92xx Analog]
子设备: 1/1
子设备:#0: subdevice #0
卡 0: SB [HDA ATI SB], 设备 1: STAC92xx Digital [STAC92xx Digital]
子设备: 1/1
子设备:#0: subdevice #0
卡 1: HDMI [HDA ATI HDMI], 设备 3: ATI HDMI [ATI HDMI]
子设备: 1/1
子设备:#0: subdevice #0


页首
 用户资料  
 
6 楼 
 文章标题 : Re: ubuntu9。04无声
帖子发表于 : 2009-09-01 23:36 
头像

注册: 2009-08-11 14:16
帖子: 84
地址: http://www.ihacklog.com
送出感谢: 0 次
接收感谢: 1
你用耳机可以听到声音,说明系统能正确识别你的声卡.
我也是HP的笔记本,用以上方法后解决的内置音响不能出声的问题.
希望以上方法能对你有所帮助.


_________________
代码:
$荒野无灯=new PHPer();

http://www.ihacklog.com


页首
 用户资料  
 
7 楼 
 文章标题 : Re: ubuntu9。04无声
帖子发表于 : 2009-09-01 23:54 

注册: 2009-08-16 16:47
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
6 楼,我用你说的方法也还是不行。。。。
还有谁知道吗???


页首
 用户资料  
 
8 楼 
 文章标题 : Re: ubuntu9。04无声
帖子发表于 : 2009-09-02 0:39 

注册: 2008-06-18 11:01
帖子: 123
送出感谢: 0 次
接收感谢: 0 次
是不是外接的都有声音?只有内置的没有声音?


页首
 用户资料  
 
9 楼 
 文章标题 : Re: ubuntu9。04无声
帖子发表于 : 2009-09-08 10:43 
头像

注册: 2009-08-11 14:16
帖子: 84
地址: http://www.ihacklog.com
送出感谢: 0 次
接收感谢: 1
zpw_0130 写道:
6 楼,我用你说的方法也还是不行。。。。
还有谁知道吗???

你用的是9.04是吧?
一般是可以的,上面的代码可能还要修改一下,具体解决办法在我笔记本里,现在我没用笔记本上网,过几天我把那个解决办法发上来,我就是用那个方法,成功让内置音响发声的。


_________________
代码:
$荒野无灯=new PHPer();

http://www.ihacklog.com


页首
 用户资料  
 
10 楼 
 文章标题 : Re: ubuntu9。04无声
帖子发表于 : 2009-09-08 10:52 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
有没有试试按笔记本自带的音量调节按钮?


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
11 楼 
 文章标题 : Re: ubuntu9。04无声
帖子发表于 : 2009-09-09 12:53 
头像

注册: 2009-08-11 14:16
帖子: 84
地址: http://www.ihacklog.com
送出感谢: 0 次
接收感谢: 1
笔记本内置的音响没声音,开机时只有耳机有声音。也就是说声卡已经能被系统正确识别(因为耳机有声音),但是内置的音响不发声。
以下方法在ubuntu9.04 + HP probook 4311s 下测试通过。
解决办法如下:
代码:
sudo gedit /etc/modprobe.d/alsa-base.conf

在文件最后增加以下内容:
代码:
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=laptop
options snd-hda-intel enable_msi=1
options snd_hda_intel model=laptop



修改保存之后重新启动笔记本,如果还是不有声音,则:
在终端依次输入一下命令

代码:
d ~
mkdir src
cd src
mkdir alsa
cd alsa
wget ftp://ftp.kernel.org/pub/linux/kernel/people/tiwai/snapshot/alsa-driver-snapshot.tar.gz
tar -xvfp alsa-driver-snapshot.tar.gz
cd alsa-driver
sudo ./configure
sudo make
sudo make install-modules
sudo reboot


ftp://ftp.kernel.org/pub/linux/kernel/p ... hot.tar.gz如果在bash里不能下载就用浏览器下载吧


_________________
代码:
$荒野无灯=new PHPer();

http://www.ihacklog.com


页首
 用户资料  
 
12 楼 
 文章标题 : Re: ubuntu9。04无声
帖子发表于 : 2009-11-03 20:29 

注册: 2009-10-22 23:42
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
works pretty well, thank you very much!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译