当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu9.10装VirtualBox3.0.4失败,依赖关系没有满足?
帖子发表于 : 2009-09-04 8:46 
头像

注册: 2009-08-14 16:24
帖子: 314
送出感谢: 0 次
接收感谢: 0 次
file:///home/angel/%E6%A1%8C%E9%9D%A2/Screenshot-%E8%BD%AF%E4%BB%B6%E5%8C%85%E5%AE%89%E8%A3%85%20-%20virtualbox-3.0.png
如图,然后我在终端中尝试:
angel@BlackAngel:~$ sudo dpkg -i VirtualBox.deb 《——键入内容
[sudo] password for angel:
选中了曾被取消选择的软件包 virtualbox-3.0。
(正在读取数据库 ... 系统当前总共安装有 106213 个文件和目录。)
正在解压缩 virtualbox-3.0 (从 VirtualBox.deb) ...
dpkg:依赖关系问题使得 virtualbox-3.0 的配置工作不能继续:
virtualbox-3.0 依赖于 libcurl3 (>= 7.16.2-1);然而:
未曾安装软件包“libcurl3”。
virtualbox-3.0 依赖于 libqt4-network (>= 4.5.0~+rc1);然而:
未曾安装软件包“libqt4-network”。
virtualbox-3.0 依赖于 libqtcore4 (>= 4.5.0~+rc1);然而:
未曾安装软件包“libqtcore4”。
virtualbox-3.0 依赖于 libqtgui4 (>= 4.5.0~+rc1);然而:
未曾安装软件包“libqtgui4”。
virtualbox-3.0 依赖于 python2.5 (>= 2.5);然而:
未曾安装软件包“python2.5”。
dpkg:处理 virtualbox-3.0 (--install)时出错:
依赖关系问题 - 仍未被配置
正在处理用于 desktop-file-utils 的触发器...
在处理时有错误发生:
virtualbox-3.0
angel@BlackAngel:~$ sudo apt-get -f install 《——键入内容
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
正在更正依赖关系... 完成
下列软件包将被【卸载】:
virtualbox-3.0
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包,有 0 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
解压缩后将会空出 87.0MB 的空间。
您希望继续执行吗?[Y/n]y 《——键入内容
(正在读取数据库 ... 系统当前总共安装有 106794 个文件和目录。)
正在删除 virtualbox-3.0 ...
正在处理用于 desktop-file-utils 的触发器...
angel@BlackAngel:~$ sudo dpkg -i VirtualBox.deb
选中了曾被取消选择的软件包 virtualbox-3.0。
(正在读取数据库 ... 系统当前总共安装有 106214 个文件和目录。)
正在解压缩 virtualbox-3.0 (从 VirtualBox.deb) ...
dpkg:依赖关系问题使得 virtualbox-3.0 的配置工作不能继续:
virtualbox-3.0 依赖于 libcurl3 (>= 7.16.2-1);然而:
未曾安装软件包“libcurl3”。
virtualbox-3.0 依赖于 libqt4-network (>= 4.5.0~+rc1);然而:
未曾安装软件包“libqt4-network”。
virtualbox-3.0 依赖于 libqtcore4 (>= 4.5.0~+rc1);然而:
未曾安装软件包“libqtcore4”。
virtualbox-3.0 依赖于 libqtgui4 (>= 4.5.0~+rc1);然而:
未曾安装软件包“libqtgui4”。
virtualbox-3.0 依赖于 python2.5 (>= 2.5);然而:
未曾安装软件包“python2.5”。
dpkg:处理 virtualbox-3.0 (--install)时出错:
依赖关系问题 - 仍未被配置
正在处理用于 desktop-file-utils 的触发器...
在处理时有错误发生:
virtualbox-3.0
angel@BlackAngel:~$


失败了,virturlbox官网上的是写着Ubuntu9.04适用的,我的是9.10的,难道是因为这个?9.04的我就用成功过。


_________________
我很乖的。。。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu9.10装VirtualBox3.0.4失败,依赖关系没有满足?
帖子发表于 : 2009-09-04 8:47 
头像

注册: 2009-08-14 16:24
帖子: 314
送出感谢: 0 次
接收感谢: 0 次
[img]file:///home/angel/%E6%A1%8C%E9%9D%A2/Screenshot-%E8%BD%AF%E4%BB%B6%E5%8C%85%E5%AE%89%E8%A3%85%20-%20virtualbox-3.0.png[/img]


_________________
我很乖的。。。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Ubuntu9.10装VirtualBox3.0.4失败,依赖关系没有满足?
帖子发表于 : 2009-09-04 8:48 
头像

注册: 2009-08-14 16:24
帖子: 314
送出感谢: 0 次
接收感谢: 0 次
抓狂,不会上传图片。。


_________________
我很乖的。。。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Ubuntu9.10装VirtualBox3.0.4失败,依赖关系没有满足?
帖子发表于 : 2009-09-04 8:50 
头像

注册: 2009-08-14 16:24
帖子: 314
送出感谢: 0 次
接收感谢: 0 次
算了,。。
双击那deb包后出现:
错误:依赖关系没有满足:libcurl3(>=7.16.2-1)


_________________
我很乖的。。。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: Ubuntu9.10装VirtualBox3.0.4失败,依赖关系没有满足?
帖子发表于 : 2009-09-04 8:53 
头像

注册: 2009-08-14 16:24
帖子: 314
送出感谢: 0 次
接收感谢: 0 次
系统提示升级,升级后还是这样。。错误。。。


_________________
我很乖的。。。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: Ubuntu9.10装VirtualBox3.0.4失败,依赖关系没有满足?
帖子发表于 : 2009-09-04 22:03 
头像

注册: 2008-07-08 10:39
帖子: 413
送出感谢: 1
接收感谢: 3
irtualbox-3.0 依赖于 libcurl3 (>= 7.16.2-1);然而:
未曾安装软件包“libcurl3”。
virtualbox-3.0 依赖于 libqt4-network (>= 4.5.0~+rc1);然而:
未曾安装软件包“libqt4-network”。
virtualbox-3.0 依赖于 libqtcore4 (>= 4.5.0~+rc1);然而:
未曾安装软件包“libqtcore4”。
virtualbox-3.0 依赖于 libqtgui4 (>= 4.5.0~+rc1);然而:
未曾安装软件包“libqtgui4”。
virtualbox-3.0 依赖于 python2.5 (>= 2.5);然而:
未曾安装软件包“python2.5”。

装上这些软件包吧,很明显的提示了。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: Ubuntu9.10装VirtualBox3.0.4失败,依赖关系没有满足?
帖子发表于 : 2009-09-04 22:09 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
你的源对不对啊?


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
8 楼 
 文章标题 : Re: Ubuntu9.10装VirtualBox3.0.4失败,依赖关系没有满足?
帖子发表于 : 2009-09-21 8:16 
头像

注册: 2009-08-14 16:24
帖子: 314
送出感谢: 0 次
接收感谢: 0 次
打算装回9.04版本的。。。
但没下载完。。


_________________
我很乖的。。。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: Ubuntu9.10装VirtualBox3.0.4失败,依赖关系没有满足?
帖子发表于 : 2009-10-24 11:10 
头像

注册: 2008-09-06 23:40
帖子: 590
地址: 天朝
送出感谢: 1
接收感谢: 1
我好多deb软件都装不上,都提示说依赖不满足,但是用新立得查看软件包的时候明明是符合要求的 :em20


_________________
我是一只菜鸟。。。
Ubuntu | Blog | Twitter | Blender


页首
 用户资料  
 
10 楼 
 文章标题 : Re: Ubuntu9.10装VirtualBox3.0.4失败,依赖关系没有满足?
帖子发表于 : 2009-10-24 22:17 
头像

注册: 2008-04-02 13:26
帖子: 3331
地址: 上海
送出感谢: 0 次
接收感谢: 1
我的9.10beta没这个问题。

下这个:http://download.virtualbox.org/virtualbox/3.0.8/virtualbox-3.0_3.0.8-53138_Ubuntu_karmic_i386.deb


_________________
Blog: http://ttboke.com/ubuntu/
Google+: http://gplus.to/jandyzhu


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译