当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 无法安装mysql5.0!一直提示错误
帖子发表于 : 2009-09-12 11:04 

注册: 2009-09-12 10:59
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
代码:
root@lh-desktop:/home/lh# apt-get -f install正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
下列软件包是自动安装的并且现在不再被使用了:
  libwildmidi0 libdc1394-22 libsoundtouch1c2 libdca0 libopenspc0 libfftw3-3
  libass1 freepats libcdaudio1 libmodplug0c2 libofa0 libmms0 libneon27-gnutls
  libiptcdata0
使用'apt-get autoremove'来删除它们
将会安装下列额外的软件包:
  mysql-server-5.0
建议安装的软件包:
  tinyca mailx
下列的软件包将被升级:
  mysql-server-5.0
共升级了 1 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 30 个软件未被升级。
有 14 个软件包没有被完全安装或卸载。
需要下载 23.6MB 的软件包。
解压缩后会消耗掉 79.4MB 的额外空间。
您希望继续执行吗?[Y/n]y
获取:1 http://mirror.lupaworld.com jaunty-updates/main mysql-server-5.0 5.1.30really5.0.75-0ubuntu10.2 [23.6MB]
下载 23.6MB,耗时 4min 18s (91.1kB/s)                                         
debconf: DbDriver "passwords" warning: /var/cache/debconf/passwords.dat is locked by another process: 资源临时不可用
debconf: DbDriver "templatedb": /var/cache/debconf/templates.dat is locked by another process: 资源临时不可用
(正在读取数据库 ...
dpkg:严重警告:无法找到软件包“mysql-server-5.0”的文件名列表文件,现假定该软件包目前没有任何文件被安装在系统里。
系统当前总共安装有 118196 个文件和目录。)
正预备替换 mysql-server-5.0 5.1.30really5.0.75-0ubuntu10.2 (使用 .../mysql-server-5.0_5.1.30really5.0.75-0ubuntu10.2_i386.deb) ...
debconf: DbDriver "passwords" warning: /var/cache/debconf/passwords.dat is locked by another process: 资源临时不可用
debconf: DbDriver "templatedb": /var/cache/debconf/templates.dat is locked by another process: 资源临时不可用
dpkg:处理 /var/cache/apt/archives/mysql-server-5.0_5.1.30really5.0.75-0ubuntu10.2_i386.deb (--unpack)时出错:
 子进程 pre-installation script 返回了错误号 1
debconf: DbDriver "passwords" warning: /var/cache/debconf/passwords.dat is locked by another process: 资源临时不可用
debconf: DbDriver "templatedb": /var/cache/debconf/templates.dat is locked by another process: 资源临时不可用
dpkg: 作下列清理工作时发生错误:
 子进程 post-removal script 返回了错误号 1
在处理时有错误发生:
 /var/cache/apt/archives/mysql-server-5.0_5.1.30really5.0.75-0ubuntu10.2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@lh-desktop:/home/lh#


以上是终端提示的错误!!

另一个问题::对于ubuntu和第三方源,,有没有什么管理工具可以将一些连接速度慢的和无法连接或是错误的源删掉阿!!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 无法安装mysql5.0!一直提示错误
帖子发表于 : 2009-09-13 1:39 
头像

注册: 2009-03-02 19:30
帖子: 379
地址: 河北石家庄
送出感谢: 0 次
接收感谢: 0 次
貌似是LZ在使用UPDATE指令更新源列表时没有执行完就把终端关了吧
这样的话要删除一个临时文件,你百度上搜一下,有解决办法,以前我遇到过这种情况,只是时间太久了忘记怎么操作了 :em06
第二个问题使用sudo gedit /etc/apt/sources.list 删除不要的源保存 或者使用新立得:设置-》软件库-》第三方软件-》选择不用的删除


_________________
除了真相,女人也是赤裸裸的


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译