当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 磕磕绊绊,总算架起了lamp
帖子发表于 : 2009-09-17 23:44 

注册: 2009-08-31 13:40
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
问前辈,自己股沟,总算架起了lamp,安上了phpmyadmin。
发现ubuntu真的很有意思!
有点喜欢上它了。
还得努力!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 磕磕绊绊,总算架起了lamp
帖子发表于 : 2009-09-21 12:01 

注册: 2009-08-31 13:40
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
无法载入mcrypt 扩展,<br />请检查PHP ...
安装了phpmyadmin之后,会有这个提示,搜了一下是因为没有安装php5-mcrypt扩展导致的。
于是运行sudo apt-get install php5-mcrypt安装之,然后会询问是否更新php5-mcrypt,输入Y,回车,系统会自动下载并更新,最后运行 /etc/init.d/apache2 restart 重启apache


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 磕磕绊绊,总算架起了lamp
帖子发表于 : 2009-09-21 12:03 

注册: 2009-08-31 13:40
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
安装了discuz论坛,验证码是黑白的,因为没安装php5-gd扩展
运行 sudo apt-get install php5-gd 安装之,然后运行 /etc/init.d/apache2 restart 重启apache
刷新dz的页面,验证码就变成彩色的咯


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 磕磕绊绊,总算架起了lamp
帖子发表于 : 2009-09-21 12:05 

注册: 2009-08-31 13:40
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
到昊海楼买了本ubuntu的书,正在学习中,哈哈。
入门的感觉很不错。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 磕磕绊绊,总算架起了lamp
帖子发表于 : 2009-09-21 12:19 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
难得LZ自言自语盖了4层,我也来凑热闹吧


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 磕磕绊绊,总算架起了lamp
帖子发表于 : 2009-09-21 12:28 

注册: 2009-08-31 13:40
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
gedit被我搞不响应了,没弄明白如何结束进程,把终端关掉,再打开,gedit又可以用了,然后想重启一下apache,可是返回fail,信息为: restarting web server apache2
(13)premission denied:make_sock:could not bind to address 0.0.0.0:80 no listening sockets available, shutting down
unable to open logs
搜一下,原因大概是权限不够,命令前面忘了加 sudo 囧一个。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 磕磕绊绊,总算架起了lamp
帖子发表于 : 2009-09-21 12:29 

注册: 2009-08-31 13:40
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
tenzu 写道:
难得LZ自言自语盖了4层,我也来凑热闹吧



我是打算把学习过程中遇到的问题记录下来,以后方便查找,哈哈。万一有比我还新的新人,也好有点帮助吧。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 磕磕绊绊,总算架起了lamp
帖子发表于 : 2009-09-21 12:36 

注册: 2008-01-09 22:41
帖子: 18311
送出感谢: 0 次
接收感谢: 6
tenzu 写道:
难得LZ自言自语盖了4层,我也来凑热闹吧


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 磕磕绊绊,总算架起了lamp
帖子发表于 : 2009-09-21 17:45 
头像

注册: 2007-10-24 20:20
帖子: 1565
地址: 北京、海淀
送出感谢: 0 次
接收感谢: 1
不错不错。


_________________
Dell Vostro 1500, T7300/4GB/WD5000BEVT/nVidia 8400GM, Ubuntu 10.04 x86_64/VMware 7(Win7)
我的博客:http://xieshaohu.wordpress.com/


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 磕磕绊绊,总算架起了lamp
帖子发表于 : 2009-09-21 18:15 
头像

注册: 2008-10-24 22:02
帖子: 5853
地址: 浙江
送出感谢: 0 次
接收感谢: 3
LAMP很简单的
新立得里勾一下 点几下就可以了

打开新立得,编辑 –> 使用任务分组标记软件包 –> 勾选 LAMP Server


_________________
http://sb.google.com/ 提问前 请在右上角搜索一下
请不要跨省追捕!水表在门外。谢谢! 大家一起twitter


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 磕磕绊绊,总算架起了lamp
帖子发表于 : 2009-09-21 21:46 

注册: 2009-08-31 13:40
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
RE 10#
我也发现lamp不难,ubuntu比redhat方便多了!我以前尝试过redhat,说来惭愧死,我在redhat下没有一次成功安装软件,实在搞不懂configure和make还有make install~~
安装这个,系统提示依赖那个,安装那个之后又依赖别的,挠头死了!
安装ubuntu的第二天我就能建起lamp环境了,找回一点点信心,哈哈!

再次感谢各位!


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 磕磕绊绊,总算架起了lamp
帖子发表于 : 2009-09-21 22:28 

注册: 2009-08-31 13:40
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
想尝试配置多个ip给我的系统,搞虚拟主机试试,结果发现得到多个ip很困难内。

:em06


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 磕磕绊绊,总算架起了lamp
帖子发表于 : 2009-09-22 17:31 

注册: 2009-08-31 13:40
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
我的apache默认是不启用rewrite的,也就是discuz的静态化不被支持。
花了一天多时间才搞定。
/etc/apache2/httpd.conf 这个是用户配置文件,打开一看是空白的,没敢动弹。赶紧关上了。
/etc/apache2/apache2.conf 这个是全局配置文件(书中说不要轻易修改之),我修改之后发现无效,赶紧恢复成初始状态
废话不说了:
1、执行 sudo a2enmod rewrite
2、执行 sudo gedit /etc/apache2/sites-available/default 把该文件中的 AllowOverride None 替换为 AllowOverride All
选一个位置 写入LoadModule rewrite_module modules/mod_rewrite.so
然后写入
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule ^(.*)/archiver/((fid|tid)-[\w\-]+\.html)$ $1/archiver/index.php?$2
RewriteRule ^(.*)/forum-([0-9]+)-([0-9]+)\.html$ $1/forumdisplay.php?fid=$2&page=$3
RewriteRule ^(.*)/thread-([0-9]+)-([0-9]+)-([0-9]+)\.html$ $1/viewthread.php?tid=$2&extra=page\%3D$4&page=$3
RewriteRule ^(.*)/space-(username|uid)-(.+)\.html$ $1/space.php?$2=$3
RewriteRule ^(.*)/tag-(.+)\.html$ $1/tag.php?name=$2
</IfModule>
保存,退出
3、/etc/init.d/apache2 restart
4、到dz后台开启静态化选项

小弟刚刚接触U不久,木有理论基础,好多东西都是误打误撞弄上的,个案,希望对其他的菜鸟有所帮助


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 磕磕绊绊,总算架起了lamp
帖子发表于 : 2009-09-27 13:43 

注册: 2009-08-31 13:40
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
换了个机器,重新安装虚拟机,重新安装ubuntu,这次安装到82%的时候我把虚拟机的网络断掉,跳过检查镜像的步骤,嘿嘿,省些时间。
更新的时候想不起来如何选择最近镜像,只好一点点的爬进度。


:em19


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 磕磕绊绊,总算架起了lamp
帖子发表于 : 2009-10-14 10:56 

注册: 2009-08-31 13:40
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
昨天配置https服务,今天开机apache无法启动,提示端口被占用,朋友赐我一命令 lsof -i:80 执行之后 恢复正常,正在试图理解这个命令

开机再次遇到此问题,执行上述命令不起作用了,搜了一下 得到另一个命令 :# lsof -i :80|grep -v "PID"|awk '{print "kill -9",$2}'|sh 成功执行 apache2 顺利启动。
费解中


最后由 shazhumaiyou 编辑于 2009-10-21 17:10,总共编辑了 1 次

页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译