当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 用jhbuild编译gnome 2.28遇到gnome-doc-utils出错, 怎么解决?
帖子发表于 : 2009-09-24 19:36 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
代码:
*** Configuring gnome-doc-utils *** [8/233]
./autogen.sh --prefix /opt/gnome2 --libdir '/opt/gnome2/lib'  --disable-static --disable-gtk-doc
/opt/gnome2/bin/gnome-autogen.sh
skipping ./sandbox/mallard -- flagged as no auto-gen
skipping ./test/testdoc1 -- flagged as no auto-gen
checking for autoconf >= 2.53...
  testing autoconf2.50... not found.
  testing autoconf... found 2.63
checking for automake >= 1.9...
  testing automake-1.11... found 1.11
checking for intltool >= 0.25...
  testing intltoolize... found 0.40.6
checking for pkg-config >= 0.14.0...
  testing pkg-config... found 0.23
Checking for required M4 macros...
Checking for forbidden M4 macros...
Processing ./configure.in
Running intltoolize...
Running aclocal-1.11...
configure.in:44: warning: AM_NLS is m4_require'd but not m4_defun'd
m4/intltool.m4:27: IT_PROG_INTLTOOL is expanded from...
configure.in:44: the top level
Running autoconf...
configure.in:44: warning: AM_NLS is m4_require'd but not m4_defun'd
m4/intltool.m4:27: IT_PROG_INTLTOOL is expanded from...
configure.in:44: the top level
configure:3071: error: possibly undefined macro: AM_NLS
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
*** Error during phase configure of gnome-doc-utils: ########## Error running ./autogen.sh --prefix /opt/gnome2 --libdir '/opt/gnome2/lib'  --disable-static --disable-gtk-doc  *** [8/233]

  [1] Rerun phase configure
  [2] Ignore error and continue to build
  [3] Give up on module
  [4] Start shell
  [5] Reload configuration
  [6] Go to phase "wipe directory and start over"
  [7] Go to phase "clean"
  [8] Go to phase "distclean"
choice:


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 用jhbuild编译gnome 2.28遇到gnome-doc-utils出错, 怎么解决?
帖子发表于 : 2009-09-24 20:12 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
引用:
linux@ubuntu:~$ grep AM_NLS -r /usr/share/aclocal
/usr/share/aclocal/nls.m4:AC_DEFUN([AM_NLS],
/usr/share/aclocal/po.m4: AC_REQUIRE([AM_NLS])dnl
/usr/share/aclocal/gettext.m4: AC_REQUIRE([AM_NLS])
linux@ubuntu:~$


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 用jhbuild编译gnome 2.28遇到gnome-doc-utils出错, 怎么解决?
帖子发表于 : 2009-09-24 20:24 
头像

注册: 2007-01-30 7:13
帖子: 1446
送出感谢: 4
接收感谢: 0 次
http://live.gnome.org/JhbuildIssues/gno ... 824eb7b33a

引用:
Solution: Reinstall gettext (jhbuild bootstrap --ignore-system). Ensure that gettext.m4 is installed and that it contains the macro AM_NLS.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译