当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 15 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 竟然没有xp系统分区【已经证实为1104的bug】
帖子发表于 : 2010-11-27 13:03 
头像

注册: 2007-12-03 9:54
帖子: 943
送出感谢: 0 次
接收感谢: 0 次
rt,开机不显示grub列表,使用update-grub或者update-grub2都没用
比较郁闷啊,其他没什么问题
界面有点小改动
来张图
附件:
Screenshot-计算机.png
Screenshot-计算机.png [ 74.81 KiB | 被浏览 898 次 ]


附件:
Screenshot.png
Screenshot.png [ 232.07 KiB | 被浏览 919 次 ]


附件:
Screenshot-1.png
Screenshot-1.png [ 2.05 MiB | 被浏览 919 次 ]



谁能指点下迷津?!

经过3次修复磁盘MBR、然后重装10.04升级10.10升级11.04,事实是:
硬盘修复MBR恢复正常,然后安装10.04能正常识别XP系统分区,升级10.10同样正常,升级至11.04后磁盘磁盘出现错误,不能识别XP系统分区,不能用GRUB正常引导XP系统,请双系统用户慎入11.04!!


最后由 aric286 编辑于 2010-12-01 20:26,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 竟然没有xp系统分区
帖子发表于 : 2010-11-28 16:07 

注册: 2009-06-12 10:02
帖子: 93
送出感谢: 0 次
接收感谢: 0 次
不显示?
是读取的速度太快了吧?
sudo gedit /boot/grub/grub.cfg
把你里面的时间更改成10秒看看

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
load_env
fi
set default="0"
if [ ${prev_saved_entry} ]; then
set saved_entry=${prev_saved_entry}
save_env saved_entry
set prev_saved_entry=
save_env prev_saved_entry
set boot_once=true
fi

function savedefault {
if [ -z ${boot_once} ]; then
saved_entry=${chosen}
save_env saved_entry
fi
}

function recordfail {
set recordfail=1
if [ -n ${have_grubenv} ]; then if [ -z ${boot_once} ]; then save_env recordfail; fi; fi
}
insmod ext2
set root='(hd0,9)'
search --no-floppy --fs-uuid --set 57323e3f-0b5b-493f-9ddb-706be8f336a4
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=640x480
insmod gfxterm
insmod vbe
if terminal_output gfxterm ; then true ; else
# For backward compatibility with versions of terminal.mod that don't
# understand terminal_output
terminal gfxterm
fi
fi
insmod ext2
set root='(hd0,9)'
search --no-floppy --fs-uuid --set 57323e3f-0b5b-493f-9ddb-706be8f336a4
set locale_dir=($root)/boot/grub/locale
set lang=
insmod gettext
if [ ${recordfail} = 1 ]; then
set timeout=-1
else
set timeout=4
fi

把那设为timeout = 10,启动项设为其他的看看了!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 竟然没有xp系统分区
帖子发表于 : 2010-11-28 16:11 

注册: 2009-06-12 10:02
帖子: 93
送出感谢: 0 次
接收感谢: 0 次
不过看你的分区,可能性最大的应该是,XP分区被你格掉了!

你可以把在系统——系统管理——磁盘管理器里,看一下你的磁盘分区

如果找不到你装XP(fat32 或ntfs的文件盘,可能的你的磁盘分区表有问题了,你要重新修复一下分区表!


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 竟然没有xp系统分区
帖子发表于 : 2010-11-28 16:28 
头像

注册: 2009-09-06 5:53
帖子: 4666
送出感谢: 6
接收感谢: 110
http://sourceforge.net/projects/bootinfoscript/

把文件先复制到桌面,终端运行:

代码:
sudo bash ~/桌面/boot_info_script055.sh


RESULTS.txt可以看到比较详细的引导信息。


_________________
电子书下载:
鸟哥的Linux私房菜 基础学习篇 第三版 pdf
鸟哥的Linux私房菜 服务器架设篇 第三版 pdf


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 竟然没有xp系统分区
帖子发表于 : 2010-11-28 17:10 

注册: 2008-01-09 22:41
帖子: 18311
送出感谢: 0 次
接收感谢: 6
xp分区貌似是那两个100g分区?不是的话,那就是被干掉了


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 竟然没有xp系统分区
帖子发表于 : 2010-11-28 17:21 
头像

注册: 2007-12-03 9:54
帖子: 943
送出感谢: 0 次
接收感谢: 0 次
以下为我的grub.cfg内容。
注:无XP系统启动项,以该配置文件启动不会显示grub启动列表
代码:
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
set default="0"
if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
  insmod vbe
  insmod vga
}

insmod part_msdos
insmod ext2
set root='(/dev/sda,msdos8)'
search --no-floppy --fs-uuid --set=root 94f16c5a-85ab-4b34-8677-9f3ebf01b64f
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=640x480
  load_video
  insmod gfxterm
fi
terminal_output gfxterm
insmod part_msdos
insmod ext2
set root='(/dev/sda,msdos8)'
search --no-floppy --fs-uuid --set=root 94f16c5a-85ab-4b34-8677-9f3ebf01b64f
set locale_dir=($root)/boot/grub/locale
set lang=zh
insmod gettext
if [ "${recordfail}" = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
if [ ${recordfail} != 1 ]; then
  set matches_file=${prefix}/gfxblacklist.lst
  set class_match=3
  if lua ${prefix}/hwmatch.lua; then
    if [ ${match} = 0 ]; then
      set linux_gfx_mode=keep
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=text
  fi
else
  set linux_gfx_mode=text
fi
menuentry 'Ubuntu, with Linux 2.6.37-6-generic' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   if [ "$linux_gfx_mode" != text ]; then load_video; fi
   set gfxpayload=$linux_gfx_mode
   insmod part_msdos
   insmod ext2
   set root='(/dev/sda,msdos8)'
   search --no-floppy --fs-uuid --set=root 94f16c5a-85ab-4b34-8677-9f3ebf01b64f
   linux   /boot/vmlinuz-2.6.37-6-generic root=UUID=94f16c5a-85ab-4b34-8677-9f3ebf01b64f ro   quiet splash
   initrd   /boot/initrd.img-2.6.37-6-generic
}
menuentry 'Ubuntu, with Linux 2.6.37-6-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   if [ "$linux_gfx_mode" != text ]; then load_video; fi
   set gfxpayload=$linux_gfx_mode
   insmod part_msdos
   insmod ext2
   set root='(/dev/sda,msdos8)'
   search --no-floppy --fs-uuid --set=root 94f16c5a-85ab-4b34-8677-9f3ebf01b64f
   echo   'Loading Linux 2.6.37-6-generic ...'
   linux   /boot/vmlinuz-2.6.37-6-generic root=UUID=94f16c5a-85ab-4b34-8677-9f3ebf01b64f ro single
   echo   'Loading initial ramdisk ...'
   initrd   /boot/initrd.img-2.6.37-6-generic
}
submenu "Previous Linux versions" {
menuentry 'Ubuntu, with Linux 2.6.37-5-generic' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   if [ "$linux_gfx_mode" != text ]; then load_video; fi
   set gfxpayload=$linux_gfx_mode
   insmod part_msdos
   insmod ext2
   set root='(/dev/sda,msdos8)'
   search --no-floppy --fs-uuid --set=root 94f16c5a-85ab-4b34-8677-9f3ebf01b64f
   linux   /boot/vmlinuz-2.6.37-5-generic root=UUID=94f16c5a-85ab-4b34-8677-9f3ebf01b64f ro   quiet splash
   initrd   /boot/initrd.img-2.6.37-5-generic
}
menuentry 'Ubuntu, with Linux 2.6.37-5-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   if [ "$linux_gfx_mode" != text ]; then load_video; fi
   set gfxpayload=$linux_gfx_mode
   insmod part_msdos
   insmod ext2
   set root='(/dev/sda,msdos8)'
   search --no-floppy --fs-uuid --set=root 94f16c5a-85ab-4b34-8677-9f3ebf01b64f
   echo   'Loading Linux 2.6.37-5-generic ...'
   linux   /boot/vmlinuz-2.6.37-5-generic root=UUID=94f16c5a-85ab-4b34-8677-9f3ebf01b64f ro single
   echo   'Loading initial ramdisk ...'
   initrd   /boot/initrd.img-2.6.37-5-generic
}
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
   insmod part_msdos
   insmod ext2
   set root='(/dev/sda,msdos8)'
   search --no-floppy --fs-uuid --set=root 94f16c5a-85ab-4b34-8677-9f3ebf01b64f
   linux16   /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
   insmod part_msdos
   insmod ext2
   set root='(/dev/sda,msdos8)'
   search --no-floppy --fs-uuid --set=root 94f16c5a-85ab-4b34-8677-9f3ebf01b64f
   linux16   /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
if [ "x${timeout}" != "x-1" ]; then
  if keystatus; then
    if keystatus --shift; then
      set timeout=-1
    else
      set timeout=0
    fi
  else
    if sleep --interruptible 3 ; then
      set timeout=0
    fi
  fi
fi
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###


分区情况:
附件:
Screenshot-250 GB 硬盘 (ATA ST3250310AS) [-dev-sda] — 磁盘实用工具.png
Screenshot-250 GB 硬盘 (ATA ST3250310AS) [-dev-sda] — 磁盘实用工具.png [ 161.94 KiB | 被浏览 857 次 ]



页首
 用户资料  
 
7 楼 
 文章标题 : Re: 竟然没有xp系统分区
帖子发表于 : 2010-11-28 18:06 
头像

注册: 2009-09-06 5:53
帖子: 4666
送出感谢: 6
接收感谢: 110
试试:sudo update-grub
不行就把4楼运行结果贴上来看看。


_________________
电子书下载:
鸟哥的Linux私房菜 基础学习篇 第三版 pdf
鸟哥的Linux私房菜 服务器架设篇 第三版 pdf


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 竟然没有xp系统分区
帖子发表于 : 2010-11-28 21:29 
头像

注册: 2007-12-03 9:54
帖子: 943
送出感谢: 0 次
接收感谢: 0 次
根据四楼提供的,运行之后,result.txt内容摘取一部分,请大家帮忙看看
代码:
=========================== Drive/Partition Info: =============================

Drive: sda ___________________ _____________________________________________________

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes

Partition  Boot         Start           End          Size  Id System

/dev/sda1    *             63    69,208,019    69,207,957   7 HPFS/NTFS
/dev/sda2          69,208,062   488,396,799   419,188,738   5 Extended
/dev/sda5          69,208,064   264,519,679   195,311,616   7 HPFS/NTFS
/dev/sda6         264,521,728   362,176,511    97,654,784   7 HPFS/NTFS
/dev/sda7         362,178,560   364,130,303     1,951,744  82 Linux swap / Solaris
/dev/sda8         364,132,352   488,396,799   124,264,448  83 Linux


blkid -c /dev/null: ____________________________________________________________

Device           UUID                                   TYPE       LABEL                         

/dev/sda2: PTTYPE="dos"
/dev/sda5        B6BC9047BC900451                       ntfs                                     
/dev/sda6        76709A56709A1CC5                       ntfs                                     
/dev/sda7        d7418a07-c101-40c5-9f30-0d23c837fa4f   swap                                     
/dev/sda8        94f16c5a-85ab-4b34-8677-9f3ebf01b64f   ext4                                     
/dev/sda: PTTYPE="dos"

============================ "mount | grep ^/dev  output: ===========================


代码:
=========================== Unknown MBRs/Boot Sectors/etc =======================

Unknown BootLoader  on sda1

00000000  3c a0 3a 2c ba 3c 9c 6f  63 bf 94 9d 35 85 52 c1  |<.:,.<.oc...5.R.|
00000010  fb f0 a7 08 4f 24 77 ab  06 43 2c 58 b1 cf 74 66  |....O$w..C,X..tf|
00000020  e4 cf 35 a1 60 5a 08 c0  f7 a1 e9 75 94 22 58 db  |..5.`Z.....u."X.|
00000030  c1 d5 1c 5f 01 d0 41 60  5e 32 83 13 ac be fe d9  |..._..A`^2......|
00000040  9f 89 b9 0d 6d a7 ea b3  ae 85 cb 4a 31 59 1c 07  |....m......J1Y..|
00000050  48 72 a4 13 3a e7 fd 60  5f 99 13 5c 2b b0 e5 20  |Hr..:..`_..\+.. |
00000060  7b 94 b9 32 c3 53 64 d0  b9 a6 7b 7f a1 51 27 b3  |{..2.Sd...{..Q'.|
00000070  04 cd bb 2f e4 6b bd 39  9d ca db 88 60 74 24 86  |.../.k.9....`t$.|
00000080  a2 bc ae b2 9e 13 53 c0  93 1f b1 04 dc c6 25 1b  |......S.......%.|
00000090  50 bb fa 06 cc 1b 9c bc  8a dd f9 90 cd da 79 0f  |P.............y.|
000000a0  08 d8 2d e1 dd bc d4 b1  62 b1 59 33 14 8d 70 59  |..-.....b.Y3..pY|
000000b0  61 87 6c c4 f0 56 7a 06  61 04 48 66 13 ca 5e 86  |a.l..Vz.a.Hf..^.|
000000c0  0e 7e d0 04 8f 65 62 45  48 90 3e fb 78 d9 6e d0  |.~...ebEH.>.x.n.|
000000d0  d4 62 07 59 e6 6d 35 1a  e1 34 a8 69 95 d1 ab 8a  |.b.Y.m5..4.i....|
000000e0  19 31 f7 88 78 8f 91 d3  dc 08 36 a4 98 23 76 4b  |.1..x.....6..#vK|
000000f0  c9 7d df 6b 9f e9 8d ec  17 9b 0e d7 3e 46 7b fe  |.}.k........>F{.|
00000100  b7 ca b5 19 cc 75 e6 39  6d f7 20 a4 2b d2 4d b8  |.....u.9m. .+.M.|
00000110  d1 74 40 32 3b 89 ab ba  94 c9 ca 5a 0a e5 eb 6a  |.t@2;......Z...j|
00000120  4e dd 82 4e 50 e9 84 c3  e3 47 ed e1 e4 1f 47 e8  |N..NP....G....G.|
00000130  94 04 9c 1c bb db 60 e7  55 8a d8 10 de e4 f6 95  |......`.U.......|
00000140  b0 c5 61 2e 00 b2 ed 50  3b 7f b8 92 28 4b 68 08  |..a....P;...(Kh.|
00000150  ae ac 96 78 ad 9a 3c 94  24 ef 7b ae a9 40 4d fa  |...x..<.$.{..@M.|
00000160  b3 90 9d 96 d9 e5 50 f6  b6 e5 ba 5a 6e 30 d7 af  |......P....Zn0..|
00000170  a3 ba 7c 42 b4 88 71 8d  1c 8a 36 e3 57 90 5f 6c  |..|B..q...6.W._l|
00000180  e4 54 c8 bc 30 59 be f3  2e 49 3e 90 63 5a d3 32  |.T..0Y...I>.cZ.2|
00000190  55 01 cf e9 dc 84 b3 d7  40 4b 6d 23 55 cf cd 2a  |U.......@Km#U..*|
000001a0  e2 b1 8e 65 dc da 99 0e  6e 4c 0f 49 5a 23 0a 8a  |...e....nL.IZ#..|
000001b0  7c bd 50 84 6b 13 a9 e4  dd c3 46 8a 26 95 7e bc  ||.P.k.....F.&.~.|
000001c0  78 df a1 8f 63 3e a0 d1  11 a0 09 c0 93 38 2d 4e  |x...c>.......8-N|
000001d0  51 10 60 e1 65 83 3a c8  ce fa 44 72 21 1c 1a 1c  |Q.`.e.:...Dr!...|
000001e0  1b 86 f1 85 1f 2e 75 ef  25 87 cd 03 78 74 0f ff  |......u.%...xt..|
000001f0  8d ae d5 21 4b 4c 5d d7  fc f0 a3 d8 23 92 bf 46  |...!KL].....#..F|
00000200


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 竟然没有xp系统分区
帖子发表于 : 2010-11-28 21:52 
头像

注册: 2009-09-06 5:53
帖子: 4666
送出感谢: 6
接收感谢: 110
result.txt内容摘取一部分,我猜是xp的pbr有问题,修复一下。


_________________
电子书下载:
鸟哥的Linux私房菜 基础学习篇 第三版 pdf
鸟哥的Linux私房菜 服务器架设篇 第三版 pdf


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 竟然没有xp系统分区
帖子发表于 : 2010-11-29 0:18 

注册: 2009-06-12 10:02
帖子: 93
送出感谢: 0 次
接收感谢: 0 次
楼主,看你的磁盘分区图,我没有分析后面的那一堆参数,哈哈!
你的XP是不是装在第一个主分区上,35GB的那个!
那个分区好像不能被正确识别并挂载!
可以先试着手动装裁SDA1的分区,应该不会是磁盘的卷标有问题(不凡也换成英文试试),如果挂裁不上,当然无法在启动项出现了!——那只好修复那个分区,或者直接格了,在linux下将gost盘的镜像提取还原到35G的那个盘,然后将35分区设为可启动了,接着sudo update-grub, 这等于重新gost还原了!(我曾经在linux下用G4L成功的安装了XP,当初是为了装一个特殊扫描仪及艾利的文件打印上传,没有驱动,重新编译内核找不到相应的厂商提供的模块)
如果能装载上,那可以编辑grub来手动添加启动项,也可以用sudo update-grub来添加!


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 竟然没有xp系统分区
帖子发表于 : 2010-11-29 11:46 
头像

注册: 2007-12-03 9:54
帖子: 943
送出感谢: 0 次
接收感谢: 0 次
回楼上:
我的XP分区就是35G的那个主分区。
另外想问下:如何在ubuntu下修复那个分区?还是不要格了,很多软件需要重装,太麻烦了。


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 竟然没有xp系统分区【已经证实为1104的bug】
帖子发表于 : 2010-12-04 10:41 

注册: 2010-11-20 1:14
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
我的升级也出错了,我的是windows7+ linux,升级到11.04后,进不去windows了,也挂载不上windows分区了。
后来在pe里修复了一下分区表,清了mbr,还是进不去windows,最后用bootsect.exe修改一下引导windows7可以起来了,重装grub搞定。


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 竟然没有xp系统分区【已经证实为1104的bug】
帖子发表于 : 2010-12-04 11:30 
头像

注册: 2010-12-02 18:57
帖子: 59
地址: xxoo
送出感谢: 0 次
接收感谢: 0 次
不会啊 我的显示很正常啊 顺便问下 边上的透明条框上怎么加图标啊?


_________________
(此回复虽仅有两个字,却深刻地表达了回复人的深深的祝福与刻骨的情感,可谓言简意赅,一字千金,字字扣人心弦,字字催人泪下,足可见回复人扎实的文字功底和信手拈来的写作技巧及惨绝人环的创新能力。实是佩服佩服!再加上以感叹号收尾,点睛之笔,妙笔生花,意境深远,照应前文,升华主题,把回复人的感情表达得淋漓尽致,给人无限感动和惆怅,有浑然天成之感,实乃回复中之极品,祝福中之绝笔。)


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 竟然没有xp系统分区【已经证实为1104的bug】
帖子发表于 : 2010-12-06 19:31 
头像

注册: 2007-12-03 9:54
帖子: 943
送出感谢: 0 次
接收感谢: 0 次
回楼上:
不是显示不显示的问题,而是分区表都给弄坏了,XP分区出问题了。

不知道怎么加图标,现在我已经换回10.10了,我的几十G文件全格了,哎,心疼啊


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 竟然没有xp系统分区【已经证实为1104的bug】
帖子发表于 : 2010-12-07 21:10 
头像

注册: 2010-12-07 20:09
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
看上去和10.10没有什么区别啊,图标主题都差不多。那个unity现在到底稳定了没有?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 15 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译