当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 编译安装audacious遇到问题。。。
帖子发表于 : 2011-04-30 13:07 
头像

注册: 2011-03-24 8:05
帖子: 271
送出感谢: 0 次
接收感谢: 1
configure: error:
Cannot find Glib2! If you are using binary packages based system, check that you
have the corresponding -dev/devel packages installed.

少了什么库啊。。。我该装什么?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 编译安装audacious遇到问题。。。
帖子发表于 : 2011-04-30 13:21 
头像

注册: 2008-12-06 10:38
帖子: 4570
系统: Arch
送出感谢: 23
接收感谢: 31
libglib2.0-0


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 编译安装audacious遇到问题。。。
帖子发表于 : 2011-04-30 13:42 
头像

注册: 2011-03-24 8:05
帖子: 271
送出感谢: 0 次
接收感谢: 1
灰色小狼 写道:
libglib2.0-0

maple@ThinkPad-SL410k:~$ sudo apt-get install libglib2.0-0
[sudo] password for maple:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
libglib2.0-0 已经是最新的版本了。
升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。
:em20


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 编译安装audacious遇到问题。。。
帖子发表于 : 2011-04-30 13:51 
头像

注册: 2008-04-26 12:41
帖子: 11000
送出感谢: 11
接收感谢: 38
为什么不从ppa源安装? :em09


_________________
[新手必读]wubi安装常见问题(FAQ)
[分享]装双系统的同学必看——Windows与Linux系统共享交换分区的方法
kde下唯美的暗黑内透主题(无需编译)
无穷老机上的Trinity Desktop Environment


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 编译安装audacious遇到问题。。。
帖子发表于 : 2011-04-30 13:52 
头像

注册: 2007-12-14 13:40
帖子: 49888
地址: 志虚国乌由市
系统: Winbuntu
送出感谢: 29
接收感谢: 414
photor 写道:
为什么不从ppa源安装? :em09


_________________
冷轩信

渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu

安装flash 还是要用
代码:
sudo apt install adobe-flashplugin


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 编译安装audacious遇到问题。。。
帖子发表于 : 2011-04-30 14:42 
头像

注册: 2011-03-24 8:05
帖子: 271
送出感谢: 0 次
接收感谢: 1
qy117121 写道:
photor 写道:
为什么不从ppa源安装? :em09

从10.10升级到11.04后,很多软件重新编译后就运行地很好。。。所以打算重新你编译。。。而且不喜欢加很多源。。。弄的不好把依赖关系弄坏了就不好了


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 编译安装audacious遇到问题。。。
帖子发表于 : 2011-04-30 15:03 
头像

注册: 2011-03-24 8:05
帖子: 271
送出感谢: 0 次
接收感谢: 1
有木有有知道少了什么库呀。。。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 编译安装audacious遇到问题。。。
帖子发表于 : 2011-04-30 15:20 
头像

注册: 2008-12-20 15:43
帖子: 9349
地址: 心靈深處
系统: 家14.04,公司14.04
送出感谢: 13
接收感谢: 37
:em06 ...沒人遇過...就放狗搜...建議搜英文的...


_________________
[论坛版主行为规定]+[PITIVI簡易教程]+[CAD裝draftsight]+[酷我音乐裝kwplayer]+[ubuntu裝迅雷]
[releases.ubuntu.com]+[cdimage.ubuntu.com]+[old-releases.ubuntu.com]
[學ubuntu必須拜讀懶蝸牛"笨兔兔的故事"=viewtopic.php?f=112&t=162040][Linux明日的希望在中國]


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 编译安装audacious遇到问题。。。
帖子发表于 : 2011-04-30 15:37 

注册: 2010-10-29 15:20
帖子: 99
送出感谢: 0 次
接收感谢: 0 次
11.04的glib2.0库有问题。我的emacs23.3在10.10编译没有错,在11.04编译出错。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 编译安装audacious遇到问题。。。
帖子发表于 : 2011-04-30 15:45 
头像

注册: 2008-12-20 15:43
帖子: 9349
地址: 心靈深處
系统: 家14.04,公司14.04
送出感谢: 13
接收感谢: 37
sudo apt-get install libgtk2.0-dev
這個裝了沒
代码:
design-b5@designb5-945GCM-S2L:~$ sudo apt-get install libgtk2.0-dev
正在讀取套件清單... 完成
正在重建相依關係         
正在讀取狀態資料... 完成
下列的額外套件將被安裝:
  debhelper html2text libatk1.0-dev libcairo-script-interpreter2 libcairo2-dev
  libexpat1-dev libfontconfig1-dev libfreetype6-dev libgdk-pixbuf2.0-dev
  libglib2.0-dev libice-dev libmail-sendmail-perl libpango1.0-dev
  libpixman-1-dev libpng12-dev libpthread-stubs0 libpthread-stubs0-dev
  libsm-dev libsys-hostname-long-perl libx11-dev libxau-dev libxcb-render0-dev
  libxcb-shm0-dev libxcb1-dev libxcomposite-dev libxcursor-dev libxdamage-dev
  libxdmcp-dev libxext-dev libxfixes-dev libxft-dev libxi-dev libxinerama-dev
  libxrandr-dev libxrender-dev po-debconf x11proto-composite-dev
  x11proto-core-dev x11proto-damage-dev x11proto-fixes-dev x11proto-input-dev
  x11proto-kb-dev x11proto-randr-dev x11proto-render-dev x11proto-xext-dev
  x11proto-xinerama-dev xorg-sgml-doctools xtrans-dev zlib1g-dev
建議套件:
  dh-make libcairo2-doc libglib2.0-doc python-subunit libgtk2.0-doc
  libpango1.0-doc imagemagick libmail-box-perl
下列【新】套件將會被安裝:
  debhelper html2text libatk1.0-dev libcairo-script-interpreter2 libcairo2-dev
  libexpat1-dev libfontconfig1-dev libfreetype6-dev libgdk-pixbuf2.0-dev
  libglib2.0-dev libgtk2.0-dev libice-dev libmail-sendmail-perl
  libpango1.0-dev libpixman-1-dev libpng12-dev libpthread-stubs0
  libpthread-stubs0-dev libsm-dev libsys-hostname-long-perl libx11-dev
  libxau-dev libxcb-render0-dev libxcb-shm0-dev libxcb1-dev libxcomposite-dev
  libxcursor-dev libxdamage-dev libxdmcp-dev libxext-dev libxfixes-dev
  libxft-dev libxi-dev libxinerama-dev libxrandr-dev libxrender-dev po-debconf
  x11proto-composite-dev x11proto-core-dev x11proto-damage-dev
  x11proto-fixes-dev x11proto-input-dev x11proto-kb-dev x11proto-randr-dev
  x11proto-render-dev x11proto-xext-dev x11proto-xinerama-dev
  xorg-sgml-doctools xtrans-dev zlib1g-dev
升級 0 個,新安裝 50 個,移除 0 個,有 0 個未被升級。
需要下載 22.1 MB 的套件檔。


_________________
[论坛版主行为规定]+[PITIVI簡易教程]+[CAD裝draftsight]+[酷我音乐裝kwplayer]+[ubuntu裝迅雷]
[releases.ubuntu.com]+[cdimage.ubuntu.com]+[old-releases.ubuntu.com]
[學ubuntu必須拜讀懶蝸牛"笨兔兔的故事"=viewtopic.php?f=112&t=162040][Linux明日的希望在中國]


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 编译安装audacious遇到问题。。。
帖子发表于 : 2011-04-30 15:53 
头像

注册: 2011-03-24 8:05
帖子: 271
送出感谢: 0 次
接收感谢: 1
装了~这个问题解决了~但是。。。
configure: error:
libmowgli version 0.7.1 was found, but libmowgli >= 0.9 is required.
这个怎么办?


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 编译安装audacious遇到问题。。。
帖子发表于 : 2011-04-30 16:59 
头像

注册: 2008-12-20 15:43
帖子: 9349
地址: 心靈深處
系统: 家14.04,公司14.04
送出感谢: 13
接收感谢: 37
maple_ 写道:
装了~这个问题解决了~但是。。。
configure: error:
libmowgli version 0.7.1 was found, but libmowgli >= 0.9 is required.
这个怎么办?

:em04 ...送佛送上天...送上整個編譯過程全紀錄


附件:
Screenshot.png
Screenshot.png [ 394.46 KiB | 被浏览 673 次 ]

文件注释: 全紀錄全紀錄
audacious_make.tar.gz [19.14 KiB]
被下载 11 次


_________________
[论坛版主行为规定]+[PITIVI簡易教程]+[CAD裝draftsight]+[酷我音乐裝kwplayer]+[ubuntu裝迅雷]
[releases.ubuntu.com]+[cdimage.ubuntu.com]+[old-releases.ubuntu.com]
[學ubuntu必須拜讀懶蝸牛"笨兔兔的故事"=viewtopic.php?f=112&t=162040][Linux明日的希望在中國]
页首
 用户资料  
 
13 楼 
 文章标题 : Re: 编译安装audacious遇到问题。。。
帖子发表于 : 2011-04-30 17:01 
头像

注册: 2008-12-20 15:43
帖子: 9349
地址: 心靈深處
系统: 家14.04,公司14.04
送出感谢: 13
接收感谢: 37
:em04 ...ls那個壓縮檔解開好好看...來不及整理...解決依賴是蠻麻煩的...還好有google...


_________________
[论坛版主行为规定]+[PITIVI簡易教程]+[CAD裝draftsight]+[酷我音乐裝kwplayer]+[ubuntu裝迅雷]
[releases.ubuntu.com]+[cdimage.ubuntu.com]+[old-releases.ubuntu.com]
[學ubuntu必須拜讀懶蝸牛"笨兔兔的故事"=viewtopic.php?f=112&t=162040][Linux明日的希望在中國]


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 编译安装audacious遇到问题。。。
帖子发表于 : 2011-04-30 17:03 
头像

注册: 2008-12-06 10:38
帖子: 4570
系统: Arch
送出感谢: 23
接收感谢: 31
原来是libgtk2.0-dev 啊……还是arch好 :em05


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 编译安装audacious遇到问题。。。
帖子发表于 : 2011-04-30 17:18 
头像

注册: 2011-03-24 8:05
帖子: 271
送出感谢: 0 次
接收感谢: 1
peteryeh64 写道:
maple_ 写道:
装了~这个问题解决了~但是。。。
configure: error:
libmowgli version 0.7.1 was found, but libmowgli >= 0.9 is required.
这个怎么办?

:em04 ...送佛送上天...送上整個編譯過程全紀錄

sudo add-apt-repository ppa:nilarimogard/webupd8
里面还还是添加了别的源啊 :em05


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译