当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 21 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : Ubuntu 11.4更新管理器不可用
帖子发表于 : 2011-05-06 14:09 

注册: 2011-04-28 14:59
帖子: 15
送出感谢: 0 次
接收感谢: 1
我进更新管理器的时候提示
无法初始化软件包信息
初始化包信息时遇到无法解决的问题。

请汇报这个“update-manager”软件包的错误,并且将如下信息包含在报告中:

'E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/apt/lists/cn.archive.ubuntu.com_ubuntu_dists_natty_main_binary-i386_Packages, E:无法解析或打开软件包的列表或是状态文件。'
我是菜鸟,求教高手解答。

进新立得提示这样的信息
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/cn.archive.ubuntu.com_ubuntu_dists_natty_main_binary-i386_Packages
E: 无法解析或打开软件包列表或状态文件。
E: _cache->open() failed, please report.


最后由 SexyBro 编辑于 2011-05-06 14:31,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu 11.4更新管理器不可用
帖子发表于 : 2011-05-06 14:10 
头像

注册: 2010-10-07 14:23
帖子: 33999
地址: 某系某星某洲某国某省某市
系统: Archdows10
送出感谢: 29
接收感谢: 151
换源试试。


_________________
心似浮云常自在,意如流水任东西。
此事背后一定有个天大的咪咪
广告:
1、走过路过,不要错过,dropbox网盘2.25G大放送
py大法好,退C保平安
java多妖孽,VB本异端
日诵一千遍,快活似神仙


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Ubuntu 11.4更新管理器不可用
帖子发表于 : 2011-05-06 14:25 

注册: 2011-04-28 14:59
帖子: 15
送出感谢: 0 次
接收感谢: 1
月下叹逍遥 写道:
换源试试。

具体怎么操作 ?哪里有源下载 ? 我是个彻彻底底的大白菜呀。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Ubuntu 11.4更新管理器不可用
帖子发表于 : 2011-05-06 14:29 
头像

注册: 2010-10-07 14:23
帖子: 33999
地址: 某系某星某洲某国某省某市
系统: Archdows10
送出感谢: 29
接收感谢: 151
在终端输入:
代码:
sudo gedit /etc/apt/sources.list

在网上找找163或者搜狐的源,添进去。


_________________
心似浮云常自在,意如流水任东西。
此事背后一定有个天大的咪咪
广告:
1、走过路过,不要错过,dropbox网盘2.25G大放送
py大法好,退C保平安
java多妖孽,VB本异端
日诵一千遍,快活似神仙


页首
 用户资料  
 
5 楼 
 文章标题 : Re: Ubuntu 11.4更新管理器不可用
帖子发表于 : 2011-05-06 14:39 
头像

注册: 2010-01-28 10:45
帖子: 19507
送出感谢: 6
接收感谢: 41
更新管理器 右下角 设置
就会看到软件源
检测最快的源


_________________

*********宁静致远*********
如果我说的有什么不对,请看签名第一行


页首
 用户资料  
 
6 楼 
 文章标题 : Re: Ubuntu 11.4更新管理器不可用
帖子发表于 : 2011-05-06 14:54 

注册: 2011-04-28 14:59
帖子: 15
送出感谢: 0 次
接收感谢: 1
monk 写道:
更新管理器 右下角 设置
就会看到软件源
检测最快的源

是一进去就会出现错误提示。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: Ubuntu 11.4更新管理器不可用
帖子发表于 : 2011-05-06 15:06 

注册: 2011-04-28 14:59
帖子: 15
送出感谢: 0 次
接收感谢: 1
我现在通过 Sudo apt-get update 在更新, 然后有在下载程序包,是因为我之前没更新源么 ?


页首
 用户资料  
 
8 楼 
 文章标题 : Re: Ubuntu 11.4更新管理器不可用
帖子发表于 : 2011-05-06 15:10 

注册: 2011-04-28 14:59
帖子: 15
送出感谢: 0 次
接收感谢: 1
SexyBro 写道:
我现在通过 Sudo apt-get update 在更新, 然后有在下载程序包,是因为我之前没更新源么 ?

终端下载完成提示
下载 13.5 MB,耗时 8分 23秒 (26.8 kB/s)
正在读取软件包列表... 有错误!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/cn.archive.ubuntu.com_ubuntu_dists_natty_main_i18n_Translation-en
E: 无法解析或打开软件包的列表或是状态文件。
问题仍然没有解决, 求助继续。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: Ubuntu 11.4更新管理器不可用
帖子发表于 : 2011-05-06 15:15 
头像

注册: 2010-01-28 10:45
帖子: 19507
送出感谢: 6
接收感谢: 41
SexyBro 写道:
monk 写道:
更新管理器 右下角 设置
就会看到软件源
检测最快的源

是一进去就会出现错误提示。

神马提示
源有问题

代码:
sudo gedit /etc/apt/sources.list

骨头源
代码:
deb http://ubuntu.srt.cn/ubuntu/ natty main restricted universe multiverse
deb http://ubuntu.srt.cn/ubuntu/ natty-updates main restricted universe multiverse
deb-src http://ubuntu.srt.cn/ubuntu/ natty main restricted universe multiverse
deb-src http://ubuntu.srt.cn/ubuntu/ natty-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ natty-security restricted main multiverse universe
deb-src http://security.ubuntu.com/ubuntu/ natty-security restricted main multiverse universe
deb http://ubuntu.srt.cn/ubuntu/ natty-backports restricted main multiverse universe
deb-src http://ubuntu.srt.cn/ubuntu/ natty-backports restricted main multiverse universe


_________________

*********宁静致远*********
如果我说的有什么不对,请看签名第一行


页首
 用户资料  
 
10 楼 
 文章标题 : Re: Ubuntu 11.4更新管理器不可用
帖子发表于 : 2011-05-06 15:46 

注册: 2011-04-28 14:59
帖子: 15
送出感谢: 0 次
接收感谢: 1
monk 写道:
SexyBro 写道:
monk 写道:
更新管理器 右下角 设置
就会看到软件源
检测最快的源

是一进去就会出现错误提示。

神马提示
源有问题

代码:
sudo gedit /etc/apt/sources.list

骨头源
代码:
deb http://ubuntu.srt.cn/ubuntu/ natty main restricted universe multiverse
deb http://ubuntu.srt.cn/ubuntu/ natty-updates main restricted universe multiverse
deb-src http://ubuntu.srt.cn/ubuntu/ natty main restricted universe multiverse
deb-src http://ubuntu.srt.cn/ubuntu/ natty-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ natty-security restricted main multiverse universe
deb-src http://security.ubuntu.com/ubuntu/ natty-security restricted main multiverse universe
deb http://ubuntu.srt.cn/ubuntu/ natty-backports restricted main multiverse universe
deb-src http://ubuntu.srt.cn/ubuntu/ natty-backports restricted main multiverse universe

我已经解决了
Sudo rm/var/lib/apt/list/*-vf
Sudo apt-get update
谢谢大家的帮忙。 :em09


页首
 用户资料  
 
11 楼 
 文章标题 : Re: Ubuntu 11.4更新管理器不可用
帖子发表于 : 2011-05-08 10:02 

注册: 2010-06-07 19:24
帖子: 105
送出感谢: 1
接收感谢: 0 次
你能解决?我都解决不了


_________________
未必博客

Gedit中文乱码解决方法
ubuntu11.04修改成 默认启动为xp优先
【已解决】【装过N 卡驱动后无法更改分辨率为1280*1024】


页首
 用户资料  
 
12 楼 
 文章标题 : Re: Ubuntu 11.4更新管理器不可用
帖子发表于 : 2011-05-12 1:23 

注册: 2011-04-28 14:59
帖子: 15
送出感谢: 0 次
接收感谢: 1
cangzhang 写道:
你能解决?我都解决不了

我的更新管理器确实是可用了,你的不行说明你还不行吧。


页首
 用户资料  
 
13 楼 
 文章标题 : Re: Ubuntu 11.4更新管理器不可用
帖子发表于 : 2011-05-16 10:23 

注册: 2011-05-16 10:20
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我已经解决了
Sudo rm/var/lib/apt/list/*-vf
Sudo apt-get update
谢谢大家的帮忙。 :em09[/quote]


我也按照这个解决了,多谢多谢~~


页首
 用户资料  
 
14 楼 
 文章标题 : Re: Ubuntu 11.4更新管理器不可用
帖子发表于 : 2011-05-19 8:17 

注册: 2010-08-22 20:59
帖子: 123
送出感谢: 0 次
接收感谢: 0 次
我按这个还没解决,怎么回事呢?


页首
 用户资料  
 
15 楼 
 文章标题 : Re: Ubuntu 11.4更新管理器不可用
帖子发表于 : 2011-05-19 8:20 

注册: 2010-08-22 20:59
帖子: 123
送出感谢: 0 次
接收感谢: 0 次
sorry,又好了,解决了,多谢 :em09


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 21 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译