请问,如何安装gnome3呢?

重复贴和参考价值不大的帖子,版主维护
回复
edseas
帖子: 16
注册时间: 2011-04-17 13:38
送出感谢: 0
接收感谢: 0

请问,如何安装gnome3呢?

#1

帖子 edseas » 2011-06-12 11:15

哇!各位请教教小弟,我想安装GTK头文件,学习点界面编程。在网上找了教程,
apt-get install pkg-config #用于在编译GTK程序时自动找出头文件及库文件位置
apt-get install devhelp #这将安装 devhelp GTK文档查看程序
apt-get install libglib2.0-doc libgtk2.0-doc #这将安装 gtk/glib 的API参考手册及其它帮助文档
apt-get install glade libglade2-dev #这将安装基于GTK的界面GTK是开发Gnome窗口的c/c++语言图形库。
apt-get install libgtk2.0*, gtk+2.0所需的所有文件统通下载安装完毕。

但是,安装的时候却提示
“下列软件包有未满足的依赖关系:
gnome-core-devel : 依赖: python-gnome2-desktop-dev (>= 2.30) 但是它将不会被安装
E: 破损的软件包

这是为什么呢?
我用的是ubuntu11.04,桌面是gome3
蔡万钊
帖子: 420
注册时间: 2009-02-01 19:41
送出感谢: 0
接收感谢: 2 次
联系:

Re: 请问,如何安装gnome3呢?

#2

帖子 蔡万钊 » 2011-06-12 11:46

ubuntu 不适合做开发。
头像
sevk
帖子: 2059
注册时间: 2007-05-08 16:26
系统: arch
来自: 火星内核某分子内某原子核内
送出感谢: 20 次
接收感谢: 6 次
联系:

Re: 请问,如何安装gnome3呢?

#3

帖子 sevk » 2011-06-12 19:53

[分享]C/C++开发环境搭建指南 viewtopic.php?t=85683

Gtk与Qt编译环境安装与配置 http://wiki.ubuntu.org.cn/Gtk%E4%B8%8EQ ... F.E5.A2.83

或 google 关键字: 开发环境 ubuntu wiki gtk
笔记本 :
F208S : gentoo
A460P i3G D6 : UBUNTU + WIN7
UN43D1 : UBUNTU + WIN7
1000人超级QQ群 LINUX + WIN : 31465544 或 18210387
回复

回到 “归档贴”