无法安装 svn

重复贴和参考价值不大的帖子,版主维护
回复
newren123
帖子: 2
注册时间: 2011-06-15 21:07
送出感谢: 0
接收感谢: 0

无法安装 svn

#1

帖子 newren123 » 2011-06-15 21:10

Any clue? :em03

@ubuntu:~$ sudo apt-get install subversion

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
subversion : Depends: libsvn1 (= 1.6.12dfsg-4ubuntu2.1) but it is not going to be installed
E: Broken packages
上次由 newren123 在 2011-06-15 21:20,总共编辑 1 次。
头像
monk
帖子: 19507
注册时间: 2010-01-28 10:45
送出感谢: 6 次
接收感谢: 33 次

Re: could not install svn

#2

帖子 monk » 2011-06-15 21:13

代码: 全选

sudo apt-get install libsvn1 subversion

*********宁静致远*********
如果我说的有什么不对,请看签名第一行
newren123
帖子: 2
注册时间: 2011-06-15 21:07
送出感谢: 0
接收感谢: 0

Re: could not install svn

#3

帖子 newren123 » 2011-06-15 21:19

还不行啊

sudo apt-get install libsvn1 subversion
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libsvn1 : Depends: libaprutil1 (>= 1.3.2+dfsg) but it is not installable
E: Broken packages

monk 写了:

代码: 全选

sudo apt-get install libsvn1 subversion
头像
monk
帖子: 19507
注册时间: 2010-01-28 10:45
送出感谢: 6 次
接收感谢: 33 次

Re: 无法安装 svn

#4

帖子 monk » 2011-06-15 21:35

用 aptitude 试试

*********宁静致远*********
如果我说的有什么不对,请看签名第一行
头像
liangyongsheng1990
帖子: 171
注册时间: 2008-11-05 17:37
送出感谢: 9 次
接收感谢: 0

Re: could not install svn

#5

帖子 liangyongsheng1990 » 2011-06-15 21:43

newren123 写了:还不行啊

sudo apt-get install libsvn1 subversion
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libsvn1 : Depends: libaprutil1 (>= 1.3.2+dfsg) but it is not installable
E: Broken packages

monk 写了:

代码: 全选

sudo apt-get install libsvn1 subversion
"libsvn1 : Depends: libaprutil1 (>= 1.3.2+dfsg) but it is not installable"
libsvn1依赖libaprutil1,在前面加上libaprutil1试试,现在没用ubuntu,不确定有没有这个包,但是一定有名字差不多的包,输入时可以用tab列出列表,从中找到libaprutil1或者和他最接近的。
希望大家在问题解决之后能够在标题处添加已解决
南无阿弥陀佛
回复

回到 “归档贴”