ruby 错误 求解!!!!!!!!!!!!!!!!!!!!!

重复贴和参考价值不大的帖子,版主维护
回复
头像
wangshuxun25
帖子: 342
注册时间: 2009-02-23 17:55
送出感谢: 0
接收感谢: 0
联系:

ruby 错误 求解!!!!!!!!!!!!!!!!!!!!!

#1

帖子 wangshuxun25 » 2011-06-16 12:01

These are the possible causes:

*
There may be a syntax error in the application's code. Please check for such errors and fix them.
*
A required library may not installed. Please install all libraries that this application requires.
*
The application may not be properly configured. Please check whether all configuration files are written correctly, fix any incorrect configurations, and restart this application.
*
A service that the application relies on (such as the database server or the Ferret search engine server) may not have been started. Please start that service.

Further information about the error may have been written to the application's log file. Please check it in order to analyse the problem.

Error message:
undefined local variable or method `acts_as_taggable' for #<Class:0xb7b15f78>
Exception class:
NameError
Application root:
/home/school/rails
Backtrace:
# File Line Location
0 /usr/local/ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.2/lib/active_record/base.rb 1964 in `method_missing_without_paginate'
1 /home/school/rails/vendor/plugins/will_paginate/lib/will_paginate/finder.rb 166 in `method_missing'
2 /home/school/rails/app/models/content.rb 3
3 /usr/local/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb 29 in `gem_original_require'
4 /usr/local/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb 29 in `require'
5 /usr/local/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb 158 in `require'
6 /usr/local/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb 265 in `require_or_load'
7 /usr/local/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb 224 in `depend_on'
8 /usr/local/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb 136 in `require_dependency'
9 /usr/local/ruby/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/initializer.rb 393 in `load_application_classes'
10 /usr/local/ruby/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/initializer.rb 392 in `each'
11 /usr/local/ruby/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/initializer.rb 392 in `load_application_classes'
12 /usr/local/ruby/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/initializer.rb 390 in `each'
13 /usr/local/ruby/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/initializer.rb 390 in `load_application_classes'
14 /usr/local/ruby/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/initializer.rb 195 in `process'
15 /usr/local/ruby/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/initializer.rb 113 in `send'
16 /usr/local/ruby/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/initializer.rb 113 in `run'
17 /home/school/rails/config/environment.rb 10
18 /usr/local/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb 29 in `gem_original_require'
19 /usr/local/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb 29 in `require'
20 /usr/local/ruby/lib/ruby/gems/1.8/gems/passenger-3.0.7/lib/phusion_passenger/classic_rails/application_spawner.rb 222 in `preload_application'
21 /usr/local/ruby/lib/ruby/gems/1.8/gems/passenger-3.0.7/lib/phusion_passenger/classic_rails/application_spawner.rb 181 in `initialize_server'
22 /usr/local/ruby/lib/ruby/gems/1.8/gems/passenger-3.0.7/lib/phusion_passenger/utils.rb 572 in `report_app_init_status'
23 /usr/local/ruby/lib/ruby/gems/1.8/gems/passenger-3.0.7/lib/phusion_passenger/classic_rails/application_spawner.rb 174 in `initialize_server'
24 /usr/local/ruby/lib/ruby/gems/1.8/gems/passenger-3.0.7/lib/phusion_passenger/abstract_server.rb 204 in `start_synchronously'
25 /usr/local/ruby/lib/ruby/gems/1.8/gems/passenger-3.0.7/lib/phusion_passenger/abstract_server.rb 180 in `start'
26 /usr/local/ruby/lib/ruby/gems/1.8/gems/passenger-3.0.7/lib/phusion_passenger/classic_rails/application_spawner.rb 149 in `start'
27 /usr/local/ruby/lib/ruby/gems/1.8/gems/passenger-3.0.7/lib/phusion_passenger/spawn_manager.rb 219 in `spawn_rails_application'
28 /usr/local/ruby/lib/ruby/gems/1.8/gems/passenger-3.0.7/lib/phusion_passenger/abstract_server_collection.rb 132 in `lookup_or_add'
29 /usr/local/ruby/lib/ruby/gems/1.8/gems/passenger-3.0.7/lib/phusion_passenger/spawn_manager.rb 214 in `spawn_rails_application'
30 /usr/local/ruby/lib/ruby/gems/1.8/gems/passenger-3.0.7/lib/phusion_passenger/abstract_server_collection.rb 82 in `synchronize'
31 /usr/local/ruby/lib/ruby/gems/1.8/gems/passenger-3.0.7/lib/phusion_passenger/abstract_server_collection.rb 79 in `synchronize'
32 /usr/local/ruby/lib/ruby/gems/1.8/gems/passenger-3.0.7/lib/phusion_passenger/spawn_manager.rb 213 in `spawn_rails_application'
33 /usr/local/ruby/lib/ruby/gems/1.8/gems/passenger-3.0.7/lib/phusion_passenger/spawn_manager.rb 132 in `spawn_application'
34 /usr/local/ruby/lib/ruby/gems/1.8/gems/passenger-3.0.7/lib/phusion_passenger/spawn_manager.rb 275 in `handle_spawn_application'
35 /usr/local/ruby/lib/ruby/gems/1.8/gems/passenger-3.0.7/lib/phusion_passenger/abstract_server.rb 357 in `__send__'
36 /usr/local/ruby/lib/ruby/gems/1.8/gems/passenger-3.0.7/lib/phusion_passenger/abstract_server.rb 357 in `server_main_loop'
37 /usr/local/ruby/lib/ruby/gems/1.8/gems/passenger-3.0.7/lib/phusion_passenger/abstract_server.rb 206 in `start_synchronously'
38 /usr/local/ruby/lib/ruby/gems/1.8/gems/passenger-3.0.7//helper-scripts/passenger-spawn-server 99
我的linux网站:http://www.kudouzi.com 欢迎访问!!!
我的QQ:53273291 敬请骚扰
头像
wangshuxun25
帖子: 342
注册时间: 2009-02-23 17:55
送出感谢: 0
接收感谢: 0
联系:

Re: ruby 错误 求解!!!!!!!!!!!!!!!!!!!!!

#2

帖子 wangshuxun25 » 2011-06-16 12:02

速度求解 不要没人理我!!!!!

[root@localhost public]# gem list

*** LOCAL GEMS ***

actionmailer (2.3.2, 1.2.5)
actionpack (2.3.2, 1.12.5)
actionwebservice (1.1.6)
activerecord (2.3.2, 1.14.4)
activeresource (2.3.2)
activesupport (2.3.2, 1.3.1)
acts-as-taggable-on (2.0.6)
acts_as_taggable (2.0.2)
color (1.4.1)
columnize (0.3.3)
daemon_controller (0.2.6)
fastercsv (1.5.4)
fastthread (1.0.7)
hoe (2.9.4)
htmlentities (4.3.0)
httpclient (2.2.0)
kana (0.2.0)
linecache (0.45)
macaddr (1.0.0)
mini_magick (3.3)
mkrf (0.2.3)
mysql (2.8.1)
passenger (3.0.7)
pdf-writer (1.1.8)
rack (1.2.2)
rails (2.3.2, 1.1.6)
rake (0.8.7)
rmagick (1.15.10)
rqrcode (0.3.3)
rspec (1.3.0)
ruby-debug (0.10.4)
ruby-debug-base (0.10.4)
rubygems-update (1.4.2, 1.3.7)
subexec (0.1.0)
transaction-simple (1.4.0)
uuid (2.3.2)
uuidtools (1.0.1)
xmlparser (0.6.81)
zip (2.0.2)
我的linux网站:http://www.kudouzi.com 欢迎访问!!!
我的QQ:53273291 敬请骚扰
头像
wangshuxun25
帖子: 342
注册时间: 2009-02-23 17:55
送出感谢: 0
接收感谢: 0
联系:

Re: ruby 错误 求解!!!!!!!!!!!!!!!!!!!!!

#3

帖子 wangshuxun25 » 2011-06-16 12:03

再现等~
我的linux网站:http://www.kudouzi.com 欢迎访问!!!
我的QQ:53273291 敬请骚扰
头像
wangshuxun25
帖子: 342
注册时间: 2009-02-23 17:55
送出感谢: 0
接收感谢: 0
联系:

Re: ruby 错误 求解!!!!!!!!!!!!!!!!!!!!!

#4

帖子 wangshuxun25 » 2011-06-16 12:43

为什么没有人来帮我?>!!!!!!!!!!!!!!!!!!!!!!!!111
我的linux网站:http://www.kudouzi.com 欢迎访问!!!
我的QQ:53273291 敬请骚扰
头像
wangshuxun25
帖子: 342
注册时间: 2009-02-23 17:55
送出感谢: 0
接收感谢: 0
联系:

Re: ruby 错误 求解!!!!!!!!!!!!!!!!!!!!!

#5

帖子 wangshuxun25 » 2011-06-16 14:02

:em20
我的linux网站:http://www.kudouzi.com 欢迎访问!!!
我的QQ:53273291 敬请骚扰
头像
月下叹逍遥
论坛版主
帖子: 33994
注册时间: 2010-10-07 14:23
系统: Archdows10
来自: 某系某星某洲某国某省某市
送出感谢: 8 次
接收感谢: 63 次
联系:

Re: ruby 错误 求解!!!!!!!!!!!!!!!!!!!!!

#6

帖子 月下叹逍遥 » 2011-06-16 14:25

好吧,我表示不会…………
帮顶了……
心似浮云常自在,意如流水任东西。
此事背后一定有个天大的咪咪
广告:
1、走过路过,不要错过,dropbox网盘2.25G大放送
py大法好,退C保平安
java多妖孽,VB本异端
日诵一千遍,快活似神仙
回复

回到 “归档贴”