当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : TXT乱码了
帖子发表于 : 2011-06-21 17:02 

注册: 2011-06-01 15:43
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
打开TXT文档都是乱码 必须每次都要这样操作吗

在终端输入:
gconf-editor //调出gconf-edit
然后依次点开:
apps->gedit-2->preferences->encodings
双击encodings中的auto-detected
在弹开的对话框中加入
GB18030,GBK,GB2312

有没有更好的方法或设置了


大家试试这个附件


附件:
食物中毒(不能一起吃的食物).txt [10.8 KiB]
被下载 7 次
页首
 用户资料  
 
2 楼 
 文章标题 : Re: TXT乱码了
帖子发表于 : 2011-06-21 17:03 
头像

注册: 2010-10-07 14:23
帖子: 33999
地址: 某系某星某洲某国某省某市
系统: Archdows10
送出感谢: 29
接收感谢: 151
geany……


_________________
心似浮云常自在,意如流水任东西。
此事背后一定有个天大的咪咪
广告:
1、走过路过,不要错过,dropbox网盘2.25G大放送
py大法好,退C保平安
java多妖孽,VB本异端
日诵一千遍,快活似神仙


页首
 用户资料  
 
3 楼 
 文章标题 : Re: TXT乱码了
帖子发表于 : 2011-06-21 17:04 
头像

注册: 2010-09-13 19:04
帖子: 1404
地址: 0xFF00EE
送出感谢: 1
接收感谢: 3
差不多就是这个方法了


_________________
qq旋风离线空间下载程序
漂亮的fcitx皮肤
Fcitx皮肤合集


页首
 用户资料  
 
4 楼 
 文章标题 : Re: TXT乱码了
帖子发表于 : 2011-06-21 17:11 

注册: 2008-01-11 17:02
帖子: 12127
送出感谢: 1
接收感谢: 6
指定编码

gedit --encoding=GB2312 xx.txt


_________________
你往幸福的方向挥挥手,从此我便追随你永不回头。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: TXT乱码了
帖子发表于 : 2011-06-21 17:13 
头像

注册: 2009-10-16 22:46
帖子: 18958
地址: finland
送出感谢: 28
接收感谢: 48
iconv转码也行 :em04 :em04


_________________
>>>>推Ubuntu 桌面培训~~<<<<
>>>>想加入/了解gimp汉化吗,点我吧~<<<<
——————————————————————
不推荐wubi,也不推荐你给别人推荐wubi…………
随心而为的感觉真好……
强推mayhem!!
强推ensiferum


页首
 用户资料  
 
6 楼 
 文章标题 : Re: TXT乱码了
帖子发表于 : 2011-06-21 17:22 
头像

注册: 2008-12-06 10:38
帖子: 4570
系统: Arch
送出感谢: 23
接收感谢: 31
抓码还是算了吧,拿到wino还要转回去,换个编辑器好了
话说我记得8点几9点几的时候不会乱码挖,抽那门子疯这是


页首
 用户资料  
 
7 楼 
 文章标题 : Re: TXT乱码了
帖子发表于 : 2011-06-21 21:42 

注册: 2011-03-17 16:43
帖子: 10
系统: windows7,ubuntu
送出感谢: 1
接收感谢: 0 次
复制以下命令到终端中,然后回车即可:

gconftool-2 --set --type=list --list-type=string /apps/gedit-2/preferences/encodings/auto_detected "[UTF-8,CURRENT,GB18030,BIG5-HKSCS,UTF-16]"


_________________
-------------------------------------------
设身处地,推己及人。
-------------------------------------------


页首
 用户资料  
 
8 楼 
 文章标题 : Re: TXT乱码了
帖子发表于 : 2011-06-22 11:23 
头像

注册: 2011-06-22 11:17
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我找到的答案,照做后成功:
windows下简体中文多用gb2312编码 (或gbk, gb18030), linux下多用utf8编码,有点区别。ALT+F2打开运行对话框,运行代码:
代码:
gconf-editor

展开“/apps/gedit-2/preferences/encodings/”。
编辑右侧的“auto_detected”将"GB18030”添加到最顶上。以后文本编辑器就可以正常显示中文了。
上面修改的是 gedit, 要是用其它文本编辑器要改相应的设置才行。比如 kate 就要在设置里改。总之要用 gb18030 或者 gbk, gb2312等打开windows 的 txt 才不会乱码。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: TXT乱码了
帖子发表于 : 2011-06-22 13:25 
头像

注册: 2008-09-13 19:17
帖子: 7789
系统: Arch Linux (x86_64)
送出感谢: 10
接收感谢: 77
听说leafpad能好点


_________________
博客:http://www.lainme.com


页首
 用户资料  
 
10 楼 
 文章标题 : Re: TXT乱码了
帖子发表于 : 2011-06-22 13:32 
头像

注册: 2009-01-06 15:18
帖子: 13005
地址: 人间
送出感谢: 1
接收感谢: 24
就1L的办法了


_________________
“有一种被人抛诸脑后的过去,包含一些不该遗忘的点点滴滴。欢笑之余,我将故旧拾起,才刹见自己的薄情。人世间似乎存在着某种公平,每个人都曾被抛掷在他人的遗忘中;而今你所有哽咽难宣的话语,也正是你曾为人所期盼,却永远听不见的字句。” —赫曼 赫塞


页首
 用户资料  
 
11 楼 
 文章标题 : Re: TXT乱码了
帖子发表于 : 2011-06-22 17:08 
头像

注册: 2011-06-07 14:20
帖子: 3866
系统: Mint18
送出感谢: 17
接收感谢: 65
果断用leafpad打开就行了,没一点问题。。。


_________________
wiki: ubuntu 技巧


页首
 用户资料  
 
12 楼 
 文章标题 : Re: TXT乱码了
帖子发表于 : 2011-06-22 20:02 

注册: 2008-05-09 12:51
帖子: 202
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
kate从来不乱码。


页首
 用户资料  
 
13 楼 
 文章标题 : Re: TXT乱码了
帖子发表于 : 2011-06-22 22:35 
头像

注册: 2010-04-07 17:49
帖子: 159
送出感谢: 0 次
接收感谢: 0 次
openoffice我这样打开的


页首
 用户资料  
 
14 楼 
 文章标题 : Re: TXT乱码了
帖子发表于 : 2011-06-23 18:09 

注册: 2011-02-24 20:04
帖子: 153
送出感谢: 1
接收感谢: 0 次
leafpad无压力


页首
 用户资料  
 
15 楼 
 文章标题 : Re: TXT乱码了
帖子发表于 : 2011-06-23 19:42 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
leafpad gvim都可以


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译