当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 搞了一个下午,6.06-7.04-7.10两级跳基本完成
帖子发表于 : 2007-06-23 2:43 

注册: 2006-01-19 10:33
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
之所以是基本完成,是因为新的2.6.22的内核还不知道哪不对,启动不了,用老版本的内核配新版本的软件可以正常使用了。

前段时间由于要编程,所以不得不在笔记本上也要一个LINUX,当然是UBUNTU首选了,从5.04一直玩上来的,后来毕业后台式机给家里了,里面的ubuntu自然报废了,想当年也是5.04到测试开发中的6.06折腾老半天的

光盘装了6.06,总觉得不够新,都一年了,就跳跃升级到7.04,结果生出来gnome字符全部是方框了,啥都干不了,中文英文全是,放了一个星期,今天才看到7.10已经可以测试了,毫不犹豫把源改到了gutsy,开始升,也不管上次7.04升到哪了,哪些升了哪些没升


下载到是很快,10分钟全部下完了,400-600M吧,具体不记得了

然后遇到了如下问题:

Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
bicyclerepair: Depends: python-central (>= 0.5.8) but it is not installed
gnome-app-install: Depends: python-central (>= 0.5.8) but it is not installed
Depends: python-gtkhtml2 but it is not installed
Depends: python-gconf but it is not installed
Depends: python-apt (>= 0.6.20) but 0.6.16.2ubuntu8.1 is in stalled
Depends: app-install-data (>= 0.4.0) but 0.3.31 is installe d
Depends: python-gtk2 (>= 2.10.1) but 2.8.6-0ubuntu1 is inst alled
Depends: software-properties-gtk but it is not installed
Depends: sexy-python but it is not installed
gnome-keyring: Depends: libgtk2.0-0 (>= 2.11.3) but 2.8.20-0ubuntu1.1 is insta lled
hal-device-manager: Depends: hwdb-client-gnome but it is not installed
language-selector: Depends: python-central (>= 0.5.8) but it is not installed
language-selector-common: Depends: python-central (>= 0.5.8) but it is not ins talled
libgnome-desktop-2: Depends: libbonoboui2-0 (>= 2.15.1) but 2.14.0-0ubuntu1 is installed
Depends: libgnome2-0 (>= 2.17.3) but 2.14.1-0ubuntu2 is in stalled
Depends: libgnomeui-0 (>= 2.17.1) but 2.14.1-0ubuntu3 is i nstalled
Depends: libgnomevfs2-0 (>= 1:2.17.90) but 2.14.2-0ubuntu1 is installed
Depends: libgtk2.0-0 (>= 2.11.3) but 2.8.20-0ubuntu1.1 is installed
libgnomecanvas2-0: Depends: libgtk2.0-0 (>= 2.10.3) but 2.8.20-0ubuntu1.1 is i nstalled
libgnomeprintui2.2-0: Depends: libgtk2.0-0 (>= 2.10.3) but 2.8.20-0ubuntu1.1 i s installed
libgtk2.0-bin: Depends: libgtk2.0-0 (>= 2.11.4-0ubuntu1) but 2.8.20-0ubuntu1.1 is installed
libgtksourceview1.0-0: Depends: libgtk2.0-0 (>= 2.10.3) but 2.8.20-0ubuntu1.1 is installed
libmetacity0: Depends: libgtk2.0-0 (>= 2.11.3) but 2.8.20-0ubuntu1.1 is instal led
Depends: metacity-common (>= 1:2.19) but it is not installed
Depends: metacity-common (< 1:2.20) but it is not installed
libnautilus-burn4: Depends: libgtk2.0-0 (>= 2.10.3) but 2.8.20-0ubuntu1.1 is i nstalled
libnotify1: Depends: libgtk2.0-0 (>= 2.10.3) but 2.8.20-0ubuntu1.1 is installe d
libpanel-applet2-0: Depends: libbonoboui2-0 (>= 2.15.1) but 2.14.0-0ubuntu1 is installed
Depends: libgnome2-0 (>= 2.17.3) but 2.14.1-0ubuntu2 is in stalled
Depends: libgnomeui-0 (>= 2.17.1) but 2.14.1-0ubuntu3 is i nstalled
Depends: libgnomevfs2-0 (>= 1:2.17.90) but 2.14.2-0ubuntu1 is installed
Depends: libgtk2.0-0 (>= 2.11.3) but 2.8.20-0ubuntu1.1 is installed
librsvg2-2: Depends: libgtk2.0-0 (>= 2.10.3) but 2.8.20-0ubuntu1.1 is installe d
librsvg2-common: Depends: gtk2.0-binver-2.10.0
Depends: libgtk2.0-0 (>= 2.10.3) but 2.8.20-0ubuntu1.1 is ins talled
libtotem-plparser7: Depends: libgnomevfs2-0 (>= 1:2.17.90) but 2.14.2-0ubuntu1 is installed
Depends: libgtk2.0-0 (>= 2.10.3) but 2.8.20-0ubuntu1.1 is installed
libwnck22: Depends: libgtk2.0-0 (>= 2.11.3) but 2.8.20-0ubuntu1.1 is installed
python-gnome2-extras: Depends: libbonoboui2-0 (>= 2.15.1) but 2.14.0-0ubuntu1 is installed
Depends: libgda3-3 but it is not installed
Depends: libgdl-gnome-1-0 but it is not installed
Depends: libgnome2-0 (>= 2.17.3) but 2.14.1-0ubuntu2 is installed
Depends: libgnomeui-0 (>= 2.17.1) but 2.14.1-0ubuntu3 is installed
Depends: libgnomevfs2-0 (>= 1:2.17.90) but 2.14.2-0ubunt u1 is installed
Depends: libgtk2.0-0 (>= 2.11.2) but 2.8.20-0ubuntu1.1 i s installed
Depends: libnspr4-0d (>= 1.8.0.10) but it is not install ed
python-newt: Depends: python-central (>= 0.5.8) but it is not installed
python-support: Depends: python (>= 2.4.3-10) but 2.4.2-0ubuntu3 is installed
serpentine: Depends: python-central (>= 0.5.8) but it is not installed
Depends: python-gst0.10 (>= 0.10.4-4) but 0.10.4-0ubuntu1 is insta lled
Depends: python-gnome2 (>= 2.12.4-4) but 2.12.4-0ubuntu1 is instal led
Depends: python-gnome2-desktop (>= 2.14.0-3) but 2.14.0-0ubuntu2 i s installed
Depends: python-xml (>= 0.8.4-5) but 0.8.4-1ubuntu3 is installed
Depends: python-glade2 (>= 2.8.6-5) but 2.8.6-0ubuntu1 is installe d
ubuntu-desktop: Depends: avahi-autoipd but it is not installed
Depends: avahi-daemon but it is not installed
Depends: dcraw but it is not installed
Depends: genisoimage but it is not installed
Depends: ghostscript-x but it is not installed
Depends: gnome-keyring-manager but it is not installed
Depends: gtk2-engines but it is not installed
Depends: hwdb-client-gnome but it is not installed
Depends: libgl1-mesa-glx but it is not installed
Depends: libnss-mdns but it is not installed
Depends: openprinting-ppds but it is not installed
Depends: usplash-theme-ubuntu but it is not installed
Depends: wodim but it is not installed
Depends: xdg-user-dirs but it is not installed
Depends: xdg-user-dirs-gtk but it is not installed
Depends: xorg but it is not installed
Depends: xvnc4viewer but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by he ld packages.
E: Unable to correct dependencies

把它强制删除就好了,结果搞得我把GNOME也删没了,没办法,只好在console里面继续搞

还有个问题是一个软链接不能被deb包自动删除,deb包只会删目录(这么SB?),我就手工把那软链接删掉,然后再建立一个同名的目录,deb包这次知道去把它干掉了,就通过了

中间又遇到一个gtk2-engines的包在安装文件的时候,无法覆盖一个已经存在的配置文件的问题,我手工把那文件删了,还是不行,报告的错是什么操作系统内部争用造成的broken pipe,在网上搜了下,强制f覆盖写入




发现:升级完后gnome是2007.6.18才编译的2.19,然后系统可以播MP3了,RMVB能播声音了,但是还没图像

还有一堆问题,要继续整,比如关闭系统的splash是花屏的了,可能XORG还有点问题
然后启动的时候hardware drive一项是个fail


_________________
Ubuntu Gutsy
TOSHIBA A105-S4284
Processor: Intel® Dual® Processor T2050 1.60GHz
Memory: 1GB
Hard Drive: TOSHIBA 1032GSX 80G
Graphics:Intel® 945GM Express
Network:Intel®Pro/VE 100+Intel®Pro/Wireless 3945ABG


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-06-26 5:01 

注册: 2006-01-19 10:33
帖子: 62
送出感谢: 0 次
接收感谢: 0 次
firefox感觉不太流畅,不知道是不是我网速慢了

下到了w32codecs,所以播AVI已经没问题了,


_________________
Ubuntu Gutsy
TOSHIBA A105-S4284
Processor: Intel® Dual® Processor T2050 1.60GHz
Memory: 1GB
Hard Drive: TOSHIBA 1032GSX 80G
Graphics:Intel® 945GM Express
Network:Intel®Pro/VE 100+Intel®Pro/Wireless 3945ABG


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-07-09 15:29 
头像

注册: 2007-06-20 13:17
帖子: 71
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
把源改了就能升级到7.10版了吗?我也只有6.06的光盘,想升级;不过通过这种方法来升级感觉没底....


_________________
是否我,真的一无所有??


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译