[问题]升级出错了,请问怎么办?

重复贴和参考价值不大的帖子,版主维护
回复
chen8xu6tian6
帖子: 19
注册时间: 2006-07-10 18:55
送出感谢: 0
接收感谢: 0
联系:

[问题]升级出错了,请问怎么办?

#1

帖子 chen8xu6tian6 » 2007-08-22 23:13

boris@boris:~$ sudo apt-get dist-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在筹划升级... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 2 个软件包没有被完全安装或卸载。
需要下载 0B 的软件包。
解压缩后会消耗掉 0B 的额外空间。
您希望继续执行吗?[Y/n]y
正在设置 acpid (1.0.4-5ubuntu8) ...
* Loading ACPI modules... [ OK ]
* Starting ACPI services... invoke-rc.d: initscript acpid, action "start" failed.
dpkg:处理 acpid (--configure)时出错:
子进程 post-installation script 返回了错误号 1
dpkg:依赖关系问题使得 acpi-support 的配置工作不能继续:
acpi-support 依赖于 acpid (>= 1.0.4-1ubuntu4);然而:
软件包 acpid 还没有被配置。
dpkg:处理 acpi-support (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
acpid
acpi-support
E: Sub-process /usr/bin/dpkg returned an error code (1)
头像
依寻依然
帖子: 1617
注册时间: 2006-10-31 14:49
送出感谢: 0
接收感谢: 0

#2

帖子 依寻依然 » 2007-08-22 23:31

等明天再升级
Borders are meant to be crossed
luzefeng
帖子: 1
注册时间: 2007-05-08 13:07
送出感谢: 0
接收感谢: 0

#3

帖子 luzefeng » 2008-01-22 21:40

经摸索,发现只要先安如下步骤即可:
1. sudo apt-get remove acpid
2. sudo apt-get install acpid

因为升级的时候的acpid的版本是0.14 , 而删除后重新安装的版本是0.13.
linux2ubuntu
帖子: 78
注册时间: 2007-10-25 11:26
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 linux2ubuntu » 2008-04-22 23:27

搞定3Q
zmcqu
帖子: 2
注册时间: 2008-12-12 20:52
送出感谢: 0
接收感谢: 0

Re: [问题]升级出错了,请问怎么办?

#5

帖子 zmcqu » 2009-04-22 23:51

我也出现了跟楼主一样的问题
然后从新立得里面重新安装了acpi,acpid两个
acpi安装成功了,但是acpid安装出现了错误:E:acpid:子进程post-installation script 返回了错误1

有谁可以帮我解答一下
回复

回到 “归档贴”