升级到7.10,可MX400 显卡驱动还是不能用

重复贴和参考价值不大的帖子,版主维护
回复
xile
帖子: 29
注册时间: 2007-08-16 19:48
送出感谢: 0
接收感谢: 0

升级到7.10,可MX400 显卡驱动还是不能用

#1

帖子 xile » 2007-08-29 9:00

半个月前朋友给了张ubuntu 7.04的光盘,装上了,可显卡驱动不能用,翻遍了坛里的关于nvidia显卡的帖子,试遍了各种方法,死活装不上。本指望升级系统后可以解决,昨天把系统升级到了7.10,一切正常除了显卡驱动,现在没择了。只能将nvidia 改为 nv 才能进入x windows. 请高手帮帮忙,我接触linux才半个月,这个问题太有挑战性了!

配置:华硕P5PE主板,奔IV 3.06的 cpu,显卡 nvidia mx400

日志:
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
(EE) xf86OpenSerial: Cannot open device /dev/input/wacom
No such file or directory.

xorg.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Mon Apr 16 20:37:13 PDT 2007

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"
Inputdevice "stylus" "SendCoreEvents"
Inputdevice "cursor" "SendCoreEvents"
Inputdevice "eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
Fontpath "/usr/share/fonts/X11/misc"
Fontpath "/usr/share/fonts/X11/cyrillic"
Fontpath "/usr/share/fonts/X11/100dpi/:unscaled"
Fontpath "/usr/share/fonts/X11/75dpi/:unscaled"
Fontpath "/usr/share/fonts/X11/Type1"
Fontpath "/usr/share/fonts/X11/100dpi"
Fontpath "/usr/share/fonts/X11/75dpi"
Fontpath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "int10"
Load "vbe"
Load "glx"
Load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "SAMSUNG SyncMaster 711N"
Vendorname "Plug 'n' Play"
Modelname "Plug 'n' Play"
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
modeline "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
modeline "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
modeline "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
modeline "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
modeline "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
modeline "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
Gamma 1.0
EndSection

Section "Monitor"
Identifier "monitor1"
Vendorname "Plug 'n' Play"
Modelname "Plug 'n' Play"
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
modeline "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
modeline "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
modeline "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
modeline "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
modeline "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
modeline "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
Gamma 1.0
EndSection

Section "Device"
Identifier "nVidia Corporation NV11 [GeForce2 MX/MX 400]"
Boardname "NVIDIA GeForce2 DDR (generic)"
Busid "PCI:1:0:0"
Driver "nv"
Screen 0
Vendorname "NVIDIA"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
EndSection

Section "Device"
Identifier "device1"
Boardname "NVIDIA GeForce2 DDR (generic)"
Busid "PCI:1:0:0"
Driver "nvidia"
Screen 1
Vendorname "NVIDIA"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV11 [GeForce2 MX/MX 400]"
Monitor "SAMSUNG SyncMaster 711N"
Defaultdepth 24
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
SubSection "Display"
Depth 24
Virtual 1600 1200
Modes "1280x1024@60" "1280x960@75" "1280x960@60" "1400x1050@60" "1280x1024@75" "1600x1200@60" "1152x864@75" "1024x768@60" "1024x768@70" "1024x768@75" "832x624@75" "800x600@60" "800x600@75" "800x600@72" "640x480@75" "640x480@72" "640x480@60"
EndSubSection
EndSection

Section "Screen"

#
Identifier "screen1"
Device "device1"
Monitor "monitor1"
Defaultdepth 24
SubSection "Display"
Depth 24
Modes "640x480@60" "640x480@72" "640x480@75" "800x600@72" "800x600@75" "800x600@60" "832x624@75" "1024x768@75" "1024x768@70" "1024x768@60" "1152x864@75" "1280x1024@75" "1280x960@60" "1280x1024@60" "1280x960@75" "1400x1050@60" "1600x1200@60"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "ServerFlags"
EndSection
上次由 xile 在 2007-08-30 15:39,总共编辑 1 次。
头像
飞雪笑
帖子: 335
注册时间: 2007-03-14 16:21
送出感谢: 0
接收感谢: 0

#2

帖子 飞雪笑 » 2007-08-30 12:51

跟我显卡一样,我显卡很正常呀
我安装系统之后选择了那个受限驱动(在主菜单,首选项或者系统设置那里)
还按照置顶贴安装了3D桌面,很正常呀,漂亮
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#3

帖子 skyx » 2007-08-30 12:58

如果确认安装步骤正确

不排除是asus主板的原因,下面的消息未经证实:

论坛有人反映asus的主板比较怪,除非能搞到asus的专用驱动,否则不好搞定, 云云。。。


about61892.html&sid=539613c3cdf39b9db1d5376fe33b6df0
db_lobster 写了:IntelCPU有BUG。
换片CPU就OK。
我这边也有个装XP也频繁死机的。

华硕的板子比较个别,尽量少用它的东西。除非能搞到它自己的驱动。

我的理解是不能安装公版驱动的主板或显卡,都是比较怪的板卡,所以不能一竿子打倒所有asus的板子
no security measure is worth anything if an attacker has physical access to the machine
xile
帖子: 29
注册时间: 2007-08-16 19:48
送出感谢: 0
接收感谢: 0

#4

帖子 xile » 2007-08-30 15:15

安装过程应该没有问题,看样子搞定是困难了! 谢谢你们!
xile
帖子: 29
注册时间: 2007-08-16 19:48
送出感谢: 0
接收感谢: 0

#5

帖子 xile » 2007-08-30 15:19

飞雪笑 写了:跟我显卡一样,我显卡很正常呀
我安装系统之后选择了那个受限驱动(在主菜单,首选项或者系统设置那里)
还按照置顶贴安装了3D桌面,很正常呀,漂亮
我是那么选的,可重启后就是黑屏
xile
帖子: 29
注册时间: 2007-08-16 19:48
送出感谢: 0
接收感谢: 0

#6

帖子 xile » 2007-08-30 15:25

skyx 写了:如果确认安装步骤正确

不排除是asus主板的原因,下面的消息未经证实:

论坛有人反映asus的主板比较怪,除非能搞到asus的专用驱动,否则不好搞定, 云云。。。


about61892.html&sid=539613c3cdf39b9db1d5376fe33b6df0
db_lobster 写了:IntelCPU有BUG。
换片CPU就OK。
我这边也有个装XP也频繁死机的。

华硕的板子比较个别,尽量少用它的东西。除非能搞到它自己的驱动。

我的理解是不能安装公版驱动的主板或显卡,都是比较怪的板卡,所以不能一竿子打倒所有asus的板子
那我装asau的官方驱动试试
janker2lonely
帖子: 557
注册时间: 2007-01-09 11:09
来自: 廣州
送出感谢: 0
接收感谢: 2 次

#7

帖子 janker2lonely » 2007-08-30 16:58

哈,居然有人的硬件配置跟我的一模一样。
xile
帖子: 29
注册时间: 2007-08-16 19:48
送出感谢: 0
接收感谢: 0

#8

帖子 xile » 2007-08-30 20:47

janker2lonely 写了:哈,居然有人的硬件配置跟我的一模一样。
那你的显卡驱动装好了?
janker2lonely
帖子: 557
注册时间: 2007-01-09 11:09
来自: 廣州
送出感谢: 0
接收感谢: 2 次

#9

帖子 janker2lonely » 2007-08-31 13:55

xile 写了:
janker2lonely 写了:哈,居然有人的硬件配置跟我的一模一样。
那你的显卡驱动装好了?
没问题啊,6.10和7.04都正常,我现在用的是7.04,我们用的CPU真的是很经典,还有主板,呵呵。要不要看看我的桌面?
附件
.jpg
Screenshot-系统监视器.jpg
xile
帖子: 29
注册时间: 2007-08-16 19:48
送出感谢: 0
接收感谢: 0

#10

帖子 xile » 2007-08-31 14:24

好羡慕楼上,我改天再重装一次,其实我已经重装过两次了! 能不能告诉我你是怎么装的显卡驱动?
janker2lonely
帖子: 557
注册时间: 2007-01-09 11:09
来自: 廣州
送出感谢: 0
接收感谢: 2 次

#11

帖子 janker2lonely » 2007-08-31 14:50

xile 写了:好羡慕楼上,我改天再重装一次,其实我已经重装过两次了! 能不能告诉我你是怎么装的显卡驱动?
很简单,你把7.04装好,然后安装受限驱动就可以了,这么老的显卡,根本用不着上天入地的找驱动和安装方法的。我觉得很奇怪,你的配置跟我的一模一样,怎么你的那么难装上?!
头像
coffer
帖子: 673
注册时间: 2006-12-22 21:05
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 coffer » 2007-08-31 18:47

janker2lonely写道:
xile 写道:
好羡慕楼上,我改天再重装一次,其实我已经重装过两次了! 能不能告诉我你是怎么装的显卡驱动?



很简单,你把7.04装好,然后安装受限驱动就可以了,这么老的显卡,根本用不着上天入地的找驱动和安装方法的。我觉得很奇怪,你的配置跟我的一模一样,怎么你的那么难装上?!
7.10目前对Nvidia的老显卡在支持上有一些问题,如果是GF4以下的显卡,请耐心等待官方的新的升级文件 。
头像
syrano
帖子: 4313
注册时间: 2007-10-06 18:40
送出感谢: 0
接收感谢: 5 次

#13

帖子 syrano » 2007-12-18 16:36

用官方驱动
我的是GeForce2 MX/MX 400
回复

回到 “归档贴”