挂载NTFS分区的问题(比较奇怪)

重复贴和参考价值不大的帖子,版主维护
honeyfish
帖子: 22
注册时间: 2007-04-15 11:23
送出感谢: 0
接收感谢: 0

挂载NTFS分区的问题(比较奇怪)

#1

帖子 honeyfish » 2007-09-04 20:20

FSTAB中加载的NTFS分区无法显示中文文件名的目录和文件。
加了编码参数也没用。
而直接在SHELL使用命令,不用编码参数,也能顺利显示中文文件名的目录。 mount /dev/sda5 /media/sda5 -t ntfs

然后将该命令添加在rc.local中,仍旧无法显示中文文件名目录。


奇怪的问题。。。请问如何解决? :?
头像
lifeva
帖子: 133
注册时间: 2007-08-02 0:12
送出感谢: 0
接收感谢: 0

#2

帖子 lifeva » 2007-09-05 9:28

我的也是,只能看到英文的文件和文件夹。如果用ntfs-3g设置打开写选项,就能看到中文了。关掉写选项,中文消失。呵呵,应该还是NTFS支持的问题吧
oczero
帖子: 39
注册时间: 2006-11-24 16:50
送出感谢: 0
接收感谢: 0

#3

帖子 oczero » 2007-09-05 12:55

我刚发现这个问题呢~~比较奇怪
honeyfish
帖子: 22
注册时间: 2007-04-15 11:23
送出感谢: 0
接收感谢: 0

#4

帖子 honeyfish » 2007-09-05 18:16

lifeva 写了:我的也是,只能看到英文的文件和文件夹。如果用ntfs-3g设置打开写选项,就能看到中文了。关掉写选项,中文消失。呵呵,应该还是NTFS支持的问题吧



我在FSTAB添加RW参数,也不行阿。
头像
gdzhljw
帖子: 314
注册时间: 2007-05-19 23:18
来自: 广东珠海
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 gdzhljw » 2007-09-11 14:05

我的也有这个问题!?有没高手可以解决!
头像
aitilang
帖子: 1026
注册时间: 2007-04-28 21:38
送出感谢: 0
接收感谢: 0

#6

帖子 aitilang » 2007-09-11 14:34

lifeva 写了:我的也是,只能看到英文的文件和文件夹。如果用ntfs-3g设置打开写选项,就能看到中文了。关掉写选项,中文消失。呵呵,应该还是NTFS支持的问题吧

ntfs-config
thinkpad x61 2G DDR no cdrom
--------------------------------------------
ABS学习中
sed学习中
awk学习中
perl学习中
新手描述不清,老手猜测不到,胡乱指挥一通,后果难以预料
头像
gdzhljw
帖子: 314
注册时间: 2007-05-19 23:18
来自: 广东珠海
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 gdzhljw » 2007-09-11 14:48

我的系统是KUBUNTU7.10 T5
我也是看不到中文目录!一个字惨!!
先安装这两个: ntfs-config和ntfs-3g
我的是 ntfs-config 不起作用:
后来看到其它帖子就按下面改!
不能自动加载,我觉得是应该改/etc/fstab?这是我的ntfs分区设定:
加入以下代码:
/dev/hda5 /media/hda5 ntfs-3g silent,umask=0,locale=zh_CN.utf8 0 0

运行这个: gksu ntfs-config
我的是没有装gksu 也把这个gksu 也装上
后来重起就再试ntfs-config,终于两个选项出来了!都选上!可以了成攻了!可以看到中文目录了!感谢主!
honeyfish
帖子: 22
注册时间: 2007-04-15 11:23
送出感谢: 0
接收感谢: 0

#8

帖子 honeyfish » 2007-09-12 11:10

我觉得应该是silent这个参数的关系
头像
lyh
帖子: 113
注册时间: 2007-05-26 20:57
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 lyh » 2007-09-12 12:02

我的系统也是 kubuntu 7.10 T5 , 情况上同,我当是个人问题,结果大家都一样!
bz
帖子: 60
注册时间: 2007-03-13 8:57
送出感谢: 0
接收感谢: 0

#10

帖子 bz » 2007-09-12 12:27

应该把silient改成default吧!
honeyfish
帖子: 22
注册时间: 2007-04-15 11:23
送出感谢: 0
接收感谢: 0

#11

帖子 honeyfish » 2007-09-12 18:04

bz 写了:应该把silient改成default吧!

你说反了,DEFAULT改成SILENT,但是我不知道 SILENT的含义。
头像
Marvinux
帖子: 75
注册时间: 2005-07-20 10:24
来自: 广东顺德
送出感谢: 0
接收感谢: 0

#12

帖子 Marvinux » 2007-10-31 0:45

晕死,我也遇到这个问题,真不幸吖!但我更不幸的是,我已经修改过有关设置,却没有结果,仍然是开机自动加载分区显示不了中文,手动加载就OK。哎........真有点无耐
外星人在地球的简单生活。。
头像
Marvinux
帖子: 75
注册时间: 2005-07-20 10:24
来自: 广东顺德
送出感谢: 0
接收感谢: 0

#13

帖子 Marvinux » 2007-10-31 1:54

每次都要:
# sudo umount -a
# sudo mount -a
才能显示中文,真烦吖。

期待高手的出现...............
外星人在地球的简单生活。。
头像
Marvinux
帖子: 75
注册时间: 2005-07-20 10:24
来自: 广东顺德
送出感谢: 0
接收感谢: 0

#14

帖子 Marvinux » 2007-10-31 8:47

bz 写了:应该把silient改成default吧!


经测试,都是一样的。
外星人在地球的简单生活。。
头像
Marvinux
帖子: 75
注册时间: 2005-07-20 10:24
来自: 广东顺德
送出感谢: 0
接收感谢: 0

#15

帖子 Marvinux » 2007-10-31 12:28

高人,高人, 还没有出现吗?快快来帮忙吖。升级到现在,就只差这个问题了~~~~(可能还有很多没有发现的)
外星人在地球的简单生活。。
回复

回到 “归档贴”