当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装不上libc6-dev等编译器必须
帖子发表于 : 2007-09-12 1:13 

注册: 2007-03-25 1:18
帖子: 101
送出感谢: 0 次
接收感谢: 0 次
用的是7.04更改源后升级的7.10,结果想再安装g++的时候出了问题.

gary@gary-laptop:~$ sudo apt-get install libstdc++6-4.1-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libstdc++6-4.1-dev: 依赖: libc6-dev (>= 2.5) 但是它将不会被安装
E: 无法安装的软件包
gary@gary-laptop:~$ sudo apt-get install libc6-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.6.1-1ubuntu3) 但是 2.6.1-1ubuntu4 正要被安装
E: 无法安装的软件包
gary@gary-laptop:~$ sudo apt-get install libc6
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
libc6 已经是最新的版本了。
已经不需要下列自动安装的软件包:
libchewing3-data gimp-help-zh-cn gimp-help-common libchewing3
openoffice.org-l10n-zh-cn openoffice.org-l10n-zh-tw
openoffice.org-help-zh-cn mozilla-firefox-locale-zh-cn
openoffice.org-help-zh-tw mozilla-firefox-locale-zh-tw
使用 'apt-get autoremove' 来删除它们。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。


查看了下,我的libc6是2.6.1-1ubuntu4版本的,所以不满足依赖条件
so, how to fix that?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-21 14:56 

注册: 2007-04-09 15:30
帖子: 40
送出感谢: 0 次
接收感谢: 0 次
我也有这个问题,没人来解决一下吗?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-04-08 22:08 
头像

注册: 2008-03-27 19:04
帖子: 117
送出感谢: 0 次
接收感谢: 0 次
我也一样的问题阿,大虾解决下阿,谢了阿。。。。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-04-08 22:10 
头像

注册: 2006-05-03 0:39
帖子: 8273
地址: المريخ
送出感谢: 0 次
接收感谢: 1
尝试先执行
代码:
apt-get update


_________________
PHP是最好的语言!不服来战!


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-04-08 22:15 
头像

注册: 2008-03-27 19:04
帖子: 117
送出感谢: 0 次
接收感谢: 0 次
我自己解决了,我在测试源,没想到换了源就可以了,把依赖的都装上就ok了/。。
不换源 apt-get update 也没用的,换了再apt-get update后,就可以装你要装的依赖关系了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译