[问题]apt upgrade的时候dpkg 段错误

重复贴和参考价值不大的帖子,版主维护
回复
freehands
帖子: 15
注册时间: 2007-07-16 15:10
送出感谢: 0
接收感谢: 0

[问题]apt upgrade的时候dpkg 段错误

#1

帖子 freehands » 2007-09-19 23:12

最近的一次更新,终于遇到问题了。

freehands@ubuntu:~$ sudo apt-get upgrade
[sudo] password for freehands:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
下列的软件包的版本将保持不变:
apparmor-utils kdebluetooth kdegraphics-kfile-plugins koffice kpdf krita linux linux-headers-generic linux-image-generic
linux-restricted-modules-generic poppler-utils xvidcap
下列的软件包将被升级:
acpi-support akregator app-install-data apparmor apt apt-utils binutils binutils-static cupsys cupsys-bsd cupsys-client
cupsys-common dpkg dpkg-dev dselect evolution evolution-common evolution-plugins fuse-utils ghostscript ghostscript-x
gnome-doc-utils gnome-icon-theme gs-common gs-esp gs-esp-x hotkey-setup kaddressbook kalarm karm kdepim-kio-plugins
kdepim-kresources kdepim-wizards kmail kmailcvt knotes kontact korganizer laptop-mode-tools libc6 libc6-dev libc6-i686 libcairo2
libcairo2-dev libcupsimage2 libcupsys2 libcupsys2-dev libfreetype6 libfreetype6-dev libfuse2 libgcrypt11 libgcrypt11-dev
libgnome2-0 libgnome2-common libgnome2-dev libgnomecanvas2-0 libgnomecanvas2-common libgnomecanvas2-dev libgnomeprint2.2-0
libgnomeprint2.2-data libgnomeprintui2.2-0 libgnomeprintui2.2-common libgnomevfs2-0 libgnomevfs2-common libgnomevfs2-dev
libgpg-error-dev libgpg-error0 libgphoto2-2 libgphoto2-port0 libgs8 libieee1284-3 libjack0 libjack0.100.0-0 libkcal2b libkdepim1a
libkleopatra1 libkmime2 libkpimexchange1 libkpimidentities1 libksieve0 libktnef1 liblircclient0 libmimelib1c2a libntfs-3g5
libpanel-applet2-0 libvolume-id0 libvte-common libvte9 libxft-dev libxft2 linux-generic mcpp mozilla-firefox-locale-en-gb
mozilla-firefox-locale-zh-cn networkstatus nmap ntfs-3g python-launchpad-bugs udev volumeid x11-common xbase-clients xorg
xorg-dev xserver-xorg xserver-xorg-core xserver-xorg-dev xserver-xorg-input-all xserver-xorg-video-all xserver-xorg-video-ati
xserver-xorg-video-intel xutils
共升级了 112 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 12 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B/103MB 的软件包。
解压缩后会消耗掉 2359kB 的额外空间。
您希望继续执行吗?[Y/n]y
Traceback (most recent call last):
File "/usr/bin/apt-listchanges", line 231, in <module>
main()
File "/usr/bin/apt-listchanges", line 87, in main
seen = anydbm.open(config.save_seen, 'c')
File "/usr/lib/python2.5/anydbm.py", line 83, in open
return mod.open(file, flag, mode)
File "/usr/lib/python2.5/dbhash.py", line 16, in open
return bsddb.hashopen(file, flag, mode)
File "bsddb/__init__.py", line 310, in hashopen
bsddb.db.DBInvalidArgError: (22, 'Invalid argument -- /var/lib/apt/listchanges.db: unsupported hash version: 9')
正在从软件包中解出模板:100%
正在预设定软件包 ...
(正在读取数据库 ... 系统当前总共安装有 195091 个文件和目录。)
正预备替换 dpkg 1.14.5ubuntu13 (使用 .../dpkg_1.14.5ubuntu14_i386.deb) ...
段错误
freehands
帖子: 15
注册时间: 2007-07-16 15:10
送出感谢: 0
接收感谢: 0

#2

帖子 freehands » 2007-09-19 23:24

wget http://archive.ubuntu.com/ubuntu/pool/m ... 4_i386.deb
sudo dpkg -i dpkg_1.14.5ubuntu14_i386.deb

然后就可以继续升级了
回复

回到 “归档贴”