新下了7.10beta,但是ati的驱动有问题,3d打不开了

重复贴和参考价值不大的帖子,版主维护
回复
头像
outersky
帖子: 188
注册时间: 2007-04-25 10:07
来自: 上海
送出感谢: 0
接收感谢: 0

新下了7.10beta,但是ati的驱动有问题,3d打不开了

#1

帖子 outersky » 2007-09-28 22:11

安装了源里面的 ati.org 相关的包, xorg-driver-fglrx 等等
但是发现好像不支持我的 IBM T42的7300显卡。
以前7.04里面用的就好好的,compiz-fusion用的挺爽的,现在驱动上不去,啥也搞不了了,谁弄过?指点一下!

我运行:
fgl_glxgears
显示:

代码: 全选

Using GLX_SGIX_pbuffer
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  35
  Current serial number in output stream:  35
运行:
fglrxinfo
显示:

代码: 全选

display: :0.0  screen: 0
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI Radeon 20061018 AGP 4x x86/MMX/SSE2 TCL
OpenGL version string: 1.3 Mesa 7.0.1

xorg.conf

代码: 全选

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
#   sudo dpkg-reconfigure -phigh xserver-xorg
Section "Files"
EndSection

Section "Module"
	Disable		"dbe"
	Disable		"dri"
	Disable		"glx"
	Disable		"vbe"
	Load		"dri"
	Load		"glx"
	Load		"vbe"
	Load		"v4l"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"	"/dev/input/mice"
	Option		"Protocol"	"ImPS/2"
	Option		"ZAxisMapping"	"4 5"
	Option		"Emulate3Buttons"	"true"
EndSection


Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"	"/dev/psaux"
	Option		"Protocol"	"auto-dev"
	Option		"HorizScrollDelta"	"0"
EndSection

Section "Device"
	Identifier	"Failsafe Device"
	Boardname	"ATI Radeon (fglrx)"
	Busid		"PCI:1:0:0"
	Driver		"ati"
	Screen	0
	Vendorname	"ATI"
	Option		"MergedFB"	"off"
EndSection

Section "Monitor"
	Identifier	"Failsafe Monitor"
	Vendorname	"Generic LCD Display"
	Modelname	"LCD Panel 1024x768"
	Horizsync	31.5-48.5
	Vertrefresh	40-70
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
	Gamma	1.0
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"Failsafe Device"
	Monitor		"Failsafe Monitor"
	Defaultdepth	24
	SubSection "Display"
		Depth	24
		Virtual	1024	768
		Modes		"1024x768@60"	"800x600@60"	"800x600@56"	"640x480@60"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
  screen 0 "Default Screen" 0 0
	Inputdevice	"Generic Keyboard"
	Inputdevice	"Configured Mouse"
	Inputdevice	"Synaptics Touchpad"
EndSection
Section "device" # 
	Identifier	"device1"
	Boardname	"ATI Radeon (fglrx)"
	Busid		"PCI:1:0:0"
	Driver		"ati"
	Screen	1
	Vendorname	"ATI"
	Option		"MergedFB"	"off"
EndSection
Section "screen" # 
	Identifier	"screen1"
	Device		"device1"
	Defaultdepth	24
	Monitor		"monitor1"
EndSection
Section "monitor" # 
	Identifier	"monitor1"
	Gamma	1.0
EndSection
Section "ServerFlags"
EndSection

gmlbh
帖子: 406
注册时间: 2006-03-21 10:47
送出感谢: 0
接收感谢: 0

#2

帖子 gmlbh » 2007-09-28 23:28

这里
Section "Device"
Identifier "Failsafe Device"
Boardname "ATI Radeon (fglrx)"
Busid "PCI:1:0:0"
Driver "ati"
Screen 0
Vendorname "ATI"
Option "MergedFB" "off"
EndSection
要把ati改成fglrx才行的。
头像
outersky
帖子: 188
注册时间: 2007-04-25 10:07
来自: 上海
送出感谢: 0
接收感谢: 0

#3

帖子 outersky » 2007-09-28 23:51

gmlbh 写了:这里
Section "Device"
Identifier "Failsafe Device"
Boardname "ATI Radeon (fglrx)"
Busid "PCI:1:0:0"
Driver "ati"
Screen 0
Vendorname "ATI"
Option "MergedFB" "off"
EndSection
要把ati改成fglrx才行的。

试过了,不行啊,重启就进入了图形配置界面,让我重新配置显卡 :cry:

网上找了一些别的文章,试过了都不行,有谁在T42上面用7.10版本成功的?

我的7.04版本用的就好好的,奇怪了
回复

回到 “归档贴”