会话登录界面刷新率太低怎么办?[已解决]

重复贴和参考价值不大的帖子,版主维护
回复
sambodhi
帖子: 51
注册时间: 2006-10-30 9:29
送出感谢: 0
接收感谢: 0

会话登录界面刷新率太低怎么办?[已解决]

#1

帖子 sambodhi » 2007-10-19 16:45

我装的7.10,进入桌面后刷新率很低,我在终端运行了
gtf 1024 768 80
然后出来结果:
# 1024x768 @ 80.00 Hz (GTF) hsync: 64.32 kHz; pclk: 88.50 MHz
Modeline "1024x768_80.00" 88.50 1024 1088 1200 1376 768 769 772 804 -HSync +Vsync
我把 Modeline "1024x768_80.00" 88.50 1024 1088 1200 1376 768 769 772 804 -HSync +Vsync 加入到/etc/X11/xorg.conf中的一节,重启X后,可以调到85HZ了,但是还有一个问题,不知怎么解决,而这个问题在7.04却没有:
就是在会话登录界面,即输入用户名和密码的那块,屏幕非常闪烁!
怎么解决?
上次由 sambodhi 在 2007-11-08 10:27,总共编辑 1 次。
Conan304
帖子: 299
注册时间: 2006-12-15 16:11
来自: KM
送出感谢: 0
接收感谢: 0

#2

帖子 Conan304 » 2007-10-19 16:57

我的桌面分辨率倒是正常,但是登录界面刷新率还是很低。
上次由 Conan304 在 2007-10-19 17:02,总共编辑 1 次。
sambodhi
帖子: 51
注册时间: 2006-10-30 9:29
送出感谢: 0
接收感谢: 0

#3

帖子 sambodhi » 2007-10-19 16:58

2楼的,我就是这个现象,但7.04怎么没有这个现象啊?
sambodhi
帖子: 51
注册时间: 2006-10-30 9:29
送出感谢: 0
接收感谢: 0

#4

帖子 sambodhi » 2007-10-20 7:41

用力的顶!难道大家的会话登陆界面都不是60Hz的?
nofoghu
帖子: 198
注册时间: 2005-08-06 10:10
送出感谢: 0
接收感谢: 0

#5

帖子 nofoghu » 2007-10-21 1:38

进入桌面还可以
但登录界面确实如楼主所说
以前7.04可以的
用7.04升到7.10也可以,今天趁周末全新安装了7.10,结果就出现这个问题了
ggdxx
帖子: 17
注册时间: 2007-08-07 13:54
送出感谢: 0
接收感谢: 0

#6

帖子 ggdxx » 2007-10-21 14:37

我的登陆会话窗口也是这样!进入桌面设置好为1024*768,75HZ,可是会话窗口那里估计就900*600,60HZ,闪得厉害,字体也很小!

不知道该怎么解决.
头像
yjsword
帖子: 524
注册时间: 2007-03-14 20:33
来自: 南京
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 yjsword » 2007-10-21 15:23

我也遇到这个问题!
我是由于登录窗口的分辨率太高了才会使刷新频率降低!
后来改了xorg.conf,把高的分辨率删掉就好了!
至于分辨率正常情况下的刷新频率过低就不知道怎么半了:)
For Linux
http://blog.yjsword.com/
南無觀世音菩萨
Conan304
帖子: 299
注册时间: 2006-12-15 16:11
来自: KM
送出感谢: 0
接收感谢: 0

#8

帖子 Conan304 » 2007-10-21 23:04

yjsword 写了:我也遇到这个问题!
我是由于登录窗口的分辨率太高了才会使刷新频率降低!
后来改了xorg.conf,把高的分辨率删掉就好了!
至于分辨率正常情况下的刷新频率过低就不知道怎么半了:)
多谢楼上的提醒,我也是修改了/etx/X11/xorg.conf,删除过高的分辨率,现在登录窗口终于正常了。
建议修改的时候备份下xorg.conf以免出问题。
头像
lovewine
帖子: 1233
注册时间: 2006-03-25 10:36
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 lovewine » 2007-10-21 23:10

yjsword 写了:我也遇到这个问题!
我是由于登录窗口的分辨率太高了才会使刷新频率降低!
后来改了xorg.conf,把高的分辨率删掉就好了!
至于分辨率正常情况下的刷新频率过低就不知道怎么半了:)
再来一个笨方法:设定一个默认用户,就是你最常用的用户,进行自动登陆,那样你就不用输入用户名和密码了,也就没有烦恼了。
适合机子只给你一个人用的情况。
sambodhi
帖子: 51
注册时间: 2006-10-30 9:29
送出感谢: 0
接收感谢: 0

#10

帖子 sambodhi » 2007-10-22 8:27

yjsword 写了:我也遇到这个问题!
我是由于登录窗口的分辨率太高了才会使刷新频率降低!
后来改了xorg.conf,把高的分辨率删掉就好了!
至于分辨率正常情况下的刷新频率过低就不知道怎么半了:)
能具体说说怎么弄的吗?
sambodhi
帖子: 51
注册时间: 2006-10-30 9:29
送出感谢: 0
接收感谢: 0

#11

帖子 sambodhi » 2007-10-22 8:35

我的xorg.conf的文件如下,不知道要删除那些过高的分辨率?
请帮忙看一看:

代码: 全选

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"ZAxisMapping"		"4 5"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"stylus"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"		"stylus"
	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"eraser"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"		"eraser"
	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"cursor"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"		"cursor"
	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
EndSection

Section "Device"
	Identifier	"ATI Technologies Inc RV370 [Sapphire X550 Silent]"
	Driver		"ati"
	BusID		"PCI:4:0:0"
EndSection

Section "Monitor"
	Identifier	"通用显示器"
	Option		"DPMS"
        Modeline "1024x768_80.00"  88.50  1024 1088 1200 1376  768 769 772 804  -HSync +Vsync
	HorizSync	30-80
	VertRefresh	50-120
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Technologies Inc RV370 [Sapphire X550 Silent]"
	Monitor		"通用显示器"
	DefaultDepth	24
	SubSection "Display"
		Modes		"1024x768"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"

# Uncomment if you have a wacom tablet
#	InputDevice     "stylus"	"SendCoreEvents"
#	InputDevice     "cursor"	"SendCoreEvents"
#	InputDevice     "eraser"	"SendCoreEvents"
EndSection
sambodhi
帖子: 51
注册时间: 2006-10-30 9:29
送出感谢: 0
接收感谢: 0

#12

帖子 sambodhi » 2007-10-22 16:39

有人知道吗?
kfkhfj
帖子: 19
注册时间: 2006-11-06 0:26
送出感谢: 0
接收感谢: 0

#13

帖子 kfkhfj » 2007-10-29 19:18

更改一下xorg.conf里面的:
Section "Monitor"
Identifier "MAG 770AG"
Option "DPMS"
Horizsync 60-85
Vertrefresh 60-170

将Horizsync 和Vertrefresh后面的数值改成适合你显示器的
ASUS P4P800SE
P4 2.8C HT
KINGSTON 512MB*2
Geforce FX5200 128MB/128BIT
ST80GB/SATA+ST300GB/IDE+ST80GB/IDE
sambodhi
帖子: 51
注册时间: 2006-10-30 9:29
送出感谢: 0
接收感谢: 0

#14

帖子 sambodhi » 2007-11-08 10:26

kfkhfj 写了:更改一下xorg.conf里面的:
Section "Monitor"
Identifier "MAG 770AG"
Option "DPMS"
Horizsync 60-85
Vertrefresh 60-170

将Horizsync 和Vertrefresh后面的数值改成适合你显示器的
谢谢 Kfkhfj 兄弟,按照你的帖子,我恰当的提高了一些数值,重启X后,登录窗口不再闪烁,谢谢!!
回复

回到 “归档贴”