当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]请大虾帮我解决假死的问题
帖子发表于 : 2007-10-20 16:54 

注册: 2007-08-09 18:01
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
我在安装了7.10之后总会出现假死的情况整个gnome都卡住不动了 鼠标能动 但是点击什么都没反应 听声音感觉像硬盘一下子断电了一样 然后卡一会之后又恢复了.上午两个小时左右居然卡了10几次,我要崩溃了,引起这个假死的原因都有什么呢?

附上我本子的配置A8Jm A8H24Jm-SL
Intel Core Duo(Yonah) T2400(1.83G)
DDR2 667 2G
硬盘100G
NVIDIA GeForce Go7600 512M


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-20 16:55 

注册: 2007-08-09 18:01
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
还有点击Ctrl+alt+backspace也没有用,就是整个完全停止响应了 然后过一会恢复正常


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-10-20 16:57 

注册: 2007-08-09 18:01
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
我在使用7.04的时候也遇到假死情况,但是没有在7.10里这么频繁


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-10-20 17:04 
头像

注册: 2006-10-25 18:10
帖子: 2677
地址: 长沙
送出感谢: 0 次
接收感谢: 0 次
把桌面效果关掉试试看。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-10-20 19:01 

注册: 2007-08-09 18:01
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
桌面效果已经关了,另附上系统日志的信息
kern.log


Oct 20 18:54:56 zhuxiaoyu-laptop kernel: [ 769.580000] ata1.01: qc timeout (cmd 0xa0)
Oct 20 18:55:07 zhuxiaoyu-laptop kernel: [ 769.580000] ata1.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
Oct 20 18:55:07 zhuxiaoyu-laptop kernel: [ 769.580000] ata1.01: cmd a0/00:00:00:00:20/00:00:00:00:00/b0 tag 0 cdb 0x43 data 12 in
Oct 20 18:55:07 zhuxiaoyu-laptop kernel: [ 769.580000] res 51/20:03:00:00:00/00:00:00:00:00/b0 Emask 0x5 (timeout)
Oct 20 18:55:07 zhuxiaoyu-laptop kernel: [ 774.620000] ata1: port is slow to respond, please be patient (Status 0xd0)
Oct 20 18:55:07 zhuxiaoyu-laptop kernel: [ 779.604000] ata1: device not ready (errno=-16), forcing hardreset
Oct 20 18:55:07 zhuxiaoyu-laptop kernel: [ 779.604000] ata1: soft resetting port
Oct 20 18:55:07 zhuxiaoyu-laptop kernel: [ 779.964000] ata1.00: configured for UDMA/100
Oct 20 18:55:07 zhuxiaoyu-laptop kernel: [ 780.152000] ata1.01: configured for UDMA/33
Oct 20 18:55:07 zhuxiaoyu-laptop kernel: [ 780.152000] ata1: EH complete
Oct 20 18:55:07 zhuxiaoyu-laptop kernel: [ 780.168000] sd 0:0:0:0: [sda] 195371568 512-byte hardware sectors (100030 MB)
Oct 20 18:55:07 zhuxiaoyu-laptop kernel: [ 780.184000] sd 0:0:0:0: [sda] Write Protect is off
Oct 20 18:55:07 zhuxiaoyu-laptop kernel: [ 780.184000] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
Oct 20 18:55:07 zhuxiaoyu-laptop kernel: [ 780.200000] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Oct 20 18:55:07 zhuxiaoyu-laptop kernel: [ 780.224000] sd 0:0:0:0: [sda] 195371568 512-byte hardware sectors (100030 MB)
Oct 20 18:55:07 zhuxiaoyu-laptop kernel: [ 780.236000] sd 0:0:0:0: [sda] Write Protect is off
Oct 20 18:55:07 zhuxiaoyu-laptop kernel: [ 780.236000] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
Oct 20 18:55:07 zhuxiaoyu-laptop kernel: [ 780.260000] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-10-20 19:29 

注册: 2005-11-05 18:18
帖子: 62
地址: 广东深圳
送出感谢: 0 次
接收感谢: 0 次
I've solved the problem editing /etc/initramfs-tools/modules, and adding this lines:

piix
ide_generic
ide_cd
ide_disk

# blacklist bad driver
blacklist ata_piix

# prevent unnecessary modules from being loaded (you don't need to do this)
blacklist ata_generic
blacklist libata
blacklist scsi_mod

after editing:

sudo update-initramfs -u

after reboot I have my hard disks with the old fashioned /dev/hd*, without bugs!!!:)


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-10-20 19:30 

注册: 2005-11-05 18:18
帖子: 62
地址: 广东深圳
送出感谢: 0 次
接收感谢: 0 次
引用别人的喔:

https://bugs.launchpad.net/ubuntu/+bug/104581


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-10-20 22:07 

注册: 2007-08-09 18:01
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
这个是我找到的!但是我的英语还不够好,最后的一部分哪个大虾能帮我好好解释下,并告诉我应该如何做?
Bug description [edit]

Binary package hint: hal

When I upgraded the kernel on my System76 Gazelle (basically a ASUS Z62FP without the Microsoft tax) from 2.6.17 to 2.6.20, the hard disk began freezing for 30 seconds every few minutes whenever the CD/DVD drive was empty. When there is a disk in the optical drive, the freezes occur much less often, but I'm sure there's been at least one even with a CD in.

The relevant part of the dmesg is:

[ 188.960000] ata1.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
[ 188.960000] ata1.01: cmd a0/00:00:00:00:20/00:00:00:00:00/b0 tag 0 cdb 0x0 data 0
[ 188.960000] res 40/00:03:00:00:00/00:00:00:00:00/b0 Emask 0x4 (timeout)
[ 195.964000] ata1: port is slow to respond, please be patient (Status 0xd0)
[ 218.980000] ata1: port failed to respond (30 secs, Status 0xd0)
[ 218.980000] ata1: soft resetting port
[ 219.332000] ata1.00: configured for UDMA/100
[ 219.516000] ata1.01: configured for UDMA/33
[ 219.516000] ata1: EH complete
[ 219.532000] SCSI device sda: 78140160 512-byte hdwr sectors (40008 MB)
[ 219.540000] sda: Write Protect is off
[ 219.540000] sda: Mode Sense: 00 3a 00 00
[ 219.900000] SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 219.904000] SCSI device sda: 78140160 512-byte hdwr sectors (40008 MB)
[ 219.904000] sda: Write Protect is off
[ 219.904000] sda: Mode Sense: 00 3a 00 00
[ 219.908000] SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO or FUA

I'm filing this bug against HAL because kernel developer Tejun Heo says HAL is poking the CD/DVD drive and confusing it, and indeed when I kill hald the problem goes away. On the other hand, I only noticed the problem after upgrading the kernel, and when I force the old ide_generic driver to be used by blacklisting ata_piix, the problem also goes away, so maybe it should be filed against the kernel package instead.


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-10-21 0:49 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 273
6楼引用的是,修改启动模块,使用老实的 hd 磁盘模块,而不是sdx的这种通用磁盘模块。不确定这样能和你的问题对应上。

8楼的,hald 是管理设备数据库的后台进程。实时处理设备的接入。我觉得你不是随时接入设备的这种情况。

我觉得,你还是应该有确切的信息,可以看到,系统被冻结的时候,有什么提示。可以从~/.Xsession-error或者dmesg|tail 里面找。没信息,根本不清楚应该如何确定情况。说不定gentoo社区的,熟悉些这方面的。


_________________
● 鸣学


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-10-21 11:01 

注册: 2007-08-09 18:01
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
我按照8楼那个,把ide_generic加入到modules里面了 并且blacklist了ata_generic ,貌似再没有发生假死的情况,不过启动ubuntu的时候慢到无法忍受的程度,需要将尽5分钟.

这个应该怎么解决


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译