当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]双系统引导grub失效
帖子发表于 : 2007-10-20 17:53 

注册: 2007-05-22 17:33
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
机器是预装vista的,然后在d盘剩余空间里又分了个区装gusty.安装好后能进grub,ubuntu使用正常。但是进入vista然后再重启后grub就不能引导,机器不断重启。用gusty DVD root(hd0,5) setup(hd0)后又能进入grub了。可是每次进入vista后grub都会被破坏,如何解决?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-20 18:55 

注册: 2007-05-22 17:33
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
我想把linux的引导扇区文件导出来
Device Boot Start End Blocks Id System
/dev/sda1 4 27787 7168000 1c Hidden W95 FAT32 (LBA)
/dev/sda2 * 27787 186547 40960000 7 HPFS/NTFS
/dev/sda3 186548 345304 40959306 5 Extended
/dev/sda4 345307 605772 67200000 7 HPFS/NTFS
/dev/sda5 186548 305617 30720058 7 HPFS/NTFS
/dev/sda6 305618 339683 8789026 83 Linux
/dev/sda7 339684 345304 1450216 82 Linux swap / Solaris
sudo dd if=/dev/sda2 of=/dev/sda6/linuxloader/ubuntu.lnx bs=512 count=1
dd: 正在打开 ‘/dev/sda6/linuxloader/ubuntu.lnx’: Not a directory
安装的时候我也没注意到grub装在哪里。。。
应该如何操作?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-10-20 19:41 

注册: 2007-05-22 17:33
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
问题已解决。到menu下把隐藏分区的vista引导文件##掉就没事了。大概asus的系统恢复分区有问题吧
刚才重新启动了vista,发现问题依旧…………
似乎在vista下用一会儿就会把grub修改掉导致开机无法进入grub。。。何解?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译