[问题]sudo apt-get install-essential 不成功

重复贴和参考价值不大的帖子,版主维护
回复
cg19820811
帖子: 40
注册时间: 2007-04-09 15:30
送出感谢: 0
接收感谢: 0
联系:

[问题]sudo apt-get install-essential 不成功

#1

帖子 cg19820811 » 2007-10-21 15:02

cg@cg-desktop:~$ sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.1.1) 但是它将不会被安装
dpkg: Breaks: dpkg-dev (< 1.14.0) 但是 1.13.24ubuntu6 正要被安装
E: 无法安装的软件包
cg@cg-desktop:~$ sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.1.1) 但是它将不会被安装
dpkg: Breaks: dpkg-dev (< 1.14.0) 但是 1.13.24ubuntu6 正要被安装
E: 无法安装的软件包



---------------------------
这是我的源

deb http://ubuntu.cn99.com/ubuntu/ feisty main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ feisty-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ feisty-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ feisty-proposed main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ feisty-backports main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ feisty main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ feisty-security main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ feisty-updates main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ feisty-proposed main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ feisty-backports main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu-cn/ feisty main restricted universe multiverse

谢谢,应该怎么解决呀?我想写C++程序..版本是7.10
上次由 cg19820811 在 2007-10-21 19:49,总共编辑 1 次。
头像
shaojz2005
帖子: 278
注册时间: 2006-07-13 13:01
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 shaojz2005 » 2007-10-21 15:19

按道理说cn99的源不会出问题吧
你的ubuntu版本是多少?
要不也可以尝试换其他源看看?
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#3

帖子 BigSnake.NET » 2007-10-21 15:21

sudo aptitude install build-essential
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
cg19820811
帖子: 40
注册时间: 2007-04-09 15:30
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 cg19820811 » 2007-10-21 19:49

按楼上的做法也不行。什么都没有安装上

sudo aptitude install build-essential

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在读取扩展状态文件
正在初始化软件包状态... 完成
创建标签数据库... 完成
下列软件包是“破损”的:
dpkg g++-4.1 libc6-dev libstdc++6-4.1-dev
下列新软件包将被自动安装:
dpkg-dev g++ linux-libc-dev patch
下列“新”软件包将被安装。
build-essential dpkg-dev g++ linux-libc-dev patch
0 个软件包被升级,新安装8 个, 0 个将被删除, 同时 0 个将不升级。
需要获取 8150kB 的存档。 解包后将要使用 33.9MB。
下列软件包存在未满足的依赖关系:
g++-4.1: 依赖: gcc-4.1-base (= 4.1.2-0ubuntu4) 但是 4.1.2-16ubuntu2 已安装
依赖: gcc-4.1 (= 4.1.2-0ubuntu4) 但是 4.1.2-16ubuntu2 已安装
libstdc++6-4.1-dev: 依赖: gcc-4.1-base (= 4.1.2-0ubuntu4) 但是 4.1.2-16ubuntu2 已安装
dpkg: Breaks: dpkg-dev (< 1.14.0) 但是 1.13.24ubuntu6 将被安装。
libc6-dev: 依赖: libc6 (= 2.5-0ubuntu14) 但是 2.6.1-1ubuntu9 已安装
Resolving dependencies...
open: 6; closed: 5; defer: 0; conflict/break: 1 .下列动作将解决这些依赖关系:

保持 下列软件包于其当前版本:
build-essential [未安装的]
dpkg-dev [未安装的]
g++ [未安装的]
g++-4.1 [未安装的]
libc6-dev [未安装的]
libstdc++6-4.1-dev [未安装的]

分数是 -9836

是否接受该解决方案?[Y/n/q/?] y
将不会安装,升级或者删除任何软件包。
0 个软件包被升级,新安装0 个, 0 个将被删除, 同时 0 个将不升级。
需要获取 0B 的存档。 解包后将要使用 0B。
您要继续吗?[Y/n/?] y
正在编辑扩展状态信息... 完成
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在读取扩展状态文件
正在初始化软件包状态... 完成
创建标签数据库... 完成
cg19820811
帖子: 40
注册时间: 2007-04-09 15:30
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 cg19820811 » 2007-10-21 20:51

不知道怎么搞的,用虚拟机还原后,再试就成功了!
回复

回到 “归档贴”