[问题]安装ATI X600显卡驱动出错

重复贴和参考价值不大的帖子,版主维护
回复
israin
帖子: 9
注册时间: 2007-04-27 8:59
送出感谢: 0
接收感谢: 0

[问题]安装ATI X600显卡驱动出错

#1

帖子 israin » 2007-10-22 22:43

提示如下:

代码: 全选

rain@rain-ubuntu:~$ sudo bash /home/rain/downloads/ati-driver-installer-8.40.4-x86.x86_64.run --buildpkg Ubuntu/gutsy
Created directory fglrx-install.cK8400
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.40.4..............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
 ATI Technologies Linux Driver Installer/Packager 
==================================================
Generating package: Ubuntu/gutsy
./packages/Ubuntu/ati-packager.sh: 175: dpkg-architecture: not found
Error: unsupported architecture: 
Removing temporary directory: fglrx-install.cK8400
到底是哪里出了错误呢?
israin
帖子: 9
注册时间: 2007-04-27 8:59
送出感谢: 0
接收感谢: 0

#2

帖子 israin » 2007-10-23 16:15

:cry: 谁来帮我看看问题啊
头像
xiaosilent
帖子: 513
注册时间: 2006-05-09 9:59
来自: 四川成都
送出感谢: 1 次
接收感谢: 0
联系:

#3

帖子 xiaosilent » 2007-10-23 16:19

ati-driver-installer-8.40.4-x86.x86_64.run

Error: unsupported architecture:
israin
帖子: 9
注册时间: 2007-04-27 8:59
送出感谢: 0
接收感谢: 0

#4

帖子 israin » 2007-10-23 16:27

3楼是说驱动的版本错误了么?

可是确实是官方提供的X86版本啊
头像
xiaosilent
帖子: 513
注册时间: 2006-05-09 9:59
来自: 四川成都
送出感谢: 1 次
接收感谢: 0
联系:

#5

帖子 xiaosilent » 2007-10-23 16:42

64/32 ?
lijzz
帖子: 196
注册时间: 2006-09-03 20:53
送出感谢: 0
接收感谢: 0

#6

帖子 lijzz » 2007-10-23 16:57

你把文件名改一下再试如:ati-driver-installer-8.40.4-x86.x86_64.run改 为ati-driver-installer-8.40.4.run
头像
ericzb
帖子: 441
注册时间: 2006-11-16 21:34
来自: Bridge View
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 ericzb » 2007-10-25 0:51

lijzz 写了:你把文件名改一下再试如:ati-driver-installer-8.40.4-x86.x86_64.run改 为ati-driver-installer-8.40.4.run
?????????????????????
头像
citydream
帖子: 129
注册时间: 2007-04-30 22:28
送出感谢: 0
接收感谢: 1 次

#8

帖子 citydream » 2007-10-25 10:52

lijzz 写了:你把文件名改一下再试如:ati-driver-installer-8.40.4-x86.x86_64.run改 为ati-driver-installer-8.40.4.run
下载的文件改名,然后在命令中使用新名字。
Citydream is always by your side...
israin
帖子: 9
注册时间: 2007-04-27 8:59
送出感谢: 0
接收感谢: 0

#9

帖子 israin » 2007-10-26 13:40

回楼上的,改了名字运行之后,错误提示和原来一样的

./packages/Ubuntu/ati-packager.sh: 175: dpkg-architecture: not found
Error: unsupported architecture:
Removing temporary directory: fglrx-install.cK8400
头像
xiaosilent
帖子: 513
注册时间: 2006-05-09 9:59
来自: 四川成都
送出感谢: 1 次
接收感谢: 0
联系:

#10

帖子 xiaosilent » 2007-10-26 20:10

系统是 64/32 ?

下载的驱动是 for 64/32 ?

:em25
头像
ken085
帖子: 2447
注册时间: 2007-08-09 15:11
送出感谢: 0
接收感谢: 0

#11

帖子 ken085 » 2007-10-26 20:19

干嘛那么麻烦~

删掉XGL和受限驱动后,注释掉:
Section "Extensions"
Option "Composite" "0" #or "Disable"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

之后再直接:
sudo bash "ati-driver-installer-8.40.4-x86.x86_64.run"
一路NEXT就OK了~~~
XRRC VG FVZCYR & FGHCVQ!
israin
帖子: 9
注册时间: 2007-04-27 8:59
送出感谢: 0
接收感谢: 0

#12

帖子 israin » 2007-10-31 8:56

ken085 写了:干嘛那么麻烦~

删掉XGL和受限驱动后,注释掉:
Section "Extensions"
Option "Composite" "0" #or "Disable"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

之后再直接:
sudo bash "ati-driver-installer-8.40.4-x86.x86_64.run"
一路NEXT就OK了~~~
请问一下这一步具体应该怎么做,我是新手 :oops:
回复

回到 “归档贴”