当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [问题]请教,ubantu如何安装c compiler?
帖子发表于 : 2007-11-09 12:20 

注册: 2007-11-09 10:20
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
现在装的是ubuntu7.10,
从一个老外那要来的软件,make时报错,

cc -O2 -c -o swat.o swat.c
> In file included from swat.c:25:
> swat.h:25:19: error: ctype.h: No such file or directory
> swat.h:26:18: error: math.h: No such file or directory
> swat.h:27:19: error: stdio.h: No such file or directory
> In file included from swat.c:25:
> swat.h:87: error: expected specifier-qualifier-list before ‘FILE’
> swat.c: In function ‘main’:
> swat.c:55: error: ‘FILE’ undeclared (first use in this function)
> swat.c:55: error: (Each undeclared identifier is reported only once
> swat.c:55: error: for each function it appears in.)
> swat.c:55: error: ‘fr’ undeclared (first use in this function)
> swat.c:86: warning: incompatible implicit declaration of built-in
> function ‘printf’
> swat.c:134: warning: incompatible implicit declaration of built-in
> function ‘fprintf’
> swat.c:134: error: ‘stderr’ undeclared (first use in this function)
> swat.c:142: error: ‘stdout’ undeclared (first use in this function)
> swat.c:230: warning: incompatible i
mplicit declaration of built-in
> function ‘strcpy’
> swat.c:231: warning: incompatible implicit declaration of built-in
> function ‘strcat’
> swat.c:273: warning: incompatible implicit declaration of built-in
> function ‘printf’
> make: *** [swat.o] Error 1

请教了一下老外,说是c compiler不完全
哪位兄弟有解决办法?
或者其它什么版本的linux好用?
谢谢!!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-11-09 12:28 
头像

注册: 2006-01-25 22:29
帖子: 1322
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install build-essential
大概是这样的。。。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-11-09 12:52 

注册: 2007-11-09 10:20
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
谢谢jimhu兄弟!
运行 sudo apt-get install build-essential 依然报错
继续请教,谢谢!

root@guo-laptop:~# sudo apt-get install build-essential
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
build-essential: Depends: libc6-dev but it is not going to be installed or
libc-dev
Depends: g++ (>= 4:4.1.1) but it is not going to be installed
dpkg: Breaks: dpkg-dev (< 1.14.0) but 1.13.24ubuntu6 is to be installed
E: Broken packages


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-11-09 13:02 

注册: 2006-03-10 15:10
帖子: 3182
地址: xi'an China
送出感谢: 0 次
接收感谢: 2
换个源试试呢?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-11-09 13:05 

注册: 2007-11-09 10:20
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
源是什么?
怎么换?
谢谢!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-11-09 13:06 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
http://wiki.ubuntu.org.cn/


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-11-09 13:07 
头像

注册: 2007-09-10 20:20
帖子: 1352
地址: 南京
系统: Debian
送出感谢: 0 次
接收感谢: 0 次
看错误提示


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-11-09 13:10 

注册: 2007-11-09 10:20
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
第一次接触linux,
请各位老大说得详细一点,谢谢!


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-11-09 14:39 

注册: 2007-11-09 10:20
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
换了n个源了,问题依旧!
哪位兄弟有办法,谢谢!


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-11-09 14:50 

注册: 2007-11-01 23:59
帖子: 17
地址: 江苏南京
送出感谢: 0 次
接收感谢: 0 次
新手真TM的烦,一天到晚都问这种白痴问题


_________________
身在L营心在W。。。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-11-09 15:11 

注册: 2007-11-09 10:20
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
不知道你这种所谓的“高手”到新手版来干什么!


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-11-09 16:46 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
安装错误的原因是 build-essential 依赖 libc6-dev、g++ 等,但是apt-get需要手工同时安装依赖包。

楼主可以使用:
sudo aptitude install build-essential

也可以(推荐):
直接到新立得搜寻 build-essential 包,按鼠标右键安装。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-11-09 16:57 
头像

注册: 2007-07-11 20:59
帖子: 3922
送出感谢: 0 次
接收感谢: 0 次
是ubuntu不是你标题所打的"ubantu"


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-11-09 16:59 
头像

注册: 2006-05-12 23:28
帖子: 621
地址: 江西乐平
送出感谢: 0 次
接收感谢: 1
引用:
njayong002
10楼
现已禁止


002……原来已经处理过不止一次了。

对Ubuntu不满意,发发牢骚就算了。还跑到这里来混淆视听。


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-11-10 23:34 

注册: 2007-11-09 10:20
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
重装了一次系统,直接安装G++搞定!
谢谢各位!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译