[问题]硬盘安装ubuntu7.10时强行关机造成系统无法启动,急请高手帮忙

重复贴和参考价值不大的帖子,版主维护
回复
alextome
帖子: 28
注册时间: 2007-11-04 9:22
送出感谢: 0
接收感谢: 0

[问题]硬盘安装ubuntu7.10时强行关机造成系统无法启动,急请高手帮忙

#1

帖子 alextome » 2007-11-09 20:37

刚开始学习ubuntu,看了好多帖子,终于在昨天晚上可以实现硬盘安装。但是好像是因为刚开始配置DHCP的时候没有拔掉网线,安装到后面有一个配置好像是ACP的时候,一直提示扫描镜像,长时间没有动静。因时间太晚了,第二天还要上班,等不及就直接按电源键,强行关机了。重启后却不能启动了,提示“Error loading operating system"。

已经试过的方法:
1、用win2000启动安装,然后选择控制台修复,用fixboot和fixmbr命令,无效。手里没有win98的盘,没有试DOS下fdisk /MBR。
2、用U盘启动deliya,然后找到C盘的boot.ini,删除最后的那句“c:\grldr="Start Grub"”,重启后仍然提示错误。
水平有限,不知道该怎么办了。请高手帮忙分析分析,指点一下挽救方法。多谢了!
上次由 alextome 在 2007-11-09 22:17,总共编辑 1 次。
dogal
帖子: 900
注册时间: 2006-11-23 13:04
送出感谢: 0
接收感谢: 0

#2

帖子 dogal » 2007-11-09 20:39

重装吧
alextome
帖子: 28
注册时间: 2007-11-04 9:22
送出感谢: 0
接收感谢: 0

#3

帖子 alextome » 2007-11-09 20:47

只有这一种选择吗? :cry:
头像
Nile
帖子: 990
注册时间: 2006-07-15 11:20
来自: 枫叶刀市
送出感谢: 2 次
接收感谢: 0

#4

帖子 Nile » 2007-11-09 20:49

你用的是win2000吗?我用xp除这种问题时fixboot和fixmbr就足够了。
用liveCD重装grub试试。
Thinkpad T400
alextome
帖子: 28
注册时间: 2007-11-04 9:22
送出感谢: 0
接收感谢: 0

#5

帖子 alextome » 2007-11-09 21:12

我用的是winXP,不知道怎么回事,那个XP的盘不能光驱启动,晕!
头像
Nile
帖子: 990
注册时间: 2006-07-15 11:20
来自: 枫叶刀市
送出感谢: 2 次
接收感谢: 0

#6

帖子 Nile » 2007-11-09 21:33

XP和2000的loader应该一样吧
我有一次是活动分区不知怎么从C盘上掉了害得我查了半天,具体错误代码忘了,但和LZ差不多,LZ不妨用fdisk看看是不是这问题
Thinkpad T400
alextome
帖子: 28
注册时间: 2007-11-04 9:22
送出感谢: 0
接收感谢: 0

#7

帖子 alextome » 2007-11-09 21:51

多谢Nile兄,我现在正在试,期待好消息。 :D
trend1975
帖子: 109
注册时间: 2006-06-10 14:08
送出感谢: 0
接收感谢: 0

#8

帖子 trend1975 » 2007-11-09 21:56

老大,应该是系统无法启动,电脑无法启动我还以为是硬件毛病那
alextome
帖子: 28
注册时间: 2007-11-04 9:22
送出感谢: 0
接收感谢: 0

#9

帖子 alextome » 2007-11-09 22:17

没错是系统无法启动,可能写得让人有误解。
回复

回到 “归档贴”