虚拟机上网问题

重复贴和参考价值不大的帖子,版主维护
回复
dumbwater
帖子: 22
注册时间: 2007-11-11 15:13
送出感谢: 0
接收感谢: 0

虚拟机上网问题

#1

帖子 dumbwater » 2007-11-14 22:28

主机环境:Windows XP
虚拟机环境:VM 6.0 装的是Ubuntu7.10
我装虚拟机,,上网方式选择Host-only,与主机共享一个私有网络。
完全配置好IP,网关,DNS!
因为我处于校园网,当配置好虚拟机里能打开校园网,但是打不开外网。ping www.baidu.com
都能ping得通,但是就是打不开网页。请问这是怎么回事。
PS:开始我觉得是DNS服务器有问题,但是跟我主机用的DNS是一样,在主机里DNS也能用。为什么在虚拟机里好像没有用一样呢?是不是有什么服务没有开启?

能ping得通外网,但是打不开网页。可以告诉我应该从哪方面入手检查吗?
附件
-1.png
Sc.png
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

#2

帖子 Element » 2007-11-15 0:01

试试 NAT 和 Bridge 模式
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
dumbwater
帖子: 22
注册时间: 2007-11-11 15:13
送出感谢: 0
接收感谢: 0

#3

帖子 dumbwater » 2007-11-15 12:55

Bridge 模式在学校是不可能,因为我们这要拨号,不能连到外网,而且在linux下没有拨号软件!!!
 NAT还没有试过!!
头像
chattan
论坛版主
帖子: 3922
注册时间: 2007-07-11 20:59
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 chattan » 2007-11-15 12:57

我记得我以前用的时候,只须在XP上登号,在虚拟的LINUX下就能上了,我选择的是桥的模式!
dumbwater
帖子: 22
注册时间: 2007-11-11 15:13
送出感谢: 0
接收感谢: 0

#5

帖子 dumbwater » 2007-11-17 13:19

谢谢楼上的,,我的选桥接的话。在XP上拨号了,虚拟机上不能上网。必须在虚拟机拨号。。但是虚构机Linux下没有拨号软件。。现在我用了NAT上网方式可以了!!
头像
Panney
帖子: 19
注册时间: 2007-11-16 23:42
送出感谢: 0
接收感谢: 0
联系:

Bridge 模式

#6

帖子 Panney » 2007-11-17 15:07

一定要用 Bridge 模式 这是我的成功经验 一定要相信我 ~~~
dumbwater
帖子: 22
注册时间: 2007-11-11 15:13
送出感谢: 0
接收感谢: 0

#7

帖子 dumbwater » 2007-11-17 23:28

谢谢楼上的,,Bridge 模式不合适我这的情况!!
PhoenixJ
帖子: 1488
注册时间: 2007-08-09 3:33
系统: Windows 12.04
送出感谢: 2 次
接收感谢: 1 次

#8

帖子 PhoenixJ » 2007-11-17 23:38

居然还有人认为虚拟机要用bridge。
sigh.

NAT才是王道阿。。。
回复

回到 “归档贴”