紧急求助!安装显卡驱动后,进不了系统了!不想就这样放弃ubuntu啊!

重复贴和参考价值不大的帖子,版主维护
回复
DuFang
帖子: 10
注册时间: 2007-11-14 19:46
送出感谢: 0
接收感谢: 0

紧急求助!安装显卡驱动后,进不了系统了!不想就这样放弃ubuntu啊!

#1

帖子 DuFang » 2007-11-15 21:11

gma900的显卡,安装ubuntu才2天,为了能实现windows下面那种扩展桌面到电视上,就按照网上的方法, sudo dpkg-reconfigure xserver-xorg ,安装了i810的驱动.里面有很多步骤和选项,我都选的是默认的.结束后,重新开机,结果启动后,ubuntu的进度条走完后,就停留在黑色的命令行界面了,上面显示了几行启动信息,但后面都标志的OK.这时什么也不能做,只有CTRL ALT DEL重启.
请高手帮帮我!感谢!如何进入系统,如何正确安装显卡驱动,实现多显示器效果.不想因为这些就放弃LINUX啊.应该都可以做到的吧!
头像
tiancaiamao
帖子: 149
注册时间: 2007-11-06 22:58
来自: 武汉
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 tiancaiamao » 2007-11-15 22:51

我也是装了显卡驱动后就进不了系统了,只好重装系统了。
DuFang
帖子: 10
注册时间: 2007-11-14 19:46
送出感谢: 0
接收感谢: 0

#3

帖子 DuFang » 2007-11-15 23:02

不会吧.真的就为了这个重装???只有放弃ubuntu了
头像
bjsm
帖子: 2322
注册时间: 2007-05-13 16:45
来自: 阿拉斯加群岛其中的一个岛上一片原始森林里其中的一颗树上
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 bjsm » 2007-11-15 23:06

谁叫你没备份XORG啊。我发个我备份的给你。有用的话要写感谢信的啊。OK?
http://shop33976086.taobao.com/
AMD 速龙 x4 630
GIGABYTE MA785GT-UD3H
金士顿 骇客神条 DDR3 1666 2G (这个内存我最肉疼,390元。)
VIEWSONIC 2433
ssh -qTfnN -D 7070
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

#5

帖子 Element » 2007-11-15 23:07

那就把i810的驱动拆除了啊
试试recover模式
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
头像
bjsm
帖子: 2322
注册时间: 2007-05-13 16:45
来自: 阿拉斯加群岛其中的一个岛上一片原始森林里其中的一颗树上
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 bjsm » 2007-11-15 23:07

我的XORG。
头像
bjsm
帖子: 2322
注册时间: 2007-05-13 16:45
来自: 阿拉斯加群岛其中的一个岛上一片原始森林里其中的一颗树上
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 bjsm » 2007-11-15 23:09

啊,怎么发不出啊?算了。写给你吧。


# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "nVidia Corporation NV34 [GeForce FX 5200]"
Driver "nv"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "7Klr"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV34 [GeForce FX 5200]"
Monitor "7Klr"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection
http://shop33976086.taobao.com/
AMD 速龙 x4 630
GIGABYTE MA785GT-UD3H
金士顿 骇客神条 DDR3 1666 2G (这个内存我最肉疼,390元。)
VIEWSONIC 2433
ssh -qTfnN -D 7070
DuFang
帖子: 10
注册时间: 2007-11-14 19:46
送出感谢: 0
接收感谢: 0

#8

帖子 DuFang » 2007-11-15 23:12

我是菜鸟,才学LINUX的.当时我也是按照网上的方法说的做的,我看他好像自动备份了的.但是我现在根本进入不到图形界面了,请楼上的把具体过程写一下,真的可行的话,绝对感谢你!!!

GMA900的显卡,我需要的是可以实现桌面输出功能,到底要怎么做呢?
DuFang
帖子: 10
注册时间: 2007-11-14 19:46
送出感谢: 0
接收感谢: 0

#9

帖子 DuFang » 2007-11-15 23:14

感谢楼上的,但是我现在要输入什么命令才能恢复XORG呢?
你的好像不是我这个显卡啊
oiniya
帖子: 256
注册时间: 2007-07-26 15:07
送出感谢: 0
接收感谢: 0

#10

帖子 oiniya » 2007-11-16 13:40

如果备份了,那么字符界面登入以后:
cd /etc/X11
ls
查看是否有备份文件,比如xorg.conf.xxx之类的文件,如果有:
sudo cp xorg.conf.xxx xorg.conf
如果没有可以尝试一下:
nano -w xorg.conf
然后把
Section "Device"
中的
Driver "xxx"改成
Driver "vesa"
然后保存,应该可以进入x界面了,至于怎么安装驱动,可以查找相关帖子。
头像
冲浪板
论坛版主
帖子: 7467
注册时间: 2007-05-06 8:19
送出感谢: 0
接收感谢: 5 次

#11

帖子 冲浪板 » 2007-11-16 15:07

放弃又有什么难的,要拿得起放得下
paopaozj
帖子: 821
注册时间: 2007-10-28 23:35
送出感谢: 0
接收感谢: 0

#12

帖子 paopaozj » 2007-11-16 15:10

??GMA900的集成卡装I810的驱动?
回复

回到 “归档贴”