当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求:apache2支持CGI的配置方法!
帖子发表于 : 2007-11-16 9:15 

注册: 2007-11-15 10:35
帖子: 14
地址: richie8848@126.com
送出感谢: 0 次
接收感谢: 0 次
我用的是ubuntu7.04,用c编写cgi,不用perl。apache测试it works,我在/var/www下建了/cgi-bin/目录,把编写的cgi程序放进去,但是没有响应。

apache2.conf里面该如何修改?其他还有什么要修改的地方?望高大家不吝赐教!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-11-16 13:10 

注册: 2007-11-15 10:35
帖子: 14
地址: richie8848@126.com
送出感谢: 0 次
接收感谢: 0 次
大家都没有人知道吗?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-11-16 15:23 

注册: 2007-11-15 10:35
帖子: 14
地址: richie8848@126.com
送出感谢: 0 次
接收感谢: 0 次
???


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-11-16 15:40 

注册: 2006-11-30 1:29
帖子: 173
送出感谢: 0 次
接收感谢: 0 次
要改配置文件的


_________________
善知识!菩提自性,本来清净,但用此心,直了成佛。 飞信机器人


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-11-16 15:42 

注册: 2006-11-30 1:29
帖子: 173
送出感谢: 0 次
接收感谢: 0 次
vi /etc/apache2/sites-enabled/000-default


默认的CGI部分在这里:

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>


所以,你应该把你的cgi程序COPY到 /usr/lib/cgi-bin 下, 并且要注册权限。


_________________
善知识!菩提自性,本来清净,但用此心,直了成佛。 飞信机器人


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-11-17 10:46 

注册: 2007-11-15 10:35
帖子: 14
地址: richie8848@126.com
送出感谢: 0 次
接收感谢: 0 次
kelvinhan
我按照你说的方法试了,还不行。
莫非apache2安装有问题,怎么测试apache2是否能正常工作?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-11-17 10:51 

注册: 2007-11-15 10:35
帖子: 14
地址: richie8848@126.com
送出感谢: 0 次
接收感谢: 0 次
我把APACHE卸载之后为什么还能访问127.0.0.1?这与服务器无关吗?


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-11-17 22:06 

注册: 2006-11-30 1:29
帖子: 173
送出感谢: 0 次
接收感谢: 0 次
卸载之后为什么还能访问127.0.0.1? 你怎么访问?

通过浏览器 http://127.0.0.1 访问吗?


UBUNTU 自带的APACHE服务器不会有问题的。直接加我MSN好了。

shichangguo@msn.com


_________________
善知识!菩提自性,本来清净,但用此心,直了成佛。 飞信机器人


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-01-31 8:59 

注册: 2007-11-15 10:35
帖子: 14
地址: richie8848@126.com
送出感谢: 0 次
接收感谢: 0 次
kelvinhan 写道:
vi /etc/apache2/sites-enabled/000-default


默认的CGI部分在这里:

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>


所以,你应该把你的cgi程序COPY到 /usr/lib/cgi-bin 下, 并且要注册权限。


按照这个设置成功~


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译