求助 安装build-essential 出错

重复贴和参考价值不大的帖子,版主维护
回复
tiancaipengqu
帖子: 5
注册时间: 2007-06-12 21:42
送出感谢: 0
接收感谢: 0

求助 安装build-essential 出错

#1

帖子 tiancaipengqu » 2007-11-17 13:15

具体情况和报错如下,希望高手指点。


~$ sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.1.1) 但是它将不会被安装
dpkg: Breaks: dpkg-dev (< 1.14.0) 但是 1.13.24ubuntu6 正要被安装
E: 无法安装的软件包
lb_bn
帖子: 1261
注册时间: 2007-02-25 16:56
送出感谢: 0
接收感谢: 0

#2

帖子 lb_bn » 2007-11-17 15:41

用错源了吧。。。
头像
drivel
帖子: 1917
注册时间: 2006-07-08 9:21
来自: University of Science and Technology Beijing
送出感谢: 1 次
接收感谢: 0
联系:

#3

帖子 drivel » 2007-11-17 16:24

贴出/etc/apt/source.list
tiancaipengqu
帖子: 5
注册时间: 2007-06-12 21:42
送出感谢: 0
接收感谢: 0

下面是源

#4

帖子 tiancaipengqu » 2007-11-17 18:23

deb http://debian.ustc.edu.cn/ubuntu/ feisty main multiverse restricted universe
deb http://debian.ustc.edu.cn/ubuntu/ feisty-backports main multiverse restricted universe
deb http://debian.ustc.edu.cn/ubuntu/ feisty-proposed main multiverse restricted universe
deb http://debian.ustc.edu.cn/ubuntu/ feisty-security main multiverse restricted universe
deb http://debian.ustc.edu.cn/ubuntu/ feisty-updates main multiverse restricted universe
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty main multiverse restricted universe
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty-backports main multiverse restricted universe
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty-proposed main multiverse restricted universe
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty-security main multiverse restricted universe
deb-src http://debian.ustc.edu.cn/ubuntu/ feisty-updates main multiverse restricted universe
回复

回到 “归档贴”