请问我装好了apache2 mysql5 tomcat5.5 jdk1.6这四样东西

重复贴和参考价值不大的帖子,版主维护
回复
fhgsdsg
帖子: 39
注册时间: 2007-11-05 15:41
送出感谢: 0
接收感谢: 0
联系:

请问我装好了apache2 mysql5 tomcat5.5 jdk1.6这四样东西

#1

帖子 fhgsdsg » 2007-11-18 12:02

我想用jsp和servlet,这些东西装好以后就不知道怎么弄了,而且装好tomcat以后,我所有的java程序javac的时候,都会出现错误,以前都没有错误的,运行没有问题,这是怎么回事,
fenghaigang@ubuntufhgnocomputer:~/workspace$ javac Window.java
----------
1. WARNING in Window.java (at line 20)
public class Window extends JWindow{
^^^^^^
The serializable class Window does not declare a static final serialVersionUID field of type long
----------
错误信息
fenghaigang@ubuntufhgnocomputer:~/workspace$ javac Frame2.java
----------
1. WARNING in Frame2.java (at line 3)
import java.awt.event.*;
^^^^^^^^^^^^^^
The import java.awt.event is never used
----------
1 problem (1 warning)
zhangsong023
帖子: 768
注册时间: 2006-09-20 19:56
送出感谢: 0
接收感谢: 1 次

#2

帖子 zhangsong023 » 2007-11-18 13:16

你居然会抱怨这个,无语了,有警告功能不好么,简直爽死了。

这不是错误,是编译警告,一个是告诉你这个可序列化的类没有定义serialVersionUID,基本可以无视;另一个告诉你import进来的java.awt.event是多余的,源代码中没有关于这个包的引用,删掉这行import语句就行了。

建议楼主先搞清楚J2SE基础,再碰web。
zhangsong023
帖子: 768
注册时间: 2006-09-20 19:56
送出感谢: 0
接收感谢: 1 次

#3

帖子 zhangsong023 » 2007-11-18 13:26

如果你实在不喜欢警告信息(个人认为这世上没有这样做开发的),这样子:
javac -nowarn somefile
lwf79
帖子: 29
注册时间: 2007-11-22 10:52
送出感谢: 0
接收感谢: 0

#4

帖子 lwf79 » 2007-11-22 11:12

我想请问lz是如何把apache2 mysql5 tomcat5.5 jdk1.6这四样东西安装好的,能否详细的讲解一下安装的步骤给我这个初学者
回复

回到 “归档贴”