当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]怎么才能实现具有读写权限的自动挂载ntfs分区
帖子发表于 : 2007-11-21 12:46 

注册: 2007-05-10 13:33
帖子: 92
送出感谢: 0 次
接收感谢: 0 次
我有两块硬盘,在IDE1的主分区安装了7.10,IDE0是四个ntfs分区。我想让7.10开机后自动挂载IDE0的ntfs分区,经过在网上查找,有高人说先建立挂载的目录,然后修改fstab,我在fstab的最后加上了这样一行:
/dev/sda1 /media/winc ntfs ntf8,umask=0222 0 0
其中winc是我建的目录。重启后实现了自动挂载,但是我对该分区只能读,不能写,我想是权限的问题,请问怎么做才能实现具有读写权限的自动挂载呢?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-11-21 12:55 

注册: 2007-06-30 20:33
帖子: 132
送出感谢: 0 次
接收感谢: 0 次
默认没有挂载吗?7.10默认就应该挂载ntfs而且能读写的啊!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-11-21 12:58 

注册: 2007-11-18 11:56
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
我也遇到这个问题..不会修改fstab
后来在/etc/rc.loacal
中加入挂载的指令就行
mount -t ntfs-3g /dev/sda1 /media/winc -o force


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-11-21 12:59 
头像

注册: 2007-09-16 8:29
帖子: 14252
送出感谢: 172
接收感谢: 271
我的没有问题,一装上就自动挂载了。
只是如果有死机或断电,重启以后就挂载不上,需要到windows里面检测修复,然后就又能自动挂载了。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: [问题]怎么才能实现具有读写权限的自动挂载ntfs分区
帖子发表于 : 2007-11-21 13:01 
头像

注册: 2007-04-28 21:38
帖子: 1026
送出感谢: 0 次
接收感谢: 0 次
longy 写道:
我有两块硬盘,在IDE1的主分区安装了7.10,IDE0是四个ntfs分区。我想让7.10开机后自动挂载IDE0的ntfs分区,经过在网上查找,有高人说先建立挂载的目录,然后修改fstab,我在fstab的最后加上了这样一行:
/dev/sda1 /media/winc ntfs ntf8,umask=0222 0 0
其中winc是我建的目录。重启后实现了自动挂载,但是我对该分区只能读,不能写,我想是权限的问题,请问怎么做才能实现具有读写权限的自动挂载呢?

把折一行去掉。
用磁盘挂载者小程序。。。。


_________________
thinkpad x61 2G DDR no cdrom
--------------------------------------------
ABS学习中
sed学习中
awk学习中
perl学习中
新手描述不清,老手猜测不到,胡乱指挥一通,后果难以预料


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-11-21 13:30 

注册: 2007-05-10 13:33
帖子: 92
送出感谢: 0 次
接收感谢: 0 次
引用:
默认没有挂载吗?7.10默认就应该挂载ntfs而且能读写的啊!

我说的是自动挂载第二块硬盘的ntfs分区


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-11-21 16:07 

注册: 2006-10-25 21:32
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
我实际应用中发现用umask=0222并不能做到读写。要用umask=0才行。贴出我的fstab


/dev/sdb5 /mnt/e ntfs-3g silent,locale=zh_CN.utf8,umask=0 0 0
/dev/sdc1 /mnt/d ntfs-3g silent,locale=zh_CN.utf8,umask=0 0 0


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-11-21 17:01 
头像

注册: 2007-10-29 22:12
帖子: 5353
地址: 江苏南京
系统: OSX 10.9 + Ub 1304
送出感谢: 0 次
接收感谢: 5
你的用户组看了没有?是不是plugdev组里面的用户?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译