[问题]新装的7.10开关机都很慢,怎样能快一点?

重复贴和参考价值不大的帖子,版主维护
头像
dxzmy
帖子: 167
注册时间: 2006-12-16 16:06
来自: DL
送出感谢: 0
接收感谢: 0
联系:

[问题]新装的7.10开关机都很慢,怎样能快一点?

#1

帖子 dxzmy » 2007-11-22 16:23

RT
新安装的系统,发现开关机都很慢。
开机的时候屏幕一直是黑的,偶尔闪动一下,没有启动画面,直接进入到输入密码的画面。整个过程大约5分钟。电脑比较老,IBM X31。但是以前7.04的时候没有这么明显。
想请教一下,有什么优化方法吗?谢谢。
oiniya
帖子: 256
注册时间: 2007-07-26 15:07
送出感谢: 0
接收感谢: 0

#2

帖子 oiniya » 2007-11-22 16:25

自己编译一下内核,只加载自己需要的模块,启动几个必须的服务就行。
头像
yiding_he
帖子: 2677
注册时间: 2006-10-25 18:10
来自: 长沙
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 yiding_he » 2007-11-22 16:28

很多时候开机慢是因为 fsck 花了很多时间。如果楼主也是这样的话,编辑 /etc/fstab ,将那些分区改为不检查(最后一位从0改为1)即可。
头像
dxzmy
帖子: 167
注册时间: 2006-12-16 16:06
来自: DL
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 dxzmy » 2007-11-22 19:39

oiniya 写了:自己编译一下内核,只加载自己需要的模块,启动几个必须的服务就行。
这个对我来说难度太大了。我刚刚接触linux。不过还是要多谢指点。
头像
dxzmy
帖子: 167
注册时间: 2006-12-16 16:06
来自: DL
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 dxzmy » 2007-11-22 19:40

yiding_he 写了:很多时候开机慢是因为 fsck 花了很多时间。如果楼主也是这样的话,编辑 /etc/fstab ,将那些分区改为不检查(最后一位从0改为1)即可。
这个方法简单一些。我试试看。多谢。
paopaozj
帖子: 821
注册时间: 2007-10-28 23:35
送出感谢: 0
接收感谢: 0

#6

帖子 paopaozj » 2007-11-22 19:57

。。1分20秒不知道算不算正常 反正没XP快
liaomarket
帖子: 38
注册时间: 2007-10-25 20:12
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 liaomarket » 2007-11-22 19:59

yiding_he 写了:很多时候开机慢是因为 fsck 花了很多时间。如果楼主也是这样的话,编辑 /etc/fstab ,将那些分区改为不检查(最后一位从0改为1)即可。
一个星期没上来了,一上来就看到这个,又学到一招了,谢谢!
头像
dxzmy
帖子: 167
注册时间: 2006-12-16 16:06
来自: DL
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 dxzmy » 2007-11-22 21:10

不知道大家从7.04换到7.10是不是都有这么明显的差距?
还是只有我自己这样?
头像
dxzmy
帖子: 167
注册时间: 2006-12-16 16:06
来自: DL
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 dxzmy » 2007-11-22 21:12

再请教一下,我的fstab是这样的

代码: 全选

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda5
UUID=050b0377-a0b2-4fd3-83bc-f84094c91d39 /               ext3    defaults,errors=remount-ro 0       1
# /dev/sda6
UUID=a1041200-053e-4dc8-9a59-eb83d9485eed /boot           ext3    defaults        0       2
# /dev/sda7
UUID=8e29e87d-4460-427c-adfd-4571f9cd55ee /home           ext3    defaults        0       2
# /dev/sda1
UUID=7450029F500267E6 /media/sda1     ntfs    defaults,umask=007,gid=46 0       1
# /dev/sda2
UUID=6CD4AB96D4AB60D6 /media/sda2     ntfs    defaults,umask=007,gid=46 0       1
# /dev/sda4
UUID=2a15e79e-7825-4408-8634-26be2ab17217 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec 0       0
请问应该怎么修改呢?
f146
帖子: 164
注册时间: 2007-10-19 20:08
送出感谢: 0
接收感谢: 0

#10

帖子 f146 » 2007-11-22 23:17

UUID=7450029F500267E6 /media/sda1 ntfs defaults,umask=007,gid=46 0 1
UUID=6CD4AB96D4AB60D6 /media/sda2 ntfs defaults,umask=007,gid=46 0 1

把上面两行最后面的1改成0
头像
dxzmy
帖子: 167
注册时间: 2006-12-16 16:06
来自: DL
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 dxzmy » 2007-11-23 11:16

已经按照这种方法修改了。可是启动速度依然很慢。
而且不像以前的版本有启动界面(进度条)。在输入密码的界面之前屏幕一直是黑的。
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 SuperWar3Fan » 2007-11-23 14:30

是不是在boot.ini里面没有Splash参数。。。
头像
htxh6099
帖子: 206
注册时间: 2007-07-10 14:16
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 htxh6099 » 2007-11-23 14:47

我试装过华镭2.0的,那才真叫慢,我还以为是死机了。
头像
dxzmy
帖子: 167
注册时间: 2006-12-16 16:06
来自: DL
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 dxzmy » 2007-11-24 21:53

SuperWar3Fan 写了:是不是在boot.ini里面没有Splash参数。。。
请问boot.ini在哪里啊?没有搜索到。
meto
帖子: 304
注册时间: 2006-12-20 2:06
送出感谢: 0
接收感谢: 0

#15

帖子 meto » 2007-11-24 21:58

新立得搜索startupmanager
或者sudo apt-get install startupmanager

把屏幕分辨率调到你显示器的,下面位数 设为24
回复

回到 “归档贴”