[问题]升级完7.10后无法进入gnome桌面

重复贴和参考价值不大的帖子,版主维护
回复
htpr
帖子: 15
注册时间: 2007-09-10 15:39
送出感谢: 0
接收感谢: 0

[问题]升级完7.10后无法进入gnome桌面

#1

帖子 htpr » 2007-11-23 16:07

终于升级到7.10, grub启动里有三个kernel , 尾号分别为14 15 16
用14或15进去, 出现gnome登陆框, 登录之后什么都没有, 只有黄色的桌面背景, 鼠标能动, 按Ctrl-Alt-F1, 删掉 ~/.Xauthority, 然后 startx, 出现如下错误:
xauth: creating new authority file /home/andy/.serverauth.5814
xauth: error in locking authority file /home/andy/.Xauthority
xauth: error in locking authority file /home/andy/.Xauthority
xauth: error in locking authority file /home/andy/.Xauthority
xauth: error in locking authority file /home/andy/.Xauthority


X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: Linux Ubuntu (xorg-server 2:1.3.0.0.dfsg-12ubuntu8)
Current Operating System: Linux andy-desktop 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686
Build Date: 29 September 2007
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Nov 23 15:46:02 2007
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module already built-in
(II) Module already built-in
(II) Module already built-in
(EE) xf86OpenSerial: Cannot open device /dev/input/wacom
No such file or directory.
Error opening /dev/input/wacom : Success
(EE) xf86OpenSerial: Cannot open device /dev/input/wacom
No such file or directory.
Error opening /dev/input/wacom : Success
(EE) xf86OpenSerial: Cannot open device /dev/input/wacom
No such file or directory.
Error opening /dev/input/wacom : Success
Could not init font path element /usr/share/fonts/X11/cyrillic, removing from list!


waiting for X server to shut down
-------------------------------------------------------------------------------------------------------------------

用16进去, 一片黑什么都没有, 按Ctrl-Alt-F1, 然后 startx, 出现如下错误:
xauth: creating new authority file /home/andy/.serverauth.5509
xauth: error in locking authority file /home/andy/.Xauthority
xauth: error in locking authority file /home/andy/.Xauthority
xauth: error in locking authority file /home/andy/.Xauthority
xauth: error in locking authority file /home/andy/.Xauthority


X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: Linux Ubuntu (xorg-server 2:1.3.0.0.dfsg-12ubuntu8)
Current Operating System: Linux andy-desktop 2.6.20-16-generic #2 SMP Sun Sep 23 19:50:39 UTC 2007 i686
Build Date: 29 September 2007
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Nov 23 15:32:09 2007
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module already built-in
(II) Module already built-in
(II) Module already built-in
Error: API mismatch: the NVIDIA kernel module has the version 1.0-9631, but
this X module has the version 1.0-9639. Please make sure that the kernel
module and all NVIDIA driver components have the same version.
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0): that the NVIDIA device files have been created properly.
(EE) NVIDIA(0): Please consult the NVIDIA README for details.
(EE) NVIDIA(0): *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"

after 0 requests (0 known processed) with 0 events remaining.

xauth: error in locking authority file /home/andy/.Xauthority

看来kernel 2.6.20-16 是显卡驱动的问题, 我用的是nvidia mx4000 显卡, 不知道为什么会不兼容
但是kernel 2.6.20-14/15 就不知道是什么问题了, 这个怎么解决呢?
kevin_wkp
帖子: 25
注册时间: 2007-11-22 19:16
送出感谢: 0
接收感谢: 0

#2

帖子 kevin_wkp » 2007-11-23 19:09

在进入图形界面前,试试下面的命令:
xauth -b quit

在你的home目录(/home/andy/)下,是否还有像.Xauthority-c, .Xauthority-l 这样的文件。上述命令可以解锁并删除这两个文件。
回复

回到 “归档贴”