sudo apt-get install build-essential安装错误,无法解决!

重复贴和参考价值不大的帖子,版主维护
回复
npgmis
帖子: 65
注册时间: 2007-08-28 16:42
送出感谢: 0
接收感谢: 0

sudo apt-get install build-essential安装错误,无法解决!

#1

帖子 npgmis » 2007-11-24 17:15

www@www-desktop:~$ sudo apt-get install build-essential
[sudo] password for lele:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.0) 但是它将不会被安装
dpkg: Breaks: dpkg-dev (< 1.14.0) 但是 1.13.11ubuntu7 正要被安装
E: 无法安装的软件包
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#2

帖子 yaoms » 2007-11-24 17:19

用新立得试试,看看它会不会自动处理这些依赖关系
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
头像
hethe
帖子: 3666
注册时间: 2005-08-01 9:14
送出感谢: 0
接收感谢: 0

#3

帖子 hethe » 2007-11-24 18:39

什么版本,
贴出源
Gedanken ohne Inhalt sind leer .Anschauungen ohne Begriffe sind blind.
npgmis
帖子: 65
注册时间: 2007-08-28 16:42
送出感谢: 0
接收感谢: 0

#4

帖子 npgmis » 2007-11-24 21:48

我用的是ubuntu7.10 ,源是cn99

用新得利也试过,提示错误信息和上面一样
npgmis
帖子: 65
注册时间: 2007-08-28 16:42
送出感谢: 0
接收感谢: 0

#5

帖子 npgmis » 2007-11-24 22:57

救救呀,无法编译,无法安装新的软件了
头像
tlhl28
帖子: 474
注册时间: 2006-09-02 18:58
来自: 深圳
送出感谢: 0
接收感谢: 0

#6

帖子 tlhl28 » 2007-11-25 1:26

不知道这样行不~
你去WINDOWS 里把依赖都下了,全部一起装.

其实直接去packages.ubuntu.com 里搜build-essential ,它会把依赖告诉你,都下了.
回复

回到 “归档贴”