当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [Finished] perl: warning: Setting locale failed.
帖子发表于 : 2007-11-25 10:52 

注册: 2007-11-25 9:19
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install xxx

E: Couldn't configure pre-depend python-central for python-apt, probably a dependency cycle.

z@xubuntu:~$ sudo im-switch -s scim-xim -z default

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_IE.UTF-8@euro",
LC_ALL = (unset),
LANG = "en_IE.UTF-8@euro"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
No alternatives defined for language default


now, i can't use scim, so ...

Can someone give me a few words of advice?

thx.


最后由 ztfree 编辑于 2007-11-28 10:43,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-11-28 10:41 

注册: 2007-11-25 9:19
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
Q1:it has disappired.

I can't rember anything about it.

anyway, I am enjoying the xubuntu now.


Q2:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_IE.UTF-8@euro",
LC_ALL = (unset),
LANG = "en_IE.UTF-8@euro"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

How to:
~$sudo apt-get install language-support-zh
~$sudo dpkg-reconfigure -a locale
~$sudo vi /etc/environment

put the codes in order,
LC_ALL="zh_CN.UTF-8"
LANG="zh_CN.UTF-8"
LANGUAGE="zh_CN.UTF-8:zh:en_US:en"

CTRL + ALT + Backspace or reboot .


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译