求助,关于vim7.1

重复贴和参考价值不大的帖子,版主维护
回复
sakuraghost
帖子: 6
注册时间: 2006-09-01 17:19
送出感谢: 0
接收感谢: 0

求助,关于vim7.1

#1

帖子 sakuraghost » 2007-11-29 13:36

我是菜鸟,请问怎么才能让vim7.1支持c语言的语法高亮显示?
谢谢!
applepine
帖子: 1
注册时间: 2007-11-29 13:45
送出感谢: 0
接收感谢: 0

#2

帖子 applepine » 2007-11-29 13:46

是阿,我我也存在这个问题,请问如何缩进和高亮,怎么设置呢 :?: 谢谢了
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#3

帖子 yaoms » 2007-11-29 14:01

点击这里...........

或者这里:http://wiki.ubuntu.org.cn/Vim用户操作指南
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#4

帖子 yaoms » 2007-11-29 14:08

寻找问题答案最快的方法: :em01
附件
findsomething.png
。。。。。。。
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
sakuraghost
帖子: 6
注册时间: 2006-09-01 17:19
送出感谢: 0
接收感谢: 0

#5

帖子 sakuraghost » 2007-11-29 14:38

在 /etc/vim/vimrc 中,将 syntax on 开启.
可是重新启动 vim 的时候报错,:
E319: sorroy, the command is not available in the version: syntax on

怎么办?
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#6

帖子 yaoms » 2007-11-29 14:43

sudo apt-get install vim-full
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
sakuraghost
帖子: 6
注册时间: 2006-09-01 17:19
送出感谢: 0
接收感谢: 0

#7

帖子 sakuraghost » 2007-11-29 14:48

谢谢 yaoms !! 可以了
可是是什么原因呢?缺少插件还是什么?
谢谢指教!!
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#8

帖子 yaoms » 2007-11-29 14:51

E319: sorroy, the command is not available in the version: syntax on

可能ubuntu7.10默认安装的vim是简化的版本,不支持高亮,安装vim-full就行
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
sakuraghost
帖子: 6
注册时间: 2006-09-01 17:19
送出感谢: 0
接收感谢: 0

#9

帖子 sakuraghost » 2007-11-29 14:54

再次感谢 yaoms !!
回复

回到 “归档贴”