当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装 ndiswrapper 使用 Linksys wusb54g v4 无线网卡 小记
帖子发表于 : 2007-12-05 12:11 
头像

注册: 2007-04-01 14:15
帖子: 241
送出感谢: 0 次
接收感谢: 0 次
因为本本不能使用有线网卡,故安装无线网卡。琢磨良久,搜索无数,将其过程小记一下。

准备好ndiswrapper和网卡驱动

新装系统7.10

完成后sudo apt-get install build-essential(这不是从网络安装,而是从光盘安装,所以安装盘要在光驱里)

禁用系统默认的网卡驱动
sudo gedit /etc/modprobe.d/blacklist
添加blacklist rt2500usb

重启电脑

编译安装ndiswrapper
sudo make
sudo make install

安装驱动
sudo ndiswrapper -i rt2500usb.inf
sudo ndiswrapper –m

gksu gedit /etc/modules
最后一行添加ndiswrapper及回车

重启后配置网络参数,ok


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-06-09 21:45 

注册: 2007-07-08 19:21
帖子: 145
送出感谢: 0 次
接收感谢: 0 次
HOWTO: Linksys WUSB54G V4 in Gusty
Okay, after a whole week of trying I finally have the Linksys WUSB54G V4 working in Gutsy without ndiswrapper.

This should work with a fresh install of Gutsy or an upgrade from Feisty

You will need the following packages:

* build-essential - which you can get from an Ubuntu CD. (Edgy/Feisty/Gutsy etc.)
* linux-headers-'uname -r' - which you can get from a quick search at packages.ubuntu.com

The first thing you will need to do is find a way of getting the RT2570 CVS driver on to your computer from http://rt2x00.serialmonkey.com/rt2570-cvs-daily.tar.gz.

First of all extract the contents of the archive into your home folder.

Then in the the terminal:

Code:

cd rt2570-cvs-xxxxxxxxxx

(where xxxxxxxxxx is what that part of the folder name which you extracted. (it changes depending on the date)

and then change into the module directory:

Code:

cd Module

after that make the source code:

Code:

make

and then install as root

Code:

sudo make install

That covers installing the driver. Now if all goes well you will need to blacklist the default driver that comes with Gutsy.

Code:

sudo gedit /etc/modprobe.d/blacklist

at the bottom add "blacklist rt2500usb" (without the quoatation marks)

Then restart and manually configure your network by clicking the network monitor and choosing "manual configuration" and click "wireless connection" and then properties. Untick "enable roaming mode" and fill in the details as necessary then press ok and be sure to check the box next to wireless configuration.. And restart again and check if you are connected.

If you are not connected, in the terminal:

Code:

sudo gedit /etc/network/interfaces

and change all occurrences of "rausb1" to "rausb0" and then yet again, restart.

Please post back if this method works for you.
Last edited by AlexMono94; October 26th, 2007 at 03:23 PM. Reason: Changed "Gusty" to "Gutsy" because I had been calling it that for some reason. :P

http://ubuntuforums.org/showthread.php?t=588045


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-06-26 10:41 
头像

注册: 2005-07-10 11:50
帖子: 191
送出感谢: 0 次
接收感谢: 0 次
用老外的方法,到最后试了几次都不行,然后就稀里糊涂成功了。我的网卡是Linksys WUSB54G V4


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译