大家今天先别升级 libcairo2 这个包 (2007-12-05)(雨过天晴,可以更新了,2007-12-11)

重复贴和参考价值不大的帖子,版主维护
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

大家今天先别升级 libcairo2 这个包 (2007-12-05)(雨过天晴,可以更新了,2007-12-11)

#1

帖子 bones7456 » 2007-12-05 12:16

升级之后经常发现gtk程序崩溃.
例如 点击ff的关于对话框崩溃,打开 thunderbird 直接崩溃, leafpad和mousepad的关于对话框也崩溃,ccsm拖动一下滚动条就崩溃.
错误都是 Floating point exception (core dumped)
初步分析就是这个包造成的,大家暂时先别安装 libcairo2_1.4.10-1ubuntu4.1_i386.deb 这个版本了.

如果已经安装了,并且出现了以上问题,请下载老版本,直接覆盖安装即可,
老版本下载地址: http://ubuntu.cn99.com/ubuntu/pool/main ... 4_i386.deb
上次由 bones7456 在 2007-12-11 8:56,总共编辑 2 次。
关注我的blog: ε==3
Morain
帖子: 27
注册时间: 2006-06-21 19:03
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 Morain » 2007-12-05 12:44

我的已经更新了,没有发现上述问题~
错误信息是崩溃后弹出的对话框提示的还是控制台打印的信息?
ygf
帖子: 458
注册时间: 2006-11-27 12:25
送出感谢: 0
接收感谢: 0

#3

帖子 ygf » 2007-12-05 12:58

刚中着了,谢谢!
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#4

帖子 bones7456 » 2007-12-05 13:08

Morain 写了:我的已经更新了,没有发现上述问题~
错误信息是崩溃后弹出的对话框提示的还是控制台打印的信息?
控制台运行,打印的.

可能不会全部出问题,和什么环境有关吧,我的是 gutsy+gnome+compiz.
关注我的blog: ε==3
注册时代
帖子: 16
注册时间: 2007-08-03 20:09
送出感谢: 0
接收感谢: 0

#5

帖子 注册时代 » 2007-12-05 13:21

:D 谢谢!解决了问题。。
我下载了这个文件后, 用Debian安装, 安装窗口自动关闭,所以用命令行才安装成功,一下命令供参考:
进入所下载的deb文件的目录;
sudo dpkg -i libcairo2_1.4.10-1ubuntu4_i386.deb

kai@kai-vmws:~/download$ sudo dpkg -i libcairo2_1.4.10-1ubuntu4_i386.deb
dpkg - 警告:即将把 libcairo2 从 1.4.10-1ubuntu4.1 降级到 1.4.10-1ubuntu4。
(正在读取数据库 ... 系统当前总共安装有 94480 个文件和目录。)
正预备替换 libcairo2 1.4.10-1ubuntu4.1 (使用 libcairo2_1.4.10-1ubuntu4_i386.deb) ...
正在解压缩将用于更替的包文件 libcairo2 ...
正在设置 libcairo2 (1.4.10-1ubuntu4) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place

天下太平了。。
注册时代
帖子: 16
注册时间: 2007-08-03 20:09
送出感谢: 0
接收感谢: 0

Re: 大家今天先别升级 libcairo2 这个包

#6

帖子 注册时代 » 2007-12-05 13:24

bones7456 写了:升级之后经常发现gtk程序崩溃.
例如 点击ff的关于对话框崩溃,打开 thunderbird 直接崩溃, leafpad和mousepad的关于对话框也崩溃,ccsm拖动一下滚动条就崩溃.
错误都是 Floating point exception (core dumped)
初步分析就是这个包造成的,大家暂时先别安装 libcairo2_1.4.10-1ubuntu4.1_i386.deb 这个版本了.

如果已经安装了,并且出现了以上问题,请下载老版本,直接覆盖安装即可,
老版本下载地址: http://ubuntu.cn99.com/ubuntu/pool/main ... 4_i386.deb
谢谢!看来系统自动关闭窗口是这个升级引起的
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#7

帖子 yaoms » 2007-12-05 13:24

没有发现这个问题。。
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
paopaozj
帖子: 821
注册时间: 2007-10-28 23:35
送出感谢: 0
接收感谢: 0

#8

帖子 paopaozj » 2007-12-05 16:34

自动升级的么?
头像
hnzksq
帖子: 473
注册时间: 2007-07-11 16:21
来自: 火星
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 hnzksq » 2007-12-05 16:42

没有发现这个问题。。。
------
“不要揣测神的心,我的孩子,”老头子的声音仿佛梦呓,“神的胸膛里没有心,那只是一块铁石。”
头像
hubert_star
论坛版主
帖子: 5372
注册时间: 2007-10-29 22:12
系统: OSX 10.9 + Ub 1304
来自: 江苏南京
送出感谢: 0
接收感谢: 5 次

#10

帖子 hubert_star » 2007-12-05 16:44

我也没发现有什么问题
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#11

帖子 bones7456 » 2007-12-05 18:12

那看来真的和环境有关,这里还有一例出问题的: viewtopic.php?t=93361&highlight=
关注我的blog: ε==3
头像
夜泊枫桥
帖子: 333
注册时间: 2007-04-03 22:18
送出感谢: 0
接收感谢: 0

#12

帖子 夜泊枫桥 » 2007-12-05 18:36

没遇到 不正常的现象
lyhic
帖子: 112
注册时间: 2007-06-29 20:19
送出感谢: 0
接收感谢: 1 次

#13

帖子 lyhic » 2007-12-05 18:38

我中招了,55555555
chenzhg
帖子: 31
注册时间: 2007-11-26 16:16
送出感谢: 0
接收感谢: 0

#14

帖子 chenzhg » 2007-12-05 18:45

是自动的软件包更新么?
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#15

帖子 zhuqin_83 » 2007-12-06 0:29

骨头人品问题 :lol:
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
回复

回到 “归档贴”