当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [问题]在Ubuntu7.04上安装oracle10g的问题
帖子发表于 : 2007-12-21 13:40 

注册: 2007-10-29 10:19
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
我按照这个论坛上的文档安装下来,但是在检测的一步上总是不能通过:

正在检查操作系统程序包需求...
正在检查 make-3.79; 已发现 未找到。 失败 <<<<
正在检查 binutils-2.14; 已发现 未找到。 失败 <<<<
正在检查 gcc-3.2; 已发现 未找到。 失败 <<<<
正在检查 libaio-0.3.96; 已发现 未找到。 失败 <<<<
检查完成。此次检查的总体结果为: 失败 <<<<
问题: Oracle Database 10g 正常工作所必需的某些程序包缺失 (请参阅以上内容)。
建议案: 请在继续安装之前, 安装所需的程序包。
=======================================================================

检查建议的 glibc 版本
要求的结果: ATLEAST=2.3.2-95.27
实际结果: package glibc is not installed
检查完成。此次检查的总体结果为: 失败 <<<<
问题: 缺失一些建议的程序包 (参见上文)。
建议案: 您实际上可能已经安装了比这些程序包更新的程序包, 如果是这样, 您可以成功地继续安装。如果不是这样, 建议您不要继续。要了解如何获得缺失的程序包, 请参阅自述文件。
=======================================================================

其实之前我有用apt-get命令安装过这些包的。。。
我也试着从网上下载这些包的rpm文件来安装,但是有太多问题了,安装一个包又要求其他的很多包,而且版本还有要求。
谁能告诉我改怎么解决解决这个问题呢??
先谢谢了!!!!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-12-21 14:11 

注册: 2007-10-29 10:19
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
没人知道吗??? :(


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-12-21 14:16 
头像

注册: 2007-10-19 14:51
帖子: 4953
地址: 深圳
送出感谢: 0 次
接收感谢: 2
你 sudo aptitude install build-essential 安装一下基本编译环境。


_________________
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-12-21 14:25 

注册: 2007-10-29 10:19
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
我用root用户执行aptitude install build-essential,结果是
Segmentation fault (core dumped)
这是什么意思?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-12-21 14:46 
头像

注册: 2007-10-19 14:51
帖子: 4953
地址: 深圳
送出感谢: 0 次
接收感谢: 2
.....那你试试apt-get install build-essential呢?


_________________
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-12-21 14:51 

注册: 2007-10-29 10:19
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
执行apt-get install build-essential的结果是:

Reading package lists... Done
Building dependency tree
Reading state information... Done
build-essential is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 62 not upgraded.


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-12-21 14:58 
头像

注册: 2007-10-19 14:51
帖子: 4953
地址: 深圳
送出感谢: 0 次
接收感谢: 2
好像还少一个glibc....


_________________
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-12-21 14:59 

注册: 2007-10-29 10:19
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
yaoms 再帮我看看吧,接下来我该怎么办?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-12-21 15:01 

注册: 2007-10-29 10:19
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
我执行apt-get install glibc,结果是:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package glibc


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-12-21 15:02 
头像

注册: 2007-10-19 14:51
帖子: 4953
地址: 深圳
送出感谢: 0 次
接收感谢: 2
只输 glibc不行,用tab键补齐一下阿


_________________
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-12-21 15:05 

注册: 2007-10-29 10:19
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
我按Tab键glibc后面没版本号出现,什么都没有。。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-12-21 15:08 
头像

注册: 2007-10-19 14:51
帖子: 4953
地址: 深圳
送出感谢: 0 次
接收感谢: 2
连续按两下tab就会 出来,因为它有多种选择


_________________
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-12-21 15:10 

注册: 2007-10-29 10:19
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
还是没有,按的时候机器在叫。


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-12-21 15:14 
头像

注册: 2007-10-19 14:51
帖子: 4953
地址: 深圳
送出感谢: 0 次
接收感谢: 2
没关系阿,叫两声没什么大不了的


_________________
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-12-21 15:15 

注册: 2007-10-29 10:19
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
:( 那接下来应该怎么办呢?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译