[问题]在Ubuntu7.04上安装oracle10g的问题

重复贴和参考价值不大的帖子,版主维护
tina_2007
帖子: 17
注册时间: 2007-10-29 10:19
送出感谢: 0
接收感谢: 0

[问题]在Ubuntu7.04上安装oracle10g的问题

#1

帖子 tina_2007 » 2007-12-21 13:40

我按照这个论坛上的文档安装下来,但是在检测的一步上总是不能通过:

正在检查操作系统程序包需求...
正在检查 make-3.79; 已发现 未找到。 失败 <<<<
正在检查 binutils-2.14; 已发现 未找到。 失败 <<<<
正在检查 gcc-3.2; 已发现 未找到。 失败 <<<<
正在检查 libaio-0.3.96; 已发现 未找到。 失败 <<<<
检查完成。此次检查的总体结果为: 失败 <<<<
问题: Oracle Database 10g 正常工作所必需的某些程序包缺失 (请参阅以上内容)。
建议案: 请在继续安装之前, 安装所需的程序包。
=======================================================================

检查建议的 glibc 版本
要求的结果: ATLEAST=2.3.2-95.27
实际结果: package glibc is not installed
检查完成。此次检查的总体结果为: 失败 <<<<
问题: 缺失一些建议的程序包 (参见上文)。
建议案: 您实际上可能已经安装了比这些程序包更新的程序包, 如果是这样, 您可以成功地继续安装。如果不是这样, 建议您不要继续。要了解如何获得缺失的程序包, 请参阅自述文件。
=======================================================================

其实之前我有用apt-get命令安装过这些包的。。。
我也试着从网上下载这些包的rpm文件来安装,但是有太多问题了,安装一个包又要求其他的很多包,而且版本还有要求。
谁能告诉我改怎么解决解决这个问题呢??
先谢谢了!!!!
tina_2007
帖子: 17
注册时间: 2007-10-29 10:19
送出感谢: 0
接收感谢: 0

#2

帖子 tina_2007 » 2007-12-21 14:11

没人知道吗??? :(
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#3

帖子 yaoms » 2007-12-21 14:16

你 sudo aptitude install build-essential 安装一下基本编译环境。
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
tina_2007
帖子: 17
注册时间: 2007-10-29 10:19
送出感谢: 0
接收感谢: 0

#4

帖子 tina_2007 » 2007-12-21 14:25

我用root用户执行aptitude install build-essential,结果是
Segmentation fault (core dumped)
这是什么意思?
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#5

帖子 yaoms » 2007-12-21 14:46

.....那你试试apt-get install build-essential呢?
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
tina_2007
帖子: 17
注册时间: 2007-10-29 10:19
送出感谢: 0
接收感谢: 0

#6

帖子 tina_2007 » 2007-12-21 14:51

执行apt-get install build-essential的结果是:

Reading package lists... Done
Building dependency tree
Reading state information... Done
build-essential is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 62 not upgraded.
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#7

帖子 yaoms » 2007-12-21 14:58

好像还少一个glibc....
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
tina_2007
帖子: 17
注册时间: 2007-10-29 10:19
送出感谢: 0
接收感谢: 0

#8

帖子 tina_2007 » 2007-12-21 14:59

yaoms 再帮我看看吧,接下来我该怎么办?
tina_2007
帖子: 17
注册时间: 2007-10-29 10:19
送出感谢: 0
接收感谢: 0

#9

帖子 tina_2007 » 2007-12-21 15:01

我执行apt-get install glibc,结果是:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package glibc
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#10

帖子 yaoms » 2007-12-21 15:02

只输 glibc不行,用tab键补齐一下阿
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
tina_2007
帖子: 17
注册时间: 2007-10-29 10:19
送出感谢: 0
接收感谢: 0

#11

帖子 tina_2007 » 2007-12-21 15:05

我按Tab键glibc后面没版本号出现,什么都没有。。
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#12

帖子 yaoms » 2007-12-21 15:08

连续按两下tab就会 出来,因为它有多种选择
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
tina_2007
帖子: 17
注册时间: 2007-10-29 10:19
送出感谢: 0
接收感谢: 0

#13

帖子 tina_2007 » 2007-12-21 15:10

还是没有,按的时候机器在叫。
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

#14

帖子 yaoms » 2007-12-21 15:14

没关系阿,叫两声没什么大不了的
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
tina_2007
帖子: 17
注册时间: 2007-10-29 10:19
送出感谢: 0
接收感谢: 0

#15

帖子 tina_2007 » 2007-12-21 15:15

:( 那接下来应该怎么办呢?
回复

回到 “归档贴”