当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 问题]编译xfce/desktop-agnostic 之 新问题篇
帖子发表于 : 2007-12-23 21:17 
头像

注册: 2006-09-02 18:58
帖子: 474
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
系统: Hiweed-desktop-1.0(基于ubuntu-6.06,xfce桌面环境)

过程:
最近看到AWN,自己也想装一个,看到有 “xfce/desktop-agnostic”,下了源码包来自己编译一个。
但是很多包的缺少,如下:
代码:
:~/desktop-agnostic$ gnome-autogen.sh
checking for autoconf >= 2.53...
  testing autoconf2.50... not found.
  testing autoconf... found 2.59
checking for automake = 1.4...
  testing automake-1.4... found 1.4
checking for libtool >= 1.5...
  testing libtoolize... found 1.5.22
checking for glib-gettext >= 2.2.0...
  testing glib-gettextize... found 2.2.0
checking for intltool >= 0.30...
  testing intltoolize... found 0.35.0
checking for pkg-config >= 0.14.0...
  testing pkg-config... found 0.20
checking for gtk-doc >= 1.0...
 [b] testing gtkdocize... not found.[/b]
***Error***: You must have gtk-doc >= 1.0 installed
  to build Package.  Download the appropriate package for
  from your distribution or get the source tarball at
    http://ftp.gnome.org/pub/GNOME/sources/gtk-doc/

Checking for required M4 macros...
  glib-gettext.m4 not found
  gtk-doc.m4 not found
Checking for forbidden M4 macros...
***Error***: some autoconf macros required to build Package
  were not found in your aclocal path, or some forbidden
  macros were found.  Perhaps you need to adjust your
  ACLOCAL_FLAGS?


1.gtc-doc-1.0可以编译成功,但还是出现以上结果。
2.发现1.0的源码包里没有gtkdocize.in这个文件 。
3.改下了gtc-doc-1.9来进行编译,结果如下:

代码:
:~/MyDownloads/gtk-doc-1.9$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for library containing strerror... none required
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking how to run the C++ preprocessor... g++ -E
checking for g77... no
checking for f77... no
checking for xlf... no
checking for frt... no
checking for pgf77... no
checking for cf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for f90... no
checking for xlf90... no
checking for pgf90... no
checking for pghpf... no
checking for epcf90... no
checking for gfortran... no
checking for g95... no
checking for f95... no
checking for fort... no
checking for xlf95... no
checking for ifort... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for ftn... no
checking whether we are using the GNU Fortran 77 compiler... no
checking whether  accepts -g... no
checking the maximum length of command line arguments... 32768
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking whether the gcc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
configure: creating libtool
appending configuration tag "CXX" to libtool
checking for ld used by g++... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking whether the g++ linker (/usr/bin/ld) supports shared libraries... yes
checking for g++ option to produce PIC... -fPIC
checking if g++ PIC flag -fPIC works... yes
checking if g++ static flag -static works... yes
checking if g++ supports -c -o file.o... yes
checking whether the g++ linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
appending configuration tag "F77" to libtool
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.19... yes
checking for perl... /usr/bin/perl
checking if Perl version >= 5.6.0... yes
checking for openjade... /usr/bin/openjade
checking for xsltproc... /usr/bin/xsltproc
checking for XML catalog (/etc/xml/catalog)... found
checking for xmlcatalog... no
checking for DocBook XML DTD V4.1.2 in XML catalog... not found
configure: error: could not find DocBook XML DTD V4.1.2 in XML catalog


这里说
引用:
could not find DocBook XML DTD V4.1.2 in XML catalog

但我在
代码:
/etc/xml/catalog
里能找到关于V4.1.2的行
如下:
代码:
-- DocBook driver file .................................................. --

PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN" "docbookx.dtd"
DTDDECL "-//OASIS//DTD DocBook XML V4.1.2//EN" "/usr/share/xml/declaration/xml.dcl"

DocBook modules 里也有。

另外找到:
代码:
/usr/share/sgml/docbook/dtd/xml/4.1.2


但编译结果却说找不到,请问是什么原因??


_________________
------
ThinkPad·R60i-0657LN1
Ubuntu 8.04 . Hardy Heron+XP
------


最后由 tlhl28 编辑于 2007-12-26 22:48,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-12-23 21:58 
头像

注册: 2006-09-02 18:58
帖子: 474
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
顶一下......


_________________
------
ThinkPad·R60i-0657LN1
Ubuntu 8.04 . Hardy Heron+XP
------


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-12-24 11:04 
头像

注册: 2006-09-02 18:58
帖子: 474
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
努力中......等待中......


_________________
------
ThinkPad·R60i-0657LN1
Ubuntu 8.04 . Hardy Heron+XP
------


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-12-24 12:34 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
编译需要的,都是*-dev的包吧。你看下。


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-12-24 22:19 
头像

注册: 2006-09-02 18:58
帖子: 474
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
1. *-dev包 是否是相对应包的开发包?
比如:他指示我要装
代码:
gtk-doc >= 1.0

那我是否要去下: gtk-doc-dev来装?

2. 提示找到
代码:
testing glib-gettextize... found 2.2.0

可是
代码:
Checking for required M4 macros...
                     glib-gettext.m4 not found

觉得矛盾......即使我在网上单独找到了glib-gettext.m4(不知道放哪或怎么用......)

3.那那个找不到 "XML V4.1.2" 可我却能在系统上找到又是怎么回事?

不好意思,现在的思绪就这样子,貌似有点乱......请赐教~谢谢~

=================================================

在IRC里得到了解决:
引用:
libglib2.0-dev: usr/share/aclocal/glib-gettext.m4

装了libglib2.0-dev-->glib-gettext.m4 ......found
貌似与glib-gettextize无关
引用:
比如:他指示我要装
代码:
gtk-doc >= 1.0

那我是否要去下: gtk-doc-dev来装?

理解错误.....我认为.......

configure: error: could not find DocBook XML DTD V4.1.2 in XML catalog
这个则是缺少了xmlcatalog这个程序,解答在8楼....


_________________
------
ThinkPad·R60i-0657LN1
Ubuntu 8.04 . Hardy Heron+XP
------


最后由 tlhl28 编辑于 2007-12-26 17:04,总共编辑了 2 次

页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-12-25 19:46 
头像

注册: 2005-03-30 0:27
帖子: 3294
送出感谢: 0 次
接收感谢: 2
装上这些东西

debhelper quilt automake1.10 libglib2.0-dev libpng12-dev libpng-dev libxcomposite-dev libxfixes-dev libxdamage-dev libxrandr-dev libxrender-dev libice-dev libsm-dev libgl1-mesa-dev libcairo-dev librsvg2-dev libdbus-glib-1-dev libwnck-dev libgtk2.0-dev libpango1.0-dev x11proto-gl-dev libxinerama-dev libxcursor-dev libxml2-dev libxslt1-dev libxml-parser-perl libglu1-mesa-dev xsltproc


_________________
跃过无数的时间断层,只为了在


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-12-25 21:36 
头像

注册: 2006-09-02 18:58
帖子: 474
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
谢谢!!!
xmlcatalog,在网上搜了下看,好像是程序来的。但在/usr/bin里没有它的存在
怎么装xmlcatalog的?!?
就差这个不符合条件了......
下面两个包装了还是不行......
代码:
:~/MyDownloads/gtk-doc-1.1$ sudo apt-cache search xmlcatalog
libxml2-utils - XML utilities
xml-core - XML infrastructure and XML catalog file support


_________________
------
ThinkPad·R60i-0657LN1
Ubuntu 8.04 . Hardy Heron+XP
------


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-12-26 16:51 
头像

注册: 2006-09-02 18:58
帖子: 474
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
谢谢HUAHUA!!
不好意思,我漏了libxml2-utils,但我记得已经安装过的(可能是搞晕掉了......)
今天在XGL下装好了, xmlcatalog在libxml2-utils里......
代码:
checking for xmlcatalog... no
checking for DocBook XML DTD V4.1.2 in XML catalog... not found
configure: error: could not find DocBook XML DTD V4.1.2 in XML catalog

这个搞定了,但是接着又来了个
代码:
configure: error: could not find DocBook XSL Stylesheets in XML catalog

看了README,还有一个DSSSL Stylesheets......

于是继续编译......docbook-xsl-1.73.2(XSL Stylesheets的包)......
当然,问题也继续......

代码:
/usr/share/xml/docbook-xsl-1.73.2$ sudo ./install.sh

NOTE: For non-interactive installs/uninstalls, use --batch


WARNING: This install script is meant to be run as a non-root
         user, but you are running it as root.

Are you sure you want to continue? [No] y


Add /usr/share/xml/docbook-xsl-1.73.2/catalog.xml
to /home/tlhl/.resolver/CatalogManager.properties file? [Yes] y

NOTE: /usr/share/xml/docbook-xsl-1.73.2/catalog.xml
      already in:
      /home/tlhl/.resolver/CatalogManager.properties

NOTE: Your environment does not seem to contain the Apache XML
      Commons Resolver; without that, you can't use XML catalogs
      with Java applications. For more information, see the "How
      to use a catalog file" section in Bob Stayton's "DocBook
      XSL: The Complete Guide"

      http://sagehill.net/docbookxsl/UseCatalog.html


NOTE: To source your environment correctly for using the catalog
      files in this distribution, you need to update one or more
      of your shell startup files. This installer can
      automatically make the necessary changes. Or, if you prefer,
      you can make the changes manually.

Update /home/tlhl/.bash_profile? [Yes] y
NOTE: The following file already contains information for this
      distribution, so I did not update it.
      /home/tlhl/.bash_profile

Update /home/tlhl/.profile? [Yes] y
NOTE: The following file already contains information for this
      distribution, so I did not update it.
      /home/tlhl/.profile

Update /home/tlhl/.bashrc? [Yes] y
NOTE: The following file already contains information for this
      distribution, so I did not update it.
      /home/tlhl/.bashrc

To source your shell environment for this distribution, type the
following:

. /usr/share/xml/docbook-xsl-1.73.2/.profile.incl


由于README里说可以随意装,看了网上(http://sagehill.net/docbookxsl/UseCatalog.html)的说明,学它放/usr/share/xml里了......

运行里面的 ./test.sh

代码:
Testing with xmlcatalog...

  Tested: http://docbook.sourceforge.net/release/xsl/current/

NOTE: Your environment does not seem to contain the Apache XML
      Commons Resolver; without that, you can't use XML catalogs
      with Java applications. For more information, see the "How
      to use a catalog file" section in Bob Stayton's "DocBook
      XSL: The Complete Guide"

      http://sagehill.net/docbookxsl/UseCatalog.html


Testing with Apache XML Commons Resolver...

  Tested: http://docbook.sourceforge.net/release/xsl/current/
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/xml/resolver/apps/resolver

搞了以下午,实在不懂,唯有上来请教了......


_________________
------
ThinkPad·R60i-0657LN1
Ubuntu 8.04 . Hardy Heron+XP
------


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-12-26 17:16 
头像

注册: 2005-03-30 0:27
帖子: 3294
送出感谢: 0 次
接收感谢: 2
去请哪位编译打包个 awn for 606 好了


_________________
跃过无数的时间断层,只为了在


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-12-26 17:26 
头像

注册: 2006-09-02 18:58
帖子: 474
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
好的好的,请有的人给给我吧!
谢谢!!!!!!!!!!


_________________
------
ThinkPad·R60i-0657LN1
Ubuntu 8.04 . Hardy Heron+XP
------


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-12-26 22:20 
头像

注册: 2006-09-02 18:58
帖子: 474
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
继续......
解决
代码:
configure: error: could not find DocBook XML DTD V4.1.2 in XML catalog

不用编译 docbook-xsl-1.73.2
直接
代码:
apt-get xmlto

其间还装了由rpm转过来的 docbook-style-xsl_1.65.1-3_all.deb

还有,不知道为什么我成功编译 gtk-doc-1.9.0后在编译xfce/desktop-agnostic( awn-xfce branch)时说版本过低!!!我 立即晕倒....................
然后去看了那个 configure.bin文件(没有configure.in)
里面写着:
引用:
dnl check for gtk-doc
GTK_DOC_CHECK(1.4)

说实话不知道是什么意思,但我还是去下了 gtk-doc-1.4.0来编译,然后就通过了......
接着............我又要倒了......
新问题出现!!!

代码:
~/desktop-agnostic$ gnome-autogen.sh
checking for autoconf >= 2.53...
  testing autoconf2.50... not found.
  testing autoconf... found 2.59
checking for automake = 1.4...
  testing automake-1.4... found 1.4
checking for libtool >= 1.5...
  testing libtoolize... found 1.5.22
checking for glib-gettext >= 2.2.0...
  testing glib-gettextize... found 2.2.0
checking for intltool >= 0.30...
  testing intltoolize... found 0.35.0
checking for pkg-config >= 0.14.0...
  testing pkg-config... found 0.20
checking for gtk-doc >= 1.0...
  testing gtkdocize... found 1.4
Checking for required M4 macros...
Checking for forbidden M4 macros...
**Warning**: I am going to run `configure' with no arguments.
If you wish to pass any to it, please specify them on the
`/usr/bin/gnome-autogen.sh' command line.

Processing ./configure.in
Running libtoolize...
Running glib-gettextize... Ignore non-fatal messages.
Copying file po/Makefile.in.in

Please add the files
  codeset.m4 gettext.m4 glibc21.m4 iconv.m4 isc-posix.m4 lcmessage.m4
  progtest.m4
from the /usr/local/share/aclocal directory to your autoconf macro directory
or directly to your aclocal.m4 file.
You will also need config.guess and config.sub, which you can get from
ftp://ftp.gnu.org/pub/gnu/config/.

Running intltoolize...
Running gtkdocize...
Running aclocal-1.4...
Running autoconf...
Running autoheader...
Running automake-1.4...
configure.in: 4: `automake requires `AM_CONFIG_HEADER', not `AC_CONFIG_HEADER'
automake: Makefile.am: required file `./NEWS' not found
automake: Makefile.am: required file `./README' not found
automake: Makefile.am: required file `./AUTHORS' not found
automake: Makefile.am: required file `./ChangeLog' not found
configure.in: 4: required file `./[config.h].in' not found
doc/reference/Makefile.am:4: require version 1.6, but have 1.4-p6
libawn/Makefile.am:65: libawn_la_LIBADD defined both conditionally and unconditionally
libawn/Makefile.am:65: variable `DEPS_LIBS' not defined
src/Makefile.am:13: variable `DEPS_LIBS' not defined
awn-applet-activation/Makefile.am:13: variable `DEPS_LIBS' not defined
data/Makefile.am:28: GCONF_SCHEMAS_INSTALL does not appear in AM_CONDITIONAL
automake: pyawn/Makefile.am: `awn.la' is not a standard libtool library name
pyawn/Makefile.am:30: variable `PYGTK_LIBS' not defined
pyawn/Makefile.am:40: invalid unused variable name: `nodist_awn_la_SOURCES'

看出问题的兄弟们出声拉!!!谢谢!


_________________
------
ThinkPad·R60i-0657LN1
Ubuntu 8.04 . Hardy Heron+XP
------


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-02-13 13:01 

注册: 2007-08-18 16:51
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
请问楼主哪里下载的源码包啊,我到官方主站给的地址怎么下载不下来?能否把源码包发给我。xfce桌面的。
shuangquansq@163.com
谢谢。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-02-13 23:10 
头像

注册: 2006-09-02 18:58
帖子: 474
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
哈哈~~~不 好意思,在旧电脑上。。。。。。
有看过这个帖子吗?
这里有 说怎么下载,但是我当时是一个一个文件自己下的。。。。。。痛苦阿
http://forum.ubuntu.org.cn/viewtopic.php?t=95651


_________________
------
ThinkPad·R60i-0657LN1
Ubuntu 8.04 . Hardy Heron+XP
------


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译