当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 24 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [其它]ubuntu显卡支持及相关驱动
帖子发表于 : 2007-12-26 16:01 
头像

注册: 2007-08-09 15:11
帖子: 2447
送出感谢: 0 次
接收感谢: 0 次
ubuntu显卡支持及相关驱动

1.nVIDIA(GeForce系列)
几乎完美支持!3D加速,AiGLX均完全没有问题!Compiz Fusion完美开启!可以说装ubuntu选择nVIDIA是最为明智的!!!
nVIDIA最新驱动:
32位版本:
http://us.download.nvidia.com/XFree86/L ... 7-pkg1.run
64位版本:
http://us.download.nvidia.com/XFree86/L ... 7-pkg2.run

2.AMD(ATi)(RADEON系列)
无论开源驱动还是闭源驱动均有大大小小的不同问题,支持3D加速的不支持AiGLX,支持AiGLX了又没3D加速AiGLX还不完美.
ATi最新驱动:
同时兼容32位和64位:
https://a248.e.akamai.net/f/674/9206/0/ ... x86_64.run

3.Intel(GMA系列)
Intel的集显除了一两个Compiz Fusion的特效不支持之外(比如,Blur Windows<模糊窗口>/Motion Blur<动态模糊>/Reflection<映影>)基本没什么大的毛病,完美程度仅次于nVIDIA!
Intel的X.Org 2.2.0驱动:
http://xorg.freedesktop.org/archive/ind ... .0.tar.bz2

4.VIA(Chrome系列)
使用开源的openChrome驱动还是可以支持3D加速的,可惜支持不了混合,所以不支持AiGLX,用不了Compiz Fusion.不过正常的应用还是没有问题的!只是驱动的安装过于麻烦!
另外,VIA已放出支持AiGLX可打开Compiz Fusion的UniChrome系列驱动!
VIA的最新开源驱动(openChrome):
http://www.openchrome.org/releases/xf86 ... 00.tar.bz2
支持Compiz的驱动:
ubuntu 7.04:
http://drivers.viaarena.com/via_ubuntu7 ... _v0.80.zip
ubuntu 7.10:
http://drivers.viaarena.com/via_ubuntu7 ... _v0.80.zip

5.SiS(Mirage系列)
代码:
sudo dpkg-reconfigure xserver-xorg

使用VESA驱动然后祈祷不花屏吧!听说SiS是有3D驱动的,只是出于只有上帝知道的原因,开发出来了SiS也不让人发!GOD DAMN 1T!如果你很不幸使用SiS,那么或许你可以在这里找到暂时的解决方案:
https://launchpad.net/ubuntu/+source/xs ... video-sis/

6.其它(Matrox Parhelia/3Dlabs Wildcat/etcs...)
基本上这些都属于非主流的显卡了,而且基本也不是针对民用级的,支不支持影响不大,不过估计支持再差也比SiS好………………


_________________
XRRC VG FVZCYR & FGHCVQ!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-12-26 16:03 
头像

注册: 2007-08-09 15:11
帖子: 2447
送出感谢: 0 次
接收感谢: 0 次
祝各位ubuntu之旅开心罗~~ :D


_________________
XRRC VG FVZCYR & FGHCVQ!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-12-26 16:14 
头像

注册: 2007-09-16 8:29
帖子: 14252
送出感谢: 172
接收感谢: 271
我是intel845集成显卡,用系统自带的i810驱动和intel驱动速度一样,用那个glx...(记不清楚了)命令测速度在24位色下400多,16位色下700多,显示DRI已经打开,OPENGL正常,但是3d好像有问题,表先在wine的3d游戏都不能用,cedega的3d测试不能通过,困扰了我很长时间了,一直没有解决,楼主给我一些建议吧。


_________________
闻到死太贵, 麦克价更高。 有了笨笨兔, 二者皆可抛。
+ 我的六轮折腾
+ 折腾6轮的结果(对40余种WM的测试和分析,多种DE和WM并存的方案)
+ 折腾的中间成果:可以独立运行的一个Wharf(图标化的启动菜单)
+ 强烈推荐----折腾的终极成果:一个自己开发的DE环境
+ 签名空闲链接位置招租


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-12-26 16:15 
头像

注册: 2007-09-16 8:29
帖子: 14252
送出感谢: 172
接收感谢: 271
对了,忘记说了,我用kde,3d桌面与kde有冲突,效果不好,所以没有开3d桌面。


_________________
闻到死太贵, 麦克价更高。 有了笨笨兔, 二者皆可抛。
+ 我的六轮折腾
+ 折腾6轮的结果(对40余种WM的测试和分析,多种DE和WM并存的方案)
+ 折腾的中间成果:可以独立运行的一个Wharf(图标化的启动菜单)
+ 强烈推荐----折腾的终极成果:一个自己开发的DE环境
+ 签名空闲链接位置招租


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-12-26 16:16 
头像

注册: 2007-12-19 21:42
帖子: 1163
送出感谢: 0 次
接收感谢: 0 次
ljj_jjl2008 写道:
我是intel845集成显卡,用系统自带的i810驱动和intel驱动速度一样,用那个glx...(记不清楚了)命令测速度在24位色下400多,16位色下700多,显示DRI已经打开,OPENGL正常,但是3d好像有问题,表先在wine的3d游戏都不能用,cedega的3d测试不能通过,困扰了我很长时间了,一直没有解决,楼主给我一些建议吧。

代码:
glxinfo | grep rendering

玩3D游戏时记得把Compiz给关了,或者你可以装新的Intel驱动试试!


_________________
北極熊都是左撇子…………


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-12-26 16:18 
头像

注册: 2007-12-19 21:42
帖子: 1163
送出感谢: 0 次
接收感谢: 0 次
ljj_jjl2008 写道:
对了,忘记说了,我用kde,3d桌面与kde有冲突,效果不好,所以没有开3d桌面。
我之前也用KDE3.5,但CF并没有问题,不过现在用KDE4直接用KWin的特效了,都很好,可能我是n卡的关系! :D


_________________
北極熊都是左撇子…………


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-12-26 16:22 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
ken转性了?or 换人了?


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-12-26 16:26 
头像

注册: 2007-08-09 15:11
帖子: 2447
送出感谢: 0 次
接收感谢: 0 次
leeaman 写道:
ken转性了?or 换人了?
过分~偶就只能灌水啊~害偶这么忙都抽空来写这个居然都没人看的~~~ :em87


_________________
XRRC VG FVZCYR & FGHCVQ!


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-12-26 16:28 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
不看,斋顶


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-12-26 16:31 
头像

注册: 2007-08-09 15:11
帖子: 2447
送出感谢: 0 次
接收感谢: 0 次
leeaman 写道:
不看,斋顶

:em24 :em21 就会欺负偶~~~~


_________________
XRRC VG FVZCYR & FGHCVQ!


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-12-26 16:37 
头像

注册: 2007-09-16 8:29
帖子: 14252
送出感谢: 172
接收感谢: 271
ken085 写道:
leeaman 写道:
不看,斋顶

:em24 :em21 就会欺负偶~~~~


别哭了,我在等着你回答问题呢。
下载了你提供的intel驱动,编译时出错了:

代码:
lijianjun@YWEM08:~/setup/xf86-video-intel-2.2.0$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
......
......
checking pkg-config is at least version 0.9.0... yes
checking for XORG... configure: error: Package requirements (xorg-server xproto xvmc fontsproto ) were not met:

No package 'xorg-server' found
No package 'xvmc' found
No package 'fontsproto' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XORG_CFLAGS
and XORG_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


然后,我执行:
代码:
lijianjun@YWEM08:~/setup/xf86-video-intel-2.2.0$ sudo apt-get install xorg-server
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
E: 无法找到软件包 xorg-server


_________________
闻到死太贵, 麦克价更高。 有了笨笨兔, 二者皆可抛。
+ 我的六轮折腾
+ 折腾6轮的结果(对40余种WM的测试和分析,多种DE和WM并存的方案)
+ 折腾的中间成果:可以独立运行的一个Wharf(图标化的启动菜单)
+ 强烈推荐----折腾的终极成果:一个自己开发的DE环境
+ 签名空闲链接位置招租


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-12-26 16:49 
头像

注册: 2007-10-23 22:47
帖子: 596
送出感谢: 0 次
接收感谢: 0 次
转性了,肯定换人了 :D :D :D


_________________
捉泥鳅,捉泥鳅
大哥哥带你去捉泥鳅


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-12-26 16:56 
头像

注册: 2007-11-25 13:29
帖子: 6812
地址: 新疆博乐
系统: Ubuntu 12.04/14.04
送出感谢: 32
接收感谢: 84
我的SIS集成,刚装好分辨率不对,安装的时候倒没什么


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-12-26 17:01 
头像

注册: 2007-12-19 21:42
帖子: 1163
送出感谢: 0 次
接收感谢: 0 次
ljj_jjl2008 写道:
ken085 写道:
leeaman 写道:
不看,斋顶

:em24 :em21 就会欺负偶~~~~


别哭了,我在等着你回答问题呢。
下载了你提供的intel驱动,编译时出错了:

代码:
lijianjun@YWEM08:~/setup/xf86-video-intel-2.2.0$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
......
......
checking pkg-config is at least version 0.9.0... yes
checking for XORG... configure: error: Package requirements (xorg-server xproto xvmc fontsproto ) were not met:

No package 'xorg-server' found
No package 'xvmc' found
No package 'fontsproto' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XORG_CFLAGS
and XORG_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


然后,我执行:
代码:
lijianjun@YWEM08:~/setup/xf86-video-intel-2.2.0$ sudo apt-get install xorg-server
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
E: 无法找到软件包 xorg-server

Intel X.Org驱动需要:X server 1.4.x、Mesa 7.0.x、对应内核的DRM模块才能安装!


_________________
北極熊都是左撇子…………


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-12-26 21:10 
头像

注册: 2007-10-06 18:40
帖子: 4313
送出感谢: 0 次
接收感谢: 5
引用:

这是显卡的驱动
老的显卡用NVIDIA-Linux-x86-96.43.01-pkg1.run
我的显卡是 nf2 mx/mx 400 ,照样用3D
[/url]


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 24 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译