无法安装的软件包

重复贴和参考价值不大的帖子,版主维护
回复
onlyup
帖子: 5
注册时间: 2007-12-27 1:13
送出感谢: 0
接收感谢: 0

无法安装的软件包

#1

帖子 onlyup » 2007-12-29 1:34

安装wine时出现下面的错误,帮我看下,知道的告诉一声。

myth@myth:~/文档/wine-0.9.43$ ./configure
checking build system type... i686-pc-linux-gnulibc1
checking host system type... i686-pc-linux-gnulibc1
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: C compiler cannot create executables
See `config.log' for more details.
myth@myth:~/文档/wine-0.9.43$ make
make: *** 没有指明目标并且找不到 makefile。 停止。
myth@myth:~/文档/wine-0.9.43$ sudo make





myth@myth:~$ sudo apt-get install g++
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
g++: 依赖: g++-4.1 (>= 4.1.2) 但是它将不会被安装
E: 无法安装的软件包
头像
詹舱
帖子: 20
注册时间: 2007-11-05 15:18
来自: AHU
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 詹舱 » 2007-12-29 9:38

代码: 全选

sudo apt-get install build-essential
流浪于遗忘平原的风景线,继续叹息着北极以北的回忆!
回复

回到 “归档贴”