当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : hp v3742tu笔记本电脑 喇叭和 耳机 会同时响
帖子发表于 : 2008-03-08 21:00 

注册: 2008-02-09 15:54
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我的hp笔记本型号是v3742tu 上面标有compaq
笔记本电脑 喇叭和 耳机 会同时响
1).查看声卡类型
lspci -v|grep Audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
(2).查看芯片组
cat /proc/asound/card0/codec#0 |less
结果是:Codec: Conexant ID 5051
(3)查看
/usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz

只有snd-hda-intel Conexant5047没有 Conexant 5051

后来我又
用源
deb http://ftp.de.debian.org/debian sid main
deb-src http://ftp.de.debian.org/debian sid main

sudo aptitude install alsa-base(这里的alsa-base版本是1.0.16-1)
查看
/usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz
此时有了 Conexant 5051
但是修改了gedit /etc/modprobe.d/alsa-base
加入options snd-hda-intel model=laptop(ALSA-Configuration.txt.gz 可以查到的 Conexant 5051 的model)
仍然会喇叭耳机同时响

后来我sudo aptitude --purge remove alsa-base
(这里的卸载会删掉所有配置文件,ALSA-Configuration.txt.gz在执行命令后会被删除)
然后从http://mirror.x10.com/mirror/ubuntu/pool/main/a/alsa-driver/
下载了alsa-base_1.0.16-0ubuntu3_all.deb 这时再次安装成功

再次查看
/usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz
此时又有了 Conexant 5051
但是修改了gedit /etc/modprobe.d/alsa-base
加入options snd-hda-intel model=laptop
依然是喇叭耳机同时会响

而且在前面所有更新alsa-base的过程中,打开音量控制
in the right top ->open volume control ->Edit->preferences

for device 0: HDA Intel (alsa mixer) 只有 Master,PCM,Capture,Digital
for device 1 : Conexant ID 5051(OSS mixser)只有Volume,In-gain

如何才能出现正确的 volume control preferences选项

如果你方便请发邮件到yqwxz@163.com

非常感谢你们的努力


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-08 21:19 
头像

注册: 2005-08-18 18:43
帖子: 3277
送出感谢: 0 次
接收感谢: 3
基本上安照 http://wiki.ubuntu.org.cn/UbuntuWiki:Hd ... on_of_ALSA
可以成功


_________________
໌→ iCookie Gtk Theme
໌→DropPlusBluetheme
กรัก กรัก`菠萝


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-09 12:41 

注册: 2007-07-26 10:50
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
我的HP TC1100也遇到了相同的问题,在XP下就没问题。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-09 12:51 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
玄鹤 写道:
我的HP TC1100也遇到了相同的问题,在XP下就没问题。


xp下不装驱动,基本上喇叭不会响


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-03-09 13:47 

注册: 2006-09-16 14:19
帖子: 652
送出感谢: 0 次
接收感谢: 1
我的dv2500也是Conexant的声卡
没有问题 :?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-03-12 10:58 
头像

注册: 2007-09-07 20:07
帖子: 191
地址: 江苏 苏州
送出感谢: 0 次
接收感谢: 0 次
我DV2743TX,与楼主遇到的问题一样。。。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-03-12 17:33 
头像

注册: 2007-11-23 9:49
帖子: 1021
送出感谢: 0 次
接收感谢: 1
这机非常不厚道,为了推vista连xp驱动都没……当然网上可以搜到xp驱动


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译