当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 8.04笔记本安装出现问题[已解决,重新编译了内核]
帖子发表于 : 2008-03-22 23:35 

注册: 2006-10-07 11:00
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
我的笔记本是sony C22,
配置:T5500+945GM+1.5G RAM+80G HDD+7400 GO
8.04从alpha开始我就一直没有装上去过,livecd启动不管哪个选项进去都是以下提示:
[48.077466] ACPI:EC: acpi_ec_wait timeout,status=0,expect_event=1
[48.077527] ACPI:EC: read timeout,command=128
然后就卡住了,之前所有版本都能正常安装使用,7.10我尝试编译内核也碰到类似的问题,是不是2.6.24内核的acpi模块和我的机器不兼容?
刚才使用iso加载deamontools安装,开始安装时好像选了个仅在有acpi问题时选择的选项才安装成功,但是把我的本本识别为desktop而不是laptop-_-!很是郁闷,电池根本识别不出来,显示屏也不能完全关闭

问题确定是内核的bug,许多型号的vaio笔记本都会出现问题,如果没有插电源开机能正常启动,否则卡住
google到launchpad.net上的bug报告,有人提供了一份补丁,下载了最新的2.6.24.4内核打上补丁后编译安装,问题解决

再补充一下吧,参照这里所说的https://bugs.launchpad.net/ubuntu/+source/linux/+bug/191137,只要去掉quiet参数,就能正常启动
这是2.6.24内核的bug,2.6.25已经没有,ubuntu官方早有人提交这个bug,但是直到现在仍然没有解决


最后由 tulanix 编辑于 2008-06-30 20:34,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-25 21:22 

注册: 2008-03-25 9:01
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
沙发一个!偶的也是C22,遇到同样问题,但是我是个新手,不会编译内核啊!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-26 11:55 

注册: 2006-10-07 11:00
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
http://launchpadlibrarian.net/12630529/1.diff
这是补丁地址,给内核打上补丁,参照论坛的编译方法就可以解决问题,还需要在/lib/firmwares目录下给新内核复制一份新的,否则3945无线网卡不能工作,并且到nvidia官网下载驱动重新安装


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-26 13:07 
头像

注册: 2008-03-26 12:25
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
咨询下~我有台~三星的~X1~装好后~无法安装网卡驱动是啥问题~是没安装好还是?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-29 9:27 

注册: 2008-04-26 1:17
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
tulanix 写道:
http://launchpadlibrarian.net/12630529/1.diff
这是补丁地址,给内核打上补丁,参照论坛的编译方法就可以解决问题,还需要在/lib/firmwares目录下给新内核复制一份新的,否则3945无线网卡不能工作,并且到nvidia官网下载驱动重新安装


能否给个具体的说明?偶是菜鸟 ..什么都不会阿..


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-06-27 11:58 

注册: 2008-05-16 11:26
帖子: 88
送出感谢: 0 次
接收感谢: 0 次
我也遇到同样问题,我也是VAIO,我在安装的时候选了ACPI=OFF能安装,但是安装后系统不能进,出现楼上的问题,不知道楼上详情是怎样打上这个补丁,好像连系统都进不了,怎样打补丁呢?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-06-27 12:00 

注册: 2008-05-16 11:26
帖子: 88
送出感谢: 0 次
接收感谢: 0 次
一直出现
[48.077466] ACPI:EC: acpi_ec_wait timeout,status=0,expect_event=1
[48.077527] ACPI:EC: read timeout,command=128


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-06-27 12:01 

注册: 2008-05-16 11:26
帖子: 88
送出感谢: 0 次
接收感谢: 0 次
能说详细点吗?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-06-30 8:29 

注册: 2007-05-11 15:36
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
我的也是C22,昨天安装了8.04,安装时加参数noapci acpi=off,安装后正常进入桌面,然后进行更新,安装nvidia驱动。再在/boot/grub/menu.lst中,将kernel中ro后面的参数删掉,重启后acpi正常打开。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-07-18 10:33 

注册: 2008-04-26 1:17
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我的系统是进的去。拔了电源用电池是可以进系统的。
不知道如何才能打上补丁...要不让每次启动都要拔电源..


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译